help with Electric motors for engine.ini

Discussion in 'Car Modding' started by Gumball, Oct 15, 2019.

  1. Gumball

    Gumball Registered

    Joined:
    Sep 11, 2019
    Messages:
    15
    Likes Received:
    0
    Hi everyone,

    Tried to develop electric motor with the physics sheet and chris's online tools (the method where you just put the torque numbers in) but with no luck. Car doesnt move.
    Anyone tried to create EV powertrain with instant torque and single speed gearbox?
    whats the best approach?

    Thanks
     
  2. McFlex

    McFlex Registered

    Joined:
    Feb 23, 2012
    Messages:
    706
    Likes Received:
    156
    There should be no difference between electric an combustion engine. I mean it‘s just a torque curve. Have you tried to alter for example the skippy engine file to test if it‘s a problem of the engine.ini or the transmission?
     
    Gumball likes this.
  3. Tommy78

    Tommy78 Registered

    Joined:
    Apr 3, 2012
    Messages:
    544
    Likes Received:
    474
    There is a difference, because no idle on electric engine. I working on an electric engine as well, and almost everything good now, except the idle.
     
  4. Gumball

    Gumball Registered

    Joined:
    Sep 11, 2019
    Messages:
    15
    Likes Received:
    0
    Hi Mcflex. thanks for your reply
    Just tried w skippy.. it doesnt even rev (should it?, even if the transmission isnt working like irl :p). have tried changing clutch torque etc. im just missing something here i guess

    the torque curve for electric motor is slightly different. like they dont idle and have subtle characteristics like regen braking. was just wondering whether anyone managed to capture all these details
     
  5. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    940
    Likes Received:
    444
    Have you tried to contact chris?
    Maybe he can help to solve the problem.
     
  6. Gumball

    Gumball Registered

    Joined:
    Sep 11, 2019
    Messages:
    15
    Likes Received:
    0
    Hi Bernd, no. not yet. got things running though. still tweaking it.

    @Tommy78 mind to share the engine file if possible?
     
  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,668
    Likes Received:
    2,537
    Did S397 not give any info when they did the Formula E?
     
  8. Tommy78

    Tommy78 Registered

    Joined:
    Apr 3, 2012
    Messages:
    544
    Likes Received:
    474
    As i wrote above the only thing is the engine which is not correct because of the idle. So no point to share the engine because of this problem. The only thing which is "working" you can see Battery level instead of fuel level and eTorqueMap instead of engine map settings and Regen Mode instead of engine brake map.
    We need proper info about the electric engine and regenerate braking.
     

Share This Page