GTX970 settings after update

Discussion in 'General Discussion' started by DennisLionGP, Dec 30, 2017.

Tags:
  1. DennisLionGP

    DennisLionGP Registered

    Joined:
    Dec 30, 2017
    Messages:
    3
    Likes Received:
    0
    I have trouble with my frames after the update especially when the rain starts.
    What are the best settings with a EVGA GTX 970 and the RF2 in DX11?
    Running on 1920 x1080.
    Thanks
     
  2. ebeninca

    ebeninca Registered

    Joined:
    Sep 7, 2016
    Messages:
    472
    Likes Received:
    180
    GTX970
    i5 4690
    16GB Memory
    1080p
    Anti-aliasing level 3
    Post-Processing None

    20 Cars on the track, Sunny, FPS above 80 all the time.

    PS: I forced Auto FPS 84 on player.json, but it's not necessary.

    No problems with FPS, just CPU usage, it's another battle i'm having.

    upload_2017-12-30_20-50-47.png
     
  3. e270889o

    e270889o Registered

    Joined:
    Dec 24, 2017
    Messages:
    14
    Likes Received:
    4
    with triples, really difficult to get 60fps in rain with the 970
     
  4. ebeninca

    ebeninca Registered

    Joined:
    Sep 7, 2016
    Messages:
    472
    Likes Received:
    180
    Yes, for triples probably you will need a 1070.

    Updated after resolving the CPU usage problem..

    Keeping above 60 fps with rain and 20 AI.

    upload_2018-1-2_0-26-50.png
     
    Last edited: Jan 2, 2018
  5. DennisLionGP

    DennisLionGP Registered

    Joined:
    Dec 30, 2017
    Messages:
    3
    Likes Received:
    0
    Thanks I gone try that tonight.

    "Updated after resolving the CPU usage problem.."

    What did u do?
     
  6. dadaboomda

    dadaboomda Registered

    Joined:
    May 15, 2016
    Messages:
    709
    Likes Received:
    201
    I think he's talking about this bug :

    Check that your GPU is actually selected systematically at each rf2 boot, in the "config.ini UI on the launcher".

    GPU selected, NOT "Auto". Or disable your iGPU.
     
  7. dadaboomda

    dadaboomda Registered

    Joined:
    May 15, 2016
    Messages:
    709
    Likes Received:
    201
    GTX 780 is approximatively the same as GTX 970 (mine is OC +23 %) with pcie x16 2.0.

    DX11

    - AA = 4 (132cm at 52 cm : not too ugly. If your screen is smaller, try AA = 3
    - No PP
    - Vsync video
    - full HD

    - circuit = high
    - opponent = low (important for AI)
    - Player = high (when you drive, don't see difference with full...)
    - texture detail = high
    - Texture filtering = anisotropic x8
    - special effect = low (or medium, but for rain, better performance with low...)
    - Shadows = medium
    - blur = fast
    - Rain = low or medium
    - Soft particle = off
    - Road reflections = low
    - Environment reflection (car) = off (low is bad because it gives an impression of non smooth experience : so, it is off or high ;) )

    Nvidia driver :

    - All in default (game AA, game anisotropic etc.)
    - Performance
    - Max prerendered trames = input lag lower

    Ingame :

    - You can use auto detail FPS, good but AI are visually impacted (I don't use now).
    - time scale = off or x1 or low (preserve a lot the CPU, specially if you use shadows or play when sun is low in the sky.
    - realroad = x1 or low : more realistic and better for CPU, specially on rain.

    Think about making *STABLE* CPU and GPU overclocking
    Check throtteling (cooling) : create boost fans profiles (GPU and CPU) and open your PC tower.

    Optimize Windows + stop anti-virus
    GPU drivers
    Update Bios MB + optimise performance of the Bios
     
  8. ebeninca

    ebeninca Registered

    Joined:
    Sep 7, 2016
    Messages:
    472
    Likes Received:
    180
    Well, in my case i had to disable the core parking windows function. To know if you have this problem press ctrl+c while in the Track to see If the pink bar is getting higher then 75%
     
  9. dadaboomda

    dadaboomda Registered

    Joined:
    May 15, 2016
    Messages:
    709
    Likes Received:
    201
    Hello.

    I find that my CPU (i5 2500K OC + 15%) has significant difficulties from 8 AI, even if it remains perfectly playable even in the rain and with big shadows.

    The purple bar often exceeds 40%, and it happens that it reaches 100% and therefore that it lag (more than 12 AI).

    Can you explain to me what it is? From @Ari Antero's suggestion?

    Thank you.
     
  10. e270889o

    e270889o Registered

    Joined:
    Dec 24, 2017
    Messages:
    14
    Likes Received:
    4
    purple bar?
     
  11. dadaboomda

    dadaboomda Registered

    Joined:
    May 15, 2016
    Messages:
    709
    Likes Received:
    201
    When you click on "CTRL + C", that show the CPU performance.
     
  12. ebeninca

    ebeninca Registered

    Joined:
    Sep 7, 2016
    Messages:
    472
    Likes Received:
    180
    Because the complexity physics of rFactor2, the CPU gets overloaded when you put some AI in the track...

    Core parking is a windows functionality to power saving when you're not using all the CPU's capacity, but some times it can be tricky, even activating High Performance on power options. There are two ways to avoid this problem:

    - Disabling core parking functionality:



    upload_2018-1-2_16-45-13.png


    - Use Core park manager to force the use of all cores at his maximum speed.

    http://coderbag.com/Programming-C/CPU-core-parking-manager-v3
     
    Last edited: Jan 2, 2018
  13. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,263
    Likes Received:
    1,388
    Purple bar is normally around 50%, it should not go much above unless you add 40+ AI. With some modded cars physics are a bit broken so with those it's a different story. 100% CPU usage suggests either core parking issue or CPU overheating, which makes it automatically downclock.
     
  14. e270889o

    e270889o Registered

    Joined:
    Dec 24, 2017
    Messages:
    14
    Likes Received:
    4
    Thats what i thought. My cpu is always around 40%
     
  15. dadaboomda

    dadaboomda Registered

    Joined:
    May 15, 2016
    Messages:
    709
    Likes Received:
    201
    Ok I change the parameters of the registre key + install the software. thank's
     
  16. ebeninca

    ebeninca Registered

    Joined:
    Sep 7, 2016
    Messages:
    472
    Likes Received:
    180
    Solved your problem?
     

Share This Page