grafica pioggia

Discussion in 'rFactor 2 Support (Supporto Tecnico)' started by Daniele18, Mar 5, 2015.

  1. Daniele18

    Daniele18 Registered

    Joined:
    Nov 19, 2014
    Messages:
    76
    Likes Received:
    0
    Salve ragazzi ieri provavo nel mio server una pista ed è cominciata scendere la pioggia. Tutto molto bello e realistico, ma non capisco perchè non si crea la scia d'acqua diero l'auto. Sapete aiutarmi?
     
  2. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    In condizioni normali la scia d'acqua si inizia a formare dopo qualche minuto, il tempo necessario perché la superficie sia bagnata a sufficienza (quindi anche l'intensità della pioggia è un fattore), così come la scia continua a formarsi anche dopo che è smesso di piovere, fino a che la pista non si sia asciugata.

    Ho provato adesso mettendo su OFF gli Special Effects, ma la scia si vede lo stesso, quindi l'unica ipotesi è che le piste debbano avere implementata la scia (ma questo lo può dire con sicurezza Tuttle, io non sono un modder) e che la pista invece non la avesse implementata.

    Che pista era?
     
  3. Daniele18

    Daniele18 Registered

    Joined:
    Nov 19, 2014
    Messages:
    76
    Likes Received:
    0
    La pista è Road America, eventualmente per implementarla (chiedo a qualche modder) come si deve fare?
     
  4. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Se ti ricordi il nome esatto della pista, posso provare nel mio PC.

    Io ho installate:

    Road_America v1.0
    Road_America v1.01
    Road_ America
    Road_America_FFSCA99b
    Road_America v1.01sm
    RoadAmerica

    Spero che la tua sia una di quelle che ho già. :)
     
  5. Daniele18

    Daniele18 Registered

    Joined:
    Nov 19, 2014
    Messages:
    76
    Likes Received:
    0
  6. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    RoadAmerica v0.40 è una di quelle che avevo già ... per conferma, nella pagina di caricamento della pista in alto a destra c'è scritto v1.0, giusto?

    Se è quella, io la scia la vedo, almeno in Single Player.

    Hai provato altre piste, per vedere se ti capita con tutte?

    Anche, se il server è ancora online, come si chiama? Se ho la macchina, posso provare online.
     
  7. Daniele18

    Daniele18 Registered

    Joined:
    Nov 19, 2014
    Messages:
    76
    Likes Received:
    0
    la pista abbiamo mod le pubblicità, e la mod abbiamo le livree personalizzate.
    Se vuoi ti passo sia la mod che la pista modificata, mi faresti un gran favore ma non voglio rubarti troppo tempo. Dimmi tu...
     
    Last edited by a moderator: Mar 5, 2015
  8. Daniele18

    Daniele18 Registered

    Joined:
    Nov 19, 2014
    Messages:
    76
    Likes Received:
    0
    Allora ho provato in single player la scia la vedo..... Mha da cosa dipenderà?
    Premetto che nel server uso il weather tools
     
    Last edited by a moderator: Mar 5, 2015
  9. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Prima di passarmi i contenuti del server, il problema di non vedere la scia succede a tutti o solo a te?

    In single player la vedi ... sei certo che la quantità di pioggia era la stessa, tra single player e multi?
    Ovvero, se in multi pioveva meno, sei stato abbastanza tempo per lasciare che la pista si bagnasse?

    Da cosa può dipendere, se non appunto dal ritardo tra l'inizio della pioggia e quantità di acqua in pista tale da generare la scia, sinceramente non lo so.

    Per esclusione, se Tuttle legge spero che risponda, per sapere se la scia è una feature "hardcoded" o se riguarda qualche file, tipo il tdf.
     
  10. Daniele18

    Daniele18 Registered

    Joined:
    Nov 19, 2014
    Messages:
    76
    Likes Received:
    0
    la quantità era simile e ho provato anche l'inverso cioè più acqua in server e la scia non si vedeva cmq, in single player anche con un 20% di pioggia si vede la scia. Aspetto con ansia Tuttle.
     
  11. Tuttle

    Tuttle Technical Art Director - Env Lead Staff Member

    Joined:
    Feb 14, 2012
    Messages:
    2,480
    Likes Received:
    773
    La water spray funziona ovunque vi sia una corretta implementazione del Real Road e solitamente interviene dopo breve tempo dall'inizio della pioggia. Se in single player funziona e non in MP mi viene da pensare ai settings del server e/o ad eventuali situazioni di override da parte di qualche plugin.
     
  12. Daniele18

    Daniele18 Registered

    Joined:
    Nov 19, 2014
    Messages:
    76
    Likes Received:
    0
    Ciao tuttle, allora se in single player va benissimo pensavo anche io al setting in MP, ma cosa esattamente?
     
  13. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Tuttle, grazie per il chiarimento.

    In pratica, escludendo che sia la pista (se la scia offline c'è, mi pare di capire che RealRoad funzioni e che la sua tecnologia non faccia differenze tra single e multi player), sono poco propenso a credere che sia questione di impostazioni del server perché il server, nel file multiplayer.json, non si occupa di impostazioni grafiche.
    D'altra parte il player.json del server non consente di disabilitare RealRoad in retail mode (cioè si può disabilitare solo in Dev Mode) e queste sono le ragioni che mi fanno dubitare che la causa del problema siano le impostazioni.

    Per quanto riguarda il Weather Tool, io non lo uso e non lo conosco e quindi non ho idea se possa scavalcare le impostazioni grafiche in-game, cioè se possa nascondere il water spray.

    Per provare a capire, io proseguirei ad andare per esclusione.

    Escludendo, come Tuttle ci ha spiegato, che la causa sia nella pista, nei tuoi panni proverei

    1) a disinstallare temporaneamente il plugin, per controllare se senza di lui la scia c'è.

    2) a spostare temporaneamente i file multiplayer.json e player.json del server in una cartella temporanea, così che all'avvio successivo il server li ricrei con le impostazioni default, per controllare che il problema non sia causato effettivamente dall'edit di qualche linea di questi files.
     
  14. Daniele18

    Daniele18 Registered

    Joined:
    Nov 19, 2014
    Messages:
    76
    Likes Received:
    0
    senza plugin attivato la scia si vede sia in MP sia in SP
     
  15. Daniele18

    Daniele18 Registered

    Joined:
    Nov 19, 2014
    Messages:
    76
    Likes Received:
    0
    ah ragazzi forse ho trovato, nel palyer.jons c'è la voce rainspray ed era settata su 0 appena posso modifico e vi faccio sapere, magari è utile anche ad altri.
     
  16. Carra

    Carra Registered

    Joined:
    Jan 14, 2012
    Messages:
    844
    Likes Received:
    1
    noi usiamo il weather tool ma non abbiamo mai riscontrato problemi di scia le poche volte che ha piovuto
     
  17. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Penso che ti riferisci a questa linea

    "Rainspray Flow":0,
    "Rainspray Flow#":"Add to enable: 1=flow over current 2=flow over other vehicles",

    ma ho valore 0 anche io e vedo tranquillamente le scie sia offline che in multiplayer ... non so che cosa intendano esattamente con "flow", forse è un modo per cambiarne la visualizzazione, ma anche tenendo 0 la scia si vede ... e meno male hehe, perché dopo aver letto il tuo post mi era venuto il mal di pancia pensando ai possibili "cheat" e ai relativi malumori degli utenti. :)

    Per ora il punto fermo mi pare sia quello che senza plugin le scie ci sono.

    Come dicevo sopra non conosco il Weather Tool e non so se c'è un ini che rende configurabili queste cose.

    Eventualmente, il mio consiglio è di chiedere direttamente all'autore del plugin, in questo thread

    http://isiforums.net/f/showthread.php/11398-rFactor2-Weather-Tool
     
  18. Daniele18

    Daniele18 Registered

    Joined:
    Nov 19, 2014
    Messages:
    76
    Likes Received:
    0
    Allora Max nell'altro thread non risponde nessuno. Cmq se in MP disattivo il plugin Weather tool e imposto normalmente la pioggia non si vede cmq la scia, per questo penso che il plugin non influisca.
     
  19. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Nel post #14 avevi detto diversamente

    e su questo si basava il mio post precedente.

    Hai verificato se cambiando la linea del rainspray nel player non cambia niente?
    Io, come detto, ho il suo valore a 0 e le scie le vedo, ma non si mai, è sempre meglio provare personalmente.

    Se, come immagino, il player non influisce e se anche senza plugin non vedi le scie in multi, io proverei una soluzione radicale, disinstallando rF2 e reinstallandolo "fresco".
    Questo vuol dire eliminare manualmente le cartelle Data se le tieni separate dalle cartelle Core, ma fatti un backup della cartella Packages, così da evitare di riscaricare tutti i componenti.

    Una volta reinstallato, verifica prima che il rain spray funzioni senza plugin, poi prova con il plugin installato.
     
  20. Daniele18

    Daniele18 Registered

    Joined:
    Nov 19, 2014
    Messages:
    76
    Likes Received:
    0
    Infatto è quello che ho fatto e ti confermo che ora la scia d'acqua si vede.
     

Share This Page