GP79 conversion with permission

Discussion in 'Vehicles' started by Arnao, Dec 27, 2012.

  1. Hazi

    Hazi Registered

    Joined:
    Jan 15, 2012
    Messages:
    872
    Likes Received:
    129
    Got strange shadows flickering/growing bigger on ground from outside some cars on LRP and on the new Fuji 1.04 I get white breakmarkers in some turns (tested with Corvette where there the markers were black again).
    No Blackouts on LRP and Fuji with Lotus.
    New full RF2 install, only GP79 as additional mod, new GF 680GTX 4GB
     
  2. hoover

    hoover Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,177
    Likes Received:
    190
    Thanks for changing the class names to something more descriptive. I've now added the Wolf to rF2 Rank, can you provide a list of car class names?

    All the best & keep up the good work!

    Uwe
     
  3. Arnao

    Arnao Registered

    Joined:
    Nov 23, 2010
    Messages:
    338
    Likes Received:
    27
    CATEGORIE 1979_un
    CLASS:
    -GP79_Alfa
    -GP79_arrows
    -GP79_ATS
    -GP79_brabham
    -GP79_Ensign
    -GP79_ferrari
    -GP79_fittipaldi
    -GP79_kauhsen
    -GP79_ligier
    -GP79_lotus
    -GP79_mclaren
    -GP79_merzario
    -GP79_rebaque
    -GP79_renault
    -GP79_shadow
    -GP79_tyrrell
    -GP79_williams
    -GP79_wolf

    I've looking on what I did wrong for class naming but can't find some info about Category Classes and AI classes.
    So for now... I've modify each VEH by adding:
    -
    Code:
    AIUpgradeClass=GP79_xxxxx
    -
    Code:
    Classes="1979_un, GP79_xxxxx"
    And change upgrade files with this lines...
    Code:
    UpgradeClass="GP79_xxxxx"
     {
     AIList
     {
     Model=0
     Model=1
     Model=2
     Model=3
       }
     }
    Maybe I did something wrong here and may have to do class for each chassis...
    Code:
    UpgradeClass="GP79_FERRARI_T4_1"
     {
     AIList
     {
     Model=0
    }
     }
    UpgradeClass="GP79_FERRARI_T4_2"
     {
     AIList
     {
     Model=1
     }
     }
    
    UpgradeClass="GP79_FERRARI_T3_1"
     {
     AIList
     {
     Model=3
     }
     }
    
    etc 
    etc
    Maybe it's better to wait to add 79 in your rank system Uwe...

    If someone have good documentation about class system and AIupgradeclass he is welcome to share...
     
  4. Arnao

    Arnao Registered

    Joined:
    Nov 23, 2010
    Messages:
    338
    Likes Received:
    27
    We may have to ask to ISI what is going wrong with our mod...
    As an ATI user we did not managed to reproduce this issue so for now we are a bit stuck... It's certainly come from undershadow square we add on tyrrell and lotus but can't really see what we did wrong...maybe an option to tick in exporter.
    Hope we will get it soon...
     
  5. samuelw

    samuelw Registered

    Joined:
    Jul 23, 2012
    Messages:
    161
    Likes Received:
    4
    First of all the physics for this mod are outstanding. Second the new cockpits really look great and fix the one glaring fault in the original mod. However, at least for me, there are four serious bugs. I've mostly tested at Brianza where I've noticed the bugs. Cirrently I'm running a 60 deg FOwhich previouslt exacerbated the black screen bug on my system. My system specs are in my profile. 1. The black screen bug has morphed into a dark screen bug. I can almost eliminate the dark screens by moving the drivers seat back. However this does not look realistic and there is a loss of imersion. 2. Periodically my car slows qhile the AI continue on and drive away. This is new and I have yet to figure out a pattern. 3. As others have mentioned I see flickering polygonal shadows. 4. When overtaking sometimes the AI cars oscillate in size but not always.

    GP79 is my favorite mod. I hope you can get it fixed.
    SW
     
  6. gabriel666

    gabriel666 Registered

    Joined:
    Jan 15, 2012
    Messages:
    204
    Likes Received:
    0
    Guys found what would seem a failure, I'm not sure ... but I would like to try it out. in Nords when I leave pit..., my car moving as slow motion, able to install something wrong (?), but as I did not see if you have already posted this mishap was the communicate, excuse my English ;)
     
  7. hoover

    hoover Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,177
    Likes Received:
    190
    I have the same slowdown effect, if you watch the gpu / cpu graphs the bottom one goes really wonky (also on Nordschleife)

    I'm also seeing the triangular black flickering shadows when the AI cars pass me.

    Uwe
     
  8. Hedlund_90

    Hedlund_90 Registered

    Joined:
    Apr 12, 2012
    Messages:
    1,683
    Likes Received:
    41
    Yes, I have also noticed the "slow motion bug" at Nordschleife. Feels like driving 10 km/h when going 100 km/h ;)

    As it seems, this only happens with the new cockpits. I can't say for sure, but it happened with both Tyrell and Lotus, and when I tried with one of the other cars (old cockpits), it worked as it should.
     
  9. Arnao

    Arnao Registered

    Joined:
    Nov 23, 2010
    Messages:
    338
    Likes Received:
    27
    Got slow motion too still first released with 29 AI on Belgium66 track... limit of 10 AI has no more slow motion effect... I really do not know where it come from... Maybe too much different car so too much Physics to be calculed or too much differents textures to load...

    For triangular things It's maybe from new way we have done shadow. Maybe we used a wrong texture for the shadow plane.

    Thanks guys for report and help
     
  10. jimcarrel

    jimcarrel Registered

    Joined:
    Jan 15, 2012
    Messages:
    1,720
    Likes Received:
    24
    With the small problems, it is still a mighty FINE mod. I'm sure things will get fixed. Nords is also an un-optimized WIP. Lots of calculations going on.
     
  11. gabriel666

    gabriel666 Registered

    Joined:
    Jan 15, 2012
    Messages:
    204
    Likes Received:
    0
    Is like Hedlund says on the cockpits. but just try with those who are not update, and while walking quite well...for moments like that is put into slow motion in very short periods, in different sectors of the track
     
  12. Arnao

    Arnao Registered

    Joined:
    Nov 23, 2010
    Messages:
    338
    Likes Received:
    27
    Hi,

    I need someone to test a quick update to see if "flickering polygonal shadows" are still there ???
    I 'll PM you a quick update link !!


    Edit: The only strange things I got is this strange black mark that you can see on ground !!!
    [​IMG]
     
    Last edited by a moderator: Nov 21, 2013
  13. jimcarrel

    jimcarrel Registered

    Joined:
    Jan 15, 2012
    Messages:
    1,720
    Likes Received:
    24
    Ran Brianza, both cars, each model. In driving and replay, did not see any anomalies.
    Ran 4 laps each.
    GeForce 650 TI Boost 2Gig.

    Looking good on my setup.

    OT - Had it happen twice where car bodies locked inside of each other. Once for each test model.
    I've had all open wheelers lock wheels occasionally, but this instance was "chassis" not wheels.
     
  14. samuelw

    samuelw Registered

    Joined:
    Jul 23, 2012
    Messages:
    161
    Likes Received:
    4
    maybe setting pre-rendered frames to 1 stops slow down. Works so far for me with fingers crossed. Nordschleif running smooth with pre-rendered frames set to 0. Someone on this board suggested this some time ago. Seems to help with dark screens 2.
    sw
     
  15. Arnao

    Arnao Registered

    Joined:
    Nov 23, 2010
    Messages:
    338
    Likes Received:
    27
    GP79_CAR_V0.432_fix.rfcmp

    -SHADOW ISSUE WITH TYRRELL 009 AND LOTUS 79 ARE FIXED
    -BT49 CHASSIS FLEX ERROR IS FIXED...

    This do not fix TYRRELL BLACK SCREEN FLICKERING FOR SOME NVIDIA USER

    Install:
    You need to have GP79_UNRESTRICTED 0.43 INSTALLED

    -Copy fix into your package folder
    -Update GP79_CAR

    Any feedbacks are welcome
     
  16. tjc

    tjc Registered

    Joined:
    Jun 4, 2012
    Messages:
    5,860
    Likes Received:
    340
    Cheers. :)
     
  17. jimcarrel

    jimcarrel Registered

    Joined:
    Jan 15, 2012
    Messages:
    1,720
    Likes Received:
    24
    It appears to be the same file I already have, is that true??
     
  18. Arnao

    Arnao Registered

    Joined:
    Nov 23, 2010
    Messages:
    338
    Likes Received:
    27
    No Jim sorry it's a new one

    BT49 was not fixed in your
     
  19. jimcarrel

    jimcarrel Registered

    Joined:
    Jan 15, 2012
    Messages:
    1,720
    Likes Received:
    24
    Okay, now downloading...Thanks
     
  20. Adrianstealth

    Adrianstealth Registered

    Joined:
    May 28, 2012
    Messages:
    4,545
    Likes Received:
    1,051
    Hiya

    Glad to see this project still on going, have they had any physics etc updates for rf2 since 1st launch for rf2 ??
     

Share This Page