GetMod Manager

Discussion in 'Component and Mod Packaging' started by Noel Hibbard, May 3, 2014.

  1. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    36
    Yep... once the rfcmp is marked as registered and you build the vmod, you can then change the registered URLs without rebuilding the vmod.
     
  2. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    3,026
    Likes Received:
    391
    I found the ssl switch in the account settings only. But i got this too, ssl off, checked the downoad is working, went back to MF, looked into settings, it was on again. But for now it`s seems off and it never switched back to ssl on. Logged in 5-6 times, everytime it was off.
     
  3. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    36
    I don't see the SSL option in "Account Settings". I only see it when clicking on my name. But I think I figured out what keeps turning it back on. You can turn it off and go in and out of your account and it stays off. But as soon as you go into "Account Settings" it is forced back on. I guess because you are dealing with passwords and stuff they want to make sure you are using SSL. But it shouldn't globally change SSL back to on just because you went into the Account Settings. That is stupid. So we have to remember to turn SSL back off when done playing in Account Settings or else it will break our GetMod links.

    But, even with SSL off, MF still isn't working that well with rF2. I think this is because of the delay MF has sometimes with doing the redirect. rF2 has a very short timeout and MF seems to exceed that time out 6 times out of 10.
     
  4. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,425
    Hi Noel,

    The tool is really nice and easy to use. However I don't know if I did something wrong because it is not working correctly according to reports from the drivers in the champ I host.
    They get downloads with same file size but different component name. They check this because I asked them. They get an error after the downloads. You can test at Racerfactor RRTCC. It is supposed to download everything. I had to break the civic multicomponent to do it.

    I would also suggest you activate the email part to reset the password. You will end up with trillions of usernames which we will easily forget and create a new one.... I think you understand what I am explaining like s__t. You are a ver smart guy.

    enviado mediante tapatalk
     
  5. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    36
    It's possible your webhost is doing a browser side redirect which rF2 doesn't support. So it ends up downloading what it thinks is an rfcmp but actually it is just a small HTML file. Let me take a look at your account and see if I can figure it out.

    Edit: I looked at your links and your webhost is doing a redirect but it is a standard 301 redirect so I would have expected it to work fine. To avoid the redirect, try removing www from the URLs. That way it goes directly to the final destination. One thing that would be really helpful is if you opened up the rfcmp file that is being downloaded with a text editor to see if it is actually an HTML file. If it is, it will normally give some hints. Unfortunately I don't have control over the process once my service redirects to the URL you provide. After I do the redirect it is all in ISI's hands. Their HTTP client doesn't support cookies, HTTPS, javascript ect ect.
     
    Last edited by a moderator: May 9, 2014
  6. MK3424

    MK3424 Registered

    Joined:
    Apr 24, 2014
    Messages:
    14
    Likes Received:
    0
    I have a small problem: i can't login: i've set the right password and typed it several times but it won't let me in and sais that the password is incorrect.
    Is there a way to reset your account's password?
     
  7. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,425
    Solved removing the "www" from the links. Thanks Noel.

    enviado mediante tapatalk
     
  8. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    828
    New tool works fine and it is simple to use.

    Thank you Noel, good job :)
     
  9. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,738
    Likes Received:
    776
    Unless no one has mentioned before, just a small thing really. The chooser dialog to set username and password has no taskbar button.
     
  10. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    36
    Actually I just noticed this myself the other day and forgot to fix it. I will do that now. Thanks for the reminder.
     
  11. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    36
    All done.
     
  12. Denstjiro

    Denstjiro Registered

    Joined:
    Oct 6, 2010
    Messages:
    2,952
    Likes Received:
    14
    Noel the getmod manager gives an error on our server (not a valid Win32 application)

    So what I did was add the new sebring to dropbox, added the link to the new .rfcmp via GMM locally, registered it and created the vmod locally as well and uploaded/installed them on the server.

    You think that is a valid workaround?
     
  13. Denstjiro

    Denstjiro Registered

    Joined:
    Oct 6, 2010
    Messages:
    2,952
    Likes Received:
    14
    Oh and btw, I can see my hits on your site. when I check the url it leads to the dropbox file. so all is well.

    but when uninstalling the vmod/track locally and joining server in order to see if it works, it does download it but wont let me access server.
    so I check the mod manager and the track is installed, but its the one you created which links to virtua LM instead of dropbox. vmod states I need the correct track.

    so once again I've managed to confuse myself. if you're getting tired of this just say so. no problem for me to just let it slide.
     
    Last edited by a moderator: May 14, 2014
  14. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    36
    GMM requires DotNet4.0. My guess is you don't have it on your server. Running my tool and building a vmod from another computer and then installing the content and vmod on the server is a perfectly acceptable work around.

    I am unsure of why you can't join your server. It is expected for the track that is downloaded from the server to be the original track which I fixed for you yesterday with the VLM URL in it. The way my tool works is it modifies the "Installed" component, not the original rfcmp. This is all that is needed to get the correct URL embedded into the vmod. The rfcmp that you host is actually unmodified so it will still show the bad GetMod URL. But this is fine, the correct URL is stored in your vmod. You should have been able to join without a problem.

    Shoot me a PM with the details of your server and maybe I can connect myself to see if I can spot any problems.

    BTW, no, you aren't bothering me. :)
     
  15. Denstjiro

    Denstjiro Registered

    Joined:
    Oct 6, 2010
    Messages:
    2,952
    Likes Received:
    14
    Ah yes of course, url in vmod, not rfcmp. ah well, did something right for once :)

    I will wait and see what members report upon joining and tbh i'm kinda done with this event already. a simple single event should not take up so much time, if I keep at it I will just lose motivation in general as I am stretched with that on all things rf2 as it is, so best if I save some of the remaining positives for when its actually important :)
     
  16. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    36
    Nevermind, I found your server and was able to get your vmod and install it so I can see what the list of sigs was that were included. I found your problem. The sig for the component that your GetMod URL points to is 0561b36c8e806ace09d4ee2abc58a741cbd173b28583ceea77a0954ebc36f909 but the sig that your vmod is requesting is 35583ad38417a135bc002b29c24df72a178a4b8622a7725a9f0a7d12e8e8d296. My guess is you have done a hand swap on the two attempts I made yesterday to patch the track for you.

    To be sure you have it all straight, download a fresh copy of the track using the URL I sent you yesterday. The sig on the final fixed track should be 0561b36c8e806ace09d4ee2abc58a741cbd173b28583ceea77a0954ebc36f909. Make sure you install this version on your server and on what ever machine you use with my tool and to build the vmod. Also make sure that this is the version you have hosted and have your registration pointed to. I probably should have incremented the version number with my two patches so this confusion would be avoided.

    Edit: Nevermind, scratch my directions above. This vmod should work for you:
    https://www.dropbox.com/s/0eezb3zuckyl41u/Nissan GTR - Camaro - Corvette.rfmod

    Just make sure your server has the 0561b36c8e806ace09d4ee2abc58a741cbd173b28583ceea77a0954ebc36f909 Sebring installed. Your host has the correct version and your GetMod reg is fine. You just need that version installed on your server along with this vmod. Also, I incremented the version number of your vmod to 1.1.
     
    Last edited by a moderator: May 14, 2014
  17. Denstjiro

    Denstjiro Registered

    Joined:
    Oct 6, 2010
    Messages:
    2,952
    Likes Received:
    14
    Ok man, I give up. I think i'm just not smart enough and should accept reality instead of fighting it.

    just to inform you, removed my version of track and vmod from server, uploaded yours, installed them, launched server. to find out you only added 2 of the 3 cars.
    so, went back locally and tried to create a new vmod (locally also removed old/added new) only to find out that the sig was ending in 7864eeeb6b2 and not a0954ebc36f909
    By this time I already gave in and decided to just use your stuff and 2 cars, screw it.

    uninstalled locally to test getmod, now its not even downloading, it does state i'm missing the track and I click accept but nawt happens.

    Please don't create a new vmod for me or anything else to assist, i'm not going to try anymore.
    Good thing as well this happens now, and the reason I kept at it, because now I know I can safe myself the frustration in the upcoming championship and skip this whole routine, just load stuff as per normal and if peeps cant getmod, tough luck.

    rf2 is actually bringing down my self esteem with the amount of things I am encountering now that I am diving deeper into it. I mean just take the sebring issue or the troubles with skins, that is just taking the piss somehow, I was already frustrated, now i am starting to genuinely dislike this whole thing.
    And fwiw, I know i'm not stupid, sure, things might not be as slick as guys like you but I usually get around after a while. I've survived years of rf1 adminning so that has to speak for something.
    But just imagine the amount of crap new admins, novice users etc are encountering on a daily basis. I know you complained about admins not 'getting' it when you explained stuff many times and you told me it might have been the way you explain things. well guess what, its not you, its the retarded system in general. no cool programs you or anyone creates will take that away. ISI has shot themselves in the foot in trying to be smart.

    Thx allot anyways Noel, Lord knows you tried and I just hope the fella's in your league appreciate the fact that they have a real gem amongst their mids. heck, I might even join your league because I am so longing to be just a member and show up and race. that's all I want really.

    whats the url of your league?
     
    Last edited by a moderator: May 14, 2014
  18. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    36
    You had the wrong version of my fix registered with GetMod. I didn't notice that the first time I looked. I just removed the old reg and then added the reg for the correct track. I can now join your server fine. But like you said, I missed the C6R. Duh.

    I added the C6R to the vmod. 1.2 is here:
    https://www.dropbox.com/s/0eezb3zuckyl41u/Nissan GTR - Camaro - Corvette.rfmod

    And the URL for the league I am in is here:
    VirtualEndurance.net

    Our next race is June 7th and it is 24 hours (realtime) at Le Mans.
     
    Last edited by a moderator: May 14, 2014
  19. Denstjiro

    Denstjiro Registered

    Joined:
    Oct 6, 2010
    Messages:
    2,952
    Likes Received:
    14
    Arg endurance racing. not my cup of tea. shame because it sure looks like a slick organisation :)
     
  20. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    36
    I am working on an update that will improve the way the "Packager" button works. When I am finish, the Packager button will actually build a vmod for you. It will work like this, you highlight all the components you want to include in your vmod and then click the Packager button. It then pops up a dialog asking for some basic info:
    Mod Name (this will default to the one you used last)
    Version Number (this will default to the date Ex: 14.0516 and if you build a second one for the same day it will auto increment it to 14.05161. You can also type in what ever version you want. The date has been working really well for me.)
    Author Name (which will default to what you used last)
    URL (This defaults to what you used last. And has nothing to do with GetMod)
    Output folder (defaults to what you used last and the filename will be the ModName but with spaces replaced with _)
    Path to a DDS Icon (defaults to what you used last and can be left blank if you don't have an icon)

    Then you click okay and out comes a vmod.

    For now it is going to include all cars for each component and all track layouts for each track.
     

Share This Page