GetMod Manager

Discussion in 'Component and Mod Packaging' started by Noel Hibbard, May 3, 2014.

  1. endonesia

    endonesia Registered

    Joined:
    Oct 5, 2010
    Messages:
    79
    Likes Received:
    0
    Thanks for the update Noel.

    2 things:

    The 'unregister' button doesn't seem to move with the frame if you expand it.

    Is there any way to make it so that when the GetMod refreshes after registering a component, that it would remember what line I was working on and go back to that once refreshed, instead of starting at the top? Sort of like the ISI Package Mgr does after installing a component.
     
  2. Daiman Patel

    Daiman Patel Registered

    Joined:
    Jan 10, 2014
    Messages:
    21
    Likes Received:
    3
    Ah yes, I did miss it. Thanks again! :)

    UPDATE:
    Still no joy unfortunately. My guess is that it's something to do with the server. If I try to run the tool from the Bin32 folder then it still doesn't allow me to select a DataPath; for me the tool has to be in the root installation folder to successfully select a DataPath, but then of course your vMod builder doesn't work.
     
    Last edited by a moderator: Oct 1, 2015
  3. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    32
    Are you sure you are running it from the Bin32 folder? I know that stack trace you posted before showed it was running from a folder named rFactor Apps or something like that. The tool can't determine what rf2 build you are on unless you run it from the Bin32 folder. If it can't determine the build number then it treats it like an older build.

    Edit: Sorry. I missed your edit. I guess I need to add some sort of debug logging because I have no clue what could be going wrong for you. It's working perfectly for me on several builds, installs on multiple computers. It isn't the server side. That is running fine now.
     
  4. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    32
    Yeah I can do both of these tomorrow.
     
  5. Daiman Patel

    Daiman Patel Registered

    Joined:
    Jan 10, 2014
    Messages:
    21
    Likes Received:
    3
    Sorry, I meant the server on my side which houses the rF2 installs. Seems very strange. Might potentially be a permissions issue, or something; the application may not have the correct privileges to access the install directory. However, this doesn't explain why it still doesn't work when attempting to run it from the Bin32 folder. I'll have to try a few things over the weekend, and maybe even perform a clean re-install of all rF2 instances on my server.
     
  6. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    32

    Okay.. this is a little convoluted and hard to explain but here we go. As you know some people put the core and datapath in one combined folder. Some people install the core in one path and the datapath in another. Some people install the core and datapath in one folder and then copy that whole folder to another folder to create a second installation (I suspect this is what you have done). So to accommodate for all these options, when you select a path it first looks for the existence of .\Core\data.path (which would only exist in a combined core/datapath or a discrete core folder) and if it exists it redirects to that as your datapath. If the file doesn't exist it considers it a discrete datapath and not a combined core/datapath and uses the selected path as your datapath. If you copy an existing core/datapath install to another location and don't update the data.path file to point to the new path then my tool reads that file and finds a bad path and will not add it to the drop down.

    So... to prove this theory, could you open .\Core\data.path and make sure it's pointing to the right path?

    So say you have your core and datapath installed to this folder:
    C:\rF2Server1

    Then if you open "C:\rF2Server1\Core\data.path" in notepad it should contain a single line which reads "C:\rF2Server1". If not then that is your problem.

    I need to rewrite all this logic a little. The problem with rF2 is it is so open and has so many install methods that making a one size fits all tool without bugs is nearly impossible. But I will keep at it as new scenarios arise.
     
  7. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    32
    Sorry for the delay. I know I said I would get to this last week but I got busy on some other stuff. Anyways 10.1.1.23 fixed the issues you reported. The funny thing is I had already started writing the logic to restore the scroll location and selected items. I had the logic to store the location and selection before refreshing but must have been distracted and never added the logic to restore the selection/position after the refresh.
     
  8. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    32
    When are you getting the error message? To me it looks like it's when your closing the app.
     
  9. TOCA2FREAK

    TOCA2FREAK Registered

    Joined:
    Apr 6, 2011
    Messages:
    924
    Likes Received:
    124
    Hi Noel. I noticed this tool has stopped working today. Yesterday was fine. Below is error message.

    Code:
    See the end of this message for details on invoking 
    just-in-time (JIT) debugging instead of this dialog box.
    
    ************** Exception Text **************
    System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 173.8.60.243:80
       at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
       at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)
       --- End of inner exception stack trace ---
       at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
       at System.Net.WebClient.DownloadString(Uri address)
       at rFactor2_Mod_Manager_Plus.Form1.Form1_Load(Object sender, EventArgs e)
       at System.EventHandler.Invoke(Object sender, EventArgs e)
       at System.Windows.Forms.Form.OnLoad(EventArgs e)
       at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
       at System.Windows.Forms.Control.CreateControl()
       at System.Windows.Forms.Control.WmShowWindow(Message& m)
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.Form.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    
    
    ************** Loaded Assemblies **************
    mscorlib
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.34003 built by: FX45W81RTMGDR
        CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
    ----------------------------------------
    GetModMgr
        Assembly Version: 1.0.0.23
        Win32 Version: 1.0.0.23
        CodeBase: file:///C:/Users/Administrator/Desktop/GetModMgr.exe
    ----------------------------------------
    Microsoft.VisualBasic
        Assembly Version: 10.0.0.0
        Win32 Version: 12.0.20806.33440 built by: FX45W81RTMREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
    ----------------------------------------
    System
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.34003 built by: FX45W81RTMGDR
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Core
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
    ----------------------------------------
    System.Windows.Forms
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System.Drawing
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System.Runtime.Remoting
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
    ----------------------------------------
    System.Web
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_64/System.Web/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Web.dll
    ----------------------------------------
    System.Web.Extensions
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.33440
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Web.Extensions/v4.0_4.0.0.0__31bf3856ad364e35/System.Web.Extensions.dll
    ----------------------------------------
    System.Configuration
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
    ----------------------------------------
    System.Xml
        Assembly Version: 4.0.0.0
        Win32 Version: 4.0.30319.33440 built by: FX45W81RTMREL
        CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
    ----------------------------------------
    
    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.
    
    For example:
    
    <configuration>
        <system.windows.forms jitDebugging="true" />
    </configuration>
    
    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.
     
  10. TPG

    TPG Registered

    Joined:
    Mar 12, 2014
    Messages:
    409
    Likes Received:
    2
    I got the same error a few days ago..however I was still able to open the program but I had to re-define the path to my rFactor2 install.
     
  11. André Martins

    André Martins Registered

    Joined:
    Jul 16, 2015
    Messages:
    18
    Likes Received:
    0
    Hi Noel, thanks for excellent tool.
    Here everything worked out, but the download vmod this very slow. I'm using dropbox and the two rfcmp files are downloaded in 30 seconds but within the matchmaker rf2 takes almost 10 minutes to download. Any solution??

    Test in league Brasil Drivers - 4fun
     
  12. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    32
    The vmod is hosted on your race server and is heavily throttled to prevent it from impacting people that are racing on the server. There is no way to improve this speed. All you can do is reduce the size of the vmod. The default dds icons that are generated by mas2 are very big. If you use the default icons you end up with a 4MB rfmod file. At VEC we use our own custom icons which dropped the size of our vmod to 31kb. Also, it's possible you have included content in your vmod. When you select the components to include in your vmod, make sure all the check boxes are unchecked.
     
  13. André Martins

    André Martins Registered

    Joined:
    Jul 16, 2015
    Messages:
    18
    Likes Received:
    0
    I was leaving all vmod marked boxes. now it became much lighter and a little faster.

    thank you.
     
  14. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    32
    When the boxes are checked that tells it to embed the actual content in the rfmod. If they are unchecked it simply includes a reference to the content and it uses the GetMod links to download the content from Dropbox.
     
  15. AlanBernardo

    AlanBernardo Registered

    Joined:
    Jan 10, 2012
    Messages:
    148
    Likes Received:
    0
    Hello!

    The directory system between the Steam version of rF2 and the non-Steam version are of course different.

    Are there any differences between Steam and non-Steam versions of rF2 when setting up GetModMgr?

    I mean, it's easy enough with the non-Steam version of rF2, but with the Steam version I'm running into problems with setting the path and then linking the files. The files for the locations and tracks seem to be in directories and not in one single rfcmp file.

    How am I to approach working with GetModMgr and the Steam version of rf2?
     
  16. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    554
    Likes Received:
    63
    First time I have tried this, at first it wouldnt work...said it had downloaded the rfcmp but couldnt install...check the URL validity type message. The file had downloaded, but was 0b in size.

    That was hosting the files on my own webspace......running the links i out in getmod manager in chrome, the files would download, but for some reason, jsut wouldnt work through getmod.

    Solved by using dropbox, but havent got much space on there..

    I have plent of btcoud storage available, but that is https, so havent tried it yet as read earlier that wont work.
     
  17. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    32
    Actually https works with GetMod now. I'm not sure why your own webhost wouldn't work though. As long as it's a direct link without any JavaScript trickery, it should work.
     
  18. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    32
    I haven't tested my tool with a steam install. I will try to look into that this week. I suspect it's an easy fix though.
     
  19. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    554
    Likes Received:
    63
    Ok thanks Noel...I'll give it another try later


    Sent from my SM-N9005 using Tapatalk
     
  20. aerobaticrug

    aerobaticrug Registered

    Joined:
    Dec 27, 2012
    Messages:
    203
    Likes Received:
    5
    I have it working with Steam install. Needed to change the datapath in the core file (can't remember what it was called off hand) it was pointing to .\ instead of the rf2 path

    Sent from my Nexus 6 using Tapatalk
     

Share This Page