"Get mod" broken after 770 ..

Discussion in 'Hosting Help' started by kro388th, Jul 3, 2014.

  1. kro388th

    kro388th Registered

    Joined:
    Jan 10, 2012
    Messages:
    648
    Likes Received:
    31
    Build 770 My "get mod" seems to be broken on my desktop server , after the update clients get an instant mod fail msg ,you know it jumps right to cannot install mod bla bla without even trying , re chked ports looked in the new MP.json and found this line>

    "Enable Autodownloads":true,
    "Enable Autodownloads#":"Whether to allow clients to autodownload files that they are missing.",

    I was set to false so I changed it to true but no change in get mod ..
    I cant even find a " get mod" " allow or what ever its called now" line in the mp.json .. ;-/

    It has worked like a champ for over a year .. content downloads worked as well ...
    ..
    Is ther a new line im missing some ware?

    any help ?
     
  2. WiZPER

    WiZPER Member

    Joined:
    Oct 5, 2010
    Messages:
    1,521
    Likes Received:
    186
    It DOES work, our league set up 770 servers yesterday.
     
  3. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    556
    Likes Received:
    63
    What you mean is ...it works for YOU :rolleyes:

    I am having the same problem as OP, it worked fine until 770, and my MP json is set at true for autodownloads, and that hasnt changed.
     
  4. WiZPER

    WiZPER Member

    Joined:
    Oct 5, 2010
    Messages:
    1,521
    Likes Received:
    186
    Minimalistic UI has been reported to cause issues, could this be it ?
     
  5. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    556
    Likes Received:
    63
    I wish it was...I'm using the standard ISI Ui :(
     
  6. WiZPER

    WiZPER Member

    Joined:
    Oct 5, 2010
    Messages:
    1,521
    Likes Received:
    186
    And you are hosting the same content, which has GetMod URLs defined ?
     
  7. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    32
    Make sure the vmod is located in the "default" Packages folder BEFORE launching the server. The default location is <DataPath>\Packages. I loaded a clean 770 install yesterday and didn't change a single line in the mp.json or player.json. All I did was install the content and put the vmod in the packages folder and it worked fine. We have also "updated" a server where it converted our INI files and that server works fine too. The only known problem I know of is with the minimalist UI. Other than that it's just the typical issues that people have been having all along.

    http://youtu.be/9aVkqe5YcO4
     
  8. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    556
    Likes Received:
    63
    Sorry i might be confusing this. I have the content on my host that the server is running but it's the vmod that's failing to download.
     
  9. kro388th

    kro388th Registered

    Joined:
    Jan 10, 2012
    Messages:
    648
    Likes Received:
    31
    Thx guys , default UI here as well , I created the vmod as I alwase do with mas2 ,package then Install ,I also use default locations with my installs . Very strange ...
     
  10. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    556
    Likes Received:
    63
    My server is setup default so yes that's where the vmod is.
    But my client has package folder on a separate drive.

    I believed that was the best way to do it in order to save space on my ssd.....
     
  11. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    32
    Make sure your vmod filename does not contain a space. That bug was fixed but it sounds like it is back according to some other reports.

    As for SSDs and the packages folder. GetMod is hardcoded to <DataPath>\Packages. So if your datapath is on your SSD then that is what GetMod will use.
     
  12. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    556
    Likes Received:
    63
    I think I may be getting somewhere now.
    I tried connecting to a few open servers in the list.

    All of them downloaded and installed the vmod.
    A couple of them downloaded and installed the missing components. The ones that didnt said broken links etc, so nothing to worry about?

    My packages folder in mod manager and player.json is set at non default "Package Dir":"G:\\rFactor2\\Packages",
    The new packages were downloaded to the default "Package Dir":"D:\\rFactor2\\Packages",
    Again, no problem there.

    SO I tried to connect to my two servers, and straight away "mod download failed"
    They are passworded servers, so I removed the passwords, made sure there were no traces of the vmod etc in any folders and tried again.
    I still cannot get the vmod from my servers.

    I have set this "Enable Autodownloads":true,



    So, it looks like a problem with my server settings.
    Incidentally one server is on the same network as me the other is based in Ireland....
     
  13. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    556
    Likes Received:
    63
    Yep, both vmods im trying have spaces....will repackage now and retest
     
  14. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    556
    Likes Received:
    63
    Thank you very much Noel :)

    I repackaged, with no spaces and all is working again :D
     
  15. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    32
    Cool. Thanks for the conformation. Hopefully the word spreads quickly that this is something to watch out for.

    Out of curiosity, did you strip spaces from the mod name or just the filename?
     
  16. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    556
    Likes Received:
    63
    To be honest...Im no expert...
    When I get the initial prompt for mod name thats where I made sure there were no spaces....after that I just followed through to the end, after adding my components and saved it
    HTH
     
  17. kro388th

    kro388th Registered

    Joined:
    Jan 10, 2012
    Messages:
    648
    Likes Received:
    31
    Good to here , tonight I will try mine with no spaces and try to comfirm .. while were at itthought ide mention Im also using the 64 bit exe also editing the rfm in mas2 to set oval rules for up comming indy race ..
     
  18. kro388th

    kro388th Registered

    Joined:
    Jan 10, 2012
    Messages:
    648
    Likes Received:
    31
    No spaces bug is back Confirmed ! .. re did vmod with no spaces (in mod name only if wondering) .. get mod now working !
     
  19. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,830
    Likes Received:
    611
    On my server with password, I have a vmod without space in the name and the GetMod fail. So it's not only a "space" problem.
     
  20. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    The same issue was reported in the italian sub-forum.
    The fix was to delete the server player(s) and let rF2 rebuild a new single json player (well, the italian user deleted the whole player folder, but i guess that deleting the plr and the json is enough to fix the issue). :).

    Hope it can help.
     

Share This Page