Game freeze when driver disconnect

Discussion in 'Bug Reports' started by caterkiller, Nov 22, 2016.

  1. Nicolas Pailhes

    Nicolas Pailhes Registered

    Joined:
    Jul 14, 2012
    Messages:
    60
    Likes Received:
    2
    Last edited: Feb 26, 2017
  2. caterkiller

    caterkiller Registered

    Joined:
    Oct 7, 2010
    Messages:
    88
    Likes Received:
    15
    But that happens. Proof with our race with the SuperGT, and Chris with the USF2000.
     
  3. Paulfield

    Paulfield Registered

    Joined:
    Feb 18, 2012
    Messages:
    129
    Likes Received:
    143
    At "Connection Type" select 64 up/down. I think that is the ISDN listing
    What this has done for our league is that everyone has the same speed connection. I was having big freeze running 130mbps and that was taking the bandwidth from the race server. When I changed to 64 up/down no more freeze. All our league racers are on 64 u/d now and problem gone. We race the endurance mod on 20,40 and 90 minute races. So give it a go get everyone to change their internet settings to ISDN 64/UP/DOWN can't hurt.
     
  4. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,346
    Likes Received:
    920
    I was just doing what the boss, Fieldzy, said to do.
    When the boss speaks......o_O

    Speak of the devil. ;)
    I do think that what stonec said about 64 vs 128 is something to be looked into.

    It's always hard to find the cause of a problem when not everyone, or a majority, are experiencing the same problem.
     
  5. Paulfield

    Paulfield Registered

    Joined:
    Feb 18, 2012
    Messages:
    129
    Likes Received:
    143
    We will give it a go this Friday at Bathurst. (128)
     
  6. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,101
    Likes Received:
    1,228
    Well I might have been wrong, this thread has some suggested values. It seems that at least for upload 64 kbps is enough, but for download the user recommends 128 kbps for more than 15 cars on track. The server should automatically limit upload/download per client to a sensible value if it gets overloaded, but maybe there's some bug in here, which would explain why forcing manual values for clients solves the bug. Who knows. Only ISI/S397 dev can answer what the true ideal values are for those two settings.
     
  7. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    824
    @Chris Shepherd Could this be related to skin downloads?
    Untick Allow Custom Skin Transfers from dedicated server UI and Download Custom Skins from your rF2 options and se if it helps.
     
    Last edited: Mar 2, 2017
  8. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,817
    Likes Received:
    566
    The skin download is not allowed on our server, and we have the freeze when a driver leave.
    We limited the permanent lag issue when a driver leave with fixed upgrades, so it's a bit better, but the freeze for some seconds is still there when a driver leave.
     
    Last edited: Mar 1, 2017
  9. caterkiller

    caterkiller Registered

    Joined:
    Oct 7, 2010
    Messages:
    88
    Likes Received:
    15
    We had 2 short races yesterday (25mn) with a private mod. 17 drivers on track.
    First race we were all in ISDN connection setting (64kbps). No freeze bug but quite a lot of lag, specially on start.

    Second race we were all in Cable/DSL 256k up. No freeze bug too, no lag on start. However, we all had a short lag (half a second or less) when a driver lost a wheel, but we had all the lag at the exact same time so fortunately no consequences.

    We'll keep this setup for our 2 coming races wich are longer and with more drivers (more than 30), build 1108 and Cable/DSL 256k and we'll keep you informed.
     
    Christopher Elliott and ADSTA like this.
  10. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,346
    Likes Received:
    920
    Thanks for the report caterkiller.
    Good to hear the change made a difference.
     
  11. hitm4k3r

    hitm4k3r Registered

    Joined:
    Jun 15, 2016
    Messages:
    666
    Likes Received:
    1,311
    Just watched the VEC 6hours of Interlagos and noticed that quite a few people had problems with screen freezes completely destroying their races. I am allmost 100% sure that it is a client side issue and connected to graphic settings. I had this happening during an offline race running the apex mod at Bathurst. I had the graphics basicly everything on high when it happened, so I tried to lower the settings and it gave me no screen freezes the next race. My guess is, that it is connected to one of the settings that is tied to CPU occupancy, so at one point or another people run out of realtime, wich gives the impression of lag during online sessions.

    I will try if I can replicate it. :)
     
    Christopher Elliott likes this.
  12. Ralffan

    Ralffan Registered

    Joined:
    Jan 30, 2014
    Messages:
    37
    Likes Received:
    4
    Issue still not solved for some people. This problem RUINS people's races, it must be top priority, we have paid for a software that is supposed to work in that os and hardware, studio 397 has to solve it as soon as posible.
     
  13. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,346
    Likes Received:
    920
    It's always the games fault. :rolleyes:
     
  14. Ralffan

    Ralffan Registered

    Joined:
    Jan 30, 2014
    Messages:
    37
    Likes Received:
    4
    Maybe it's not game's fault, but I haven't seen any official post from ISI/studio 397 or anything saying "it's because of X".

    However I remember a post of a member of ISI staff saying that it is a known bug (and it didn't happen in other builds), so yes, it looks like it's game's fault.

    PS: I have never had this issue, but some people in the league have it. And I don't want to blame anything or anyone, just want a solution....
     
  15. filippu

    filippu Registered

    Joined:
    Jun 14, 2013
    Messages:
    184
    Likes Received:
    121
    Don't worry, a DLC is coming, it'll solve everything :)
     
  16. kro388th

    kro388th Registered

    Joined:
    Jan 10, 2012
    Messages:
    646
    Likes Received:
    31
    Something to think about , As mentioned earlier in this post the freezes just started happening for me in the last few builds , (although I remember going threw something just like this in the early days of ISI rf2;) ) I'm pretty sure it started with the build that gave us the multiGPU selection in vid settings .. I remember one night right after a DX11 update maybe 2 dx11 builds ago ? can't remember ,after clearing the cbash & shaders for the new build , I went into the same combo from the night before Howstons @ Toban , and had the 1-2 sec freez , I thought "wtf? it was smooth as silk yesterday" having never seen this in the other builds I went out and had a look at the video settings and saw the new 'AUTO' feature selected in the gpx card drop down.. I changed this from auto to my actual card ,went back in and it was all smooth again ..

    Then just yesterday I went on one of the servers with the new M650S with like 25 drivers and it was freezing again ! This could have also been some lag because the server was packed ,but my car did freez a few times so I went to have a look in video settings and sure enough the game had went to AUTO again ,changed it back to my card & it smoothed out .. It seems every time the PC is restarted or I reboot the box it again selects AUTO .. I can tell because my game has the freezes again ..lol so now my pre race routine includes checking the vid settings first !

    So Im not saying this is the cause but I think its related , like Hitm4k3r mentioned above the problem might have to do with client & gpu interface ? ..IDK ..lol

    Just thinking out loud here and I am on the DX11 builds in 4k so Im stressing the sys a bit but have great results with the GTX1080 4096X2160 with 70-100 fps on a single 50" 4k @60hrz.. runs very smooth when my true card is selected ..:rolleyes:
     
    osiris32 likes this.
  17. Jego

    Jego Registered

    Joined:
    Feb 18, 2016
    Messages:
    147
    Likes Received:
    55
    I seem to recall that at some point this issue was addressed by Marcel and that they are working on a fix.
    Any news on that or am I imaging things.
     
  18. Sulivan Gardena

    Sulivan Gardena Registered

    Joined:
    Nov 4, 2016
    Messages:
    60
    Likes Received:
    9
    The same game freeze happens when a driver joins the server. No solution. Does not allow a driver to EXIT server during green flag. That causes lag. Drivers must pull car into pits before ESC from racing surface. If you hit ESC while on track, it can disrupt the running order and break the rules plugin. So, two different problems....
    (1) EXITING SERVER = never under green flag
    (2) ESC from race = only in pits.

    joining and/or exiting server causes game freeze. DO NOT ALLOW drivers to EXIT server during green flag.
     
  19. LallerHUN

    LallerHUN Registered

    Joined:
    Mar 18, 2011
    Messages:
    8
    Likes Received:
    1
    All of experiencing the issue after the 1115 update. Going back to the 1112 build sold for some of us but for other the problem still occurring.
     
    Giacomo Verlini likes this.

Share This Page