[SOLVED] Game does not respond after loading tracks

Discussion in 'Technical & Support' started by Gevatter, Dec 23, 2015.

  1. Gevatter

    Gevatter Registered

    Joined:
    Dec 23, 2015
    Messages:
    45
    Likes Received:
    19
    Good evening,

    I've looked around the forum, but wasn't able to find a thread that helped me. Since yesterday, I have a strange bug occurring, but first, some background information: I've purchased rFactor 2 when it was pubslished on Steam, and I've played around 25 hours so far. After the first installation, It ran without any troubles, even though I downloaded and tried out all the mods I could get my hands on. Now, a few days ago, I purchased an SSD, so I formatted and re-installed Windows 7 x64. I re-downloaded rFactor 2, and now it seems it won't let me play. rFactor is still on the same driva as before, not on the SSD

    The thing is, I select a car and track, along with race options. I'm still in the "getting used to it" phase, so I only do practice runs atm. It loads the track just fine - at least it looks like it does - but freezes as soon as the loading screen goes away and the pit screen is shown. It looks like this: https://imgur.com/JirK7Bm The game just hangs and doesn't respond anymore. When I tried on fullscreen setting I couldn't even Alt+Tab out, I could only force the Task Manager with Strg+Alt+Del. Now in Borderless setting after a few clicks Windows says the program is not responding and if I'd like to wait or close it.

    These are my launcher settings: https://imgur.com/YE22IQf It was the same when I tried forcing 32bit mode. I used a lot of mods again and thought, maybe that's where the problem lies, so here is the current situation:

    I uninstalled rFactor 2 and completely deleted the folder, then re-installed into the standard Steam directory
    It auto-subscribed to alle the ISI content, so that's what it is running with. No other mods at the moment.
    Current build 1036 (Steam Auto-Updates)
    I use the pedal overlay plugin (re-downloaded it yesterday) for 64bit and the DashMeterCom Plugin -> It also hangs without those
    I have not configured anything this time, but hat everything set up how I wanted it when it hung before and also when it worked.
    I run the current drivers for my sound "card" (RealTek Onboard) and graphics (Radeon HD 7850 - driver updated via Catalyst Control Center/Radeon Settings). Those same driver versions used to work on the first installation.
    I tried the Skippy and the Clio Cup on Lime Rock (all chicanes & Uphill chicane configs) and the Corvette C6R on Silverstone
    I attached the latest trace file.

    All other Steam games run well, so I doubt it has to do with Steam itself.
    Any ideas would be greatly appreciated. Also, it's getting quite late around these parts, so please excuse any typos this time :)


    //Edit: OK, I solved the problem myself, and it was no problem with rFactor or Steam, after reinstalling Windows I was missing the Microsoft Visual C++ 2013 Redistributable Package that's needed for the DashMeterPro Plugin, so that caused rFactor to hang. No more problems after installing it.
     
    Last edited by a moderator: Dec 26, 2015

Share This Page