Game crash after track loading 100%

Discussion in 'Bug Reports' started by Alexandr Meshkov, Sep 18, 2022.

  1. Alexandr Meshkov

    Alexandr Meshkov Registered

    Joined:
    Jun 20, 2017
    Messages:
    182
    Likes Received:
    79
    After track loading, I experienced crash to desktop. It is probably related to track error. Using V8 Supercars and Phillip Island. Cars running fine on other circuits. Phillip Island has been used number of times last year and two years ago in previous builds with exact same version.

    Track reinstall didn't help. Game integrity check in Steam didn't help. I repaired all four vcredist libraries with no effect. Two other drivers from our league have same problem.

    Track link
    https://drive.google.com/file/d/1rJIyszmTuD3-JPNFSQvifTSmEjuJlYP_/view

    My two traces and dumps. First one from online server with V8 Supercars and Phillip Island. Second one with SC2018 and Phillip Island in offline. I got also trace_2022_09_17_21_06_05-66 from different driver. Also trace_2022_09_18_15_41_31-31.txt and rfMini.dmp (#3) from another driver with same issue.

    What can cause this? How can we repair track?
     

    Attached Files:

  2. Coutie

    Coutie Moderator Staff Member

    Joined:
    Oct 5, 2010
    Messages:
    3,129
    Likes Received:
    1,598
    Thanks, seems a few people are having this issue.
     
  3. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,641
    Likes Received:
    1,459
    @Alexandr Meshkov I did make a quick Test and the Problem seems to be the Tag Deformable=True for some Meshes, like racesurface_wall19_s0, ground01 - ground08.
    When i remove the Tags in these Instances, the Track loads in DevMode.
    I guess it can be removed from all racesurface.. Instances too.
    If you know the Creator of that Track, inform him about it and ask, if he could update it.
     
  4. Alex Sawczuk

    Alex Sawczuk Registered Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    650
    Likes Received:
    650
    That shouldn't make the game crash. Did it crash in moddev for you?
     
  5. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,641
    Likes Received:
    1,459
    Yes and after i deleted the Tags, it loaded.
    I'm on 1130 Build ID 9477543
     
  6. Alex Sawczuk

    Alex Sawczuk Registered Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    650
    Likes Received:
    650
    Ok thanks
     
  7. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,641
    Likes Received:
    1,459
    @Alex Sawczuk Maybe it helps. We (SMMG) did also have some Troubles with Cars, where the Parts in the main Slot, that shall show Damage, were tagged with Deformable=True, which worked in the Past.
    It still worked with "smaller" Meshes, but for bigger Meshes (~ 25000 Polys +) it didn't load anymore.
    But it worked with the Damageable=True Tag.
    So it seems, as if something has changed about the Games Code, how it handles the Deformable=True Tag.
     
  8. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,396
    Likes Received:
    736
    redapg, what does Deformable=True in a track do out of curiosity? Is it something left over from rF1?
     
  9. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,641
    Likes Received:
    1,459
    I can not say something definitely about it, sorry. :)
    But i mean to remember, that, when RealRoad was introduced, the Racesurface Meshes were tagged with it.
    But i can not swear it.
     
  10. 3NPV5IRR

    3NPV5IRR Registered

    Joined:
    Feb 27, 2014
    Messages:
    114
    Likes Received:
    51
    @Alexandr Meshkov
    I was the third one with the same issue. I had no problem from one of my computers (old one) based on Intel CPU, Nvidia GPU and Lenovo Explorer HMD. However the issue was exactly as you described with my main PC with AMD CPU and GPU as well as Pimax HMD. I fact I had similar issue with some other custom tracks, for example with Redbull ring of Senorman.
    The issue is not happening if I open the track in a monitor. So probably apart from other things Pimax could be not compatible with some tracks, while no problem with official ones.
    Finally I solved the problem by removing DAM and shared memory plugins. Turning them off in customspluginvariables.json does not help, only deleting.
    I hope it may help somehow.
     
  11. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    2,936
    Likes Received:
    1,863
    That's very weird. Those plugins are very tested because are the most common.
    Is it possible that you weren't using the last versions of the plugins?
    It's possible that @Lazza knows something.
     
  12. Coutie

    Coutie Moderator Staff Member

    Joined:
    Oct 5, 2010
    Messages:
    3,129
    Likes Received:
    1,598
    Does this happen with newer official tracks, like Donington?
     
  13. 3NPV5IRR

    3NPV5IRR Registered

    Joined:
    Feb 27, 2014
    Messages:
    114
    Likes Received:
    51
    Yes, it's probable, because since the mentioned plugins work well with the majority of the content, I didn't bother myself with updating. I'll check later how it would be with the final versions.
    I guess no, since I identified the workaround only yesterday night.

    I don't have Donington, but I have no issue with all the official content, including Nurburgring, Spa, Azhure etc.
    I suspect some incompatibility of the few custom tracks with Pimax software, because those tracks still work on both: the monitor and Lenovo Explorer HMD.
     
  14. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,641
    Likes Received:
    1,459
    Maybe there are different Problems with different Tracks?
    I can only speak for the Phillip Island Track that @Alexandr Meshkov has linked.
    For me, that Track crashed in ModDev and i don't use any Plugins and have Intel CPU and NVidia GPU with a TV as Monitor.
    As said above, what did solve it for me, with this Track, was to remove the Deformable=True Tags from a few Meshes.
     
    lagg likes this.

Share This Page