G920 Wheel Range/Rotation

Discussion in 'Technical & Support' started by dirty4, Sep 6, 2020.

  1. dirty4

    dirty4 Registered

    Joined:
    Sep 6, 2020
    Messages:
    1
    Likes Received:
    0
    G'day,
    Noticed since the latest rFactor 2 update my wheel rotation doesn't match the animations on the screen. Wheel range has been changed to 540 degrees permanently without the option to manually change. Should be 900 range. Associated Logitech software up to date and don't have any issues regarding this with other sims I use. I see someone has posted the same issue for the G29 wheel also in the last day or two.

    Thanks
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,195
    Likes Received:
    3,582
    Your physical wheel is doing 540 all the time? This would stop it matching as most cars will have something different to 540.

    Did you tick "vehicle set" in the controls menu? That would be the normal way to have the game adjust your wheel rotation for each car. If that's not working you can try to figure out why, or use an alternative like software rotation lock.
     
  3. SunBro

    SunBro Registered

    Joined:
    Apr 16, 2015
    Messages:
    30
    Likes Received:
    8
    Yeah i have a g27 and my real life wheel rotation no longer matches my ingame wheel rotation. It's not just a visual issue too, i literally have to turn my g27 (which is 900 degrees) full lock in order to achieve full lock in game with a ferrari gte. Doesn't feel nice i'll say....
     
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,195
    Likes Received:
    3,582
    Has this only just happened? Might be build related, or a coincidence (I used to use a G27 and most of the time it adjusted properly, but sometimes didn't; and other people had issues as well).

    Could be some broken json settings, but you might want to try using software rotation lock - follow my post here: https://forum.studio-397.com/index....wheel-rotation-not-working.61750/#post-968519

    That bypasses the driver and should work with all FFB wheels. I use the same for my T500 as it has issues with the game's default adjustment.

    Just be sure to change the correct lines, and check you're editing the right json file - the minimum torque value is a good one to edit and check in the UI to confirm.

    @dirty4 you might want to try that too.
     
    buzz hornet likes this.

Share This Page