G920 Brake issue

Discussion in 'Technical & Support' started by erich, Aug 1, 2020.

  1. erich

    erich Registered

    Joined:
    Jul 28, 2020
    Messages:
    4
    Likes Received:
    1
    Hi,
    I've been running rFactor 2 for a while under Win 7 and everything was great.
    I got a Valve Index so I needed to upgrade to Win 10 to get it to work properly.
    Now the brake pedal axis is inverted and I cannot get it to calibrate. Either I get nothing, or I get reversed action. I can't find a setting to reverse it in the game and G Hub is of no use at all.
    Anyone have any ideas? I've searched and can't find a solution that works.
    Thanks.
     
  2. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,321
    Likes Received:
    6,587
    Have you tried to reassign the brake pedal? Make sure to press all the way down quickly when it prompts you.
     
  3. erich

    erich Registered

    Joined:
    Jul 28, 2020
    Messages:
    4
    Likes Received:
    1
    Yes, I tried holding down the brake pedal before clicking, then releasing while "waiting for input". It did the same thing.
     
  4. erich

    erich Registered

    Joined:
    Jul 28, 2020
    Messages:
    4
    Likes Received:
    1
    I suppose the game is trying to do the right thing.
    I've got an hydraulic mod and it reads correctly,zero volts with zero pressure.
    The game is 'doing the logitech thing' and inverting it.
    Is there no way to turn it off? It worked fine under Windows 7.
     
  5. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,724
    Likes Received:
    3,294
    There's no reason to do it this way - that will only enforce the negative direction. The game should pick up whatever direction you do when you're assigning it - I just tested this with my throttle and brake, can assign either way. (not G920, mind you)

    Find your brake axis in the game, then find that axis in your active controller json file. Here's my throttle acting in a positive direction:

    Code:
        "Controller 1 Axis RZ Zone":[
          0,
          0,
          0,
          0,
          1
        ],
    
    and here it is in negative:

    Code:
        "Controller 1 Axis RZ Zone":[
          0,
          1,
          1,
          1,
          1
        ],
    
    so you could try changing your json values to whichever it's currently not.

    Also check the controller settings in steam, there have been some instances where controller settings in there were interfering, perhaps not in this way though.
     
  6. erich

    erich Registered

    Joined:
    Jul 28, 2020
    Messages:
    4
    Likes Received:
    1
    I tried messing with the controller file and got nowhere.
    Then I reset the brake input (like I had done many times) and it calibrated properly.
    ¯\_(ツ)_/¯

    All's well that ends well.
    Thanks!
     
    Lazza likes this.

Share This Page