FYI: rFactor2 runs extremely well on Windows 8 Release Preview x64

Discussion in 'General Discussion' started by buddhatree, Jun 3, 2012.

  1. Hiatt66

    Hiatt66 Registered

    Joined:
    Dec 23, 2011
    Messages:
    10
    Likes Received:
    0
    X64?
     
  2. mavericckk

    mavericckk Registered

    Joined:
    Feb 14, 2012
    Messages:
    202
    Likes Received:
    2
    win 8
    well, rf1 starts but load always the same track, dont know why.
    rf2 starts but no drivers for my Momo.load the track but cant drive, i need alt tab and finalise the game.
     
  3. buddhatree

    buddhatree Registered

    Joined:
    Dec 22, 2011
    Messages:
    1,700
    Likes Received:
    249
    Install the Logitech Profiler for Windows 7. It works perfectly but you need to start the setup under Windows 7 compatibility mode.

    Once installed, it works as normal.
     
    Last edited by a moderator: Jun 8, 2012
  4. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,234
    Likes Received:
    368
  5. buddhatree

    buddhatree Registered

    Joined:
    Dec 22, 2011
    Messages:
    1,700
    Likes Received:
    249
    Those are the old drivers for last public build way back in March. New Win8 drivers are coming out soon.

    The latest Win7 drivers work the best for now.
     
  6. mavericckk

    mavericckk Registered

    Joined:
    Feb 14, 2012
    Messages:
    202
    Likes Received:
    2
    well,with Logitech Profiler now works the contrls in the configs of game.the game load fast track too,but when i go to the track some mods freese and need alt tab for end the task, in f renault, engine no start.uff.cant drive yet. need to remove track map plugin or the game no work.
    any help?
     
  7. Supadj

    Supadj Registered

    Joined:
    May 28, 2012
    Messages:
    5
    Likes Received:
    1
    I had the same problem. I installed the .net 3.5 thingy and then ran the compatability
    troubleshooter and it all works fine for me now.
     
  8. DrR1pper

    DrR1pper Registered

    Joined:
    Apr 29, 2012
    Messages:
    3,294
    Likes Received:
    36
    Any chance the perceived performance boost is perhaps because you are comparing it to you older win 7 installation that may have slowed down over time (as i find all windows os do).
     
  9. buddhatree

    buddhatree Registered

    Joined:
    Dec 22, 2011
    Messages:
    1,700
    Likes Received:
    249
    I'm a bit OCD about my Windows installs :) I do a full format and reinstall about every 3 months or so. I've taken into account that it's a fresh install.
     
  10. slawek

    slawek Registered

    Joined:
    Oct 5, 2010
    Messages:
    32
    Likes Received:
    0
    Hi, I've installed 32 bit version on my AMD X2 2.4ghz GF8600 and must say it works perfect, I need to compare FPS with XP but I can definitely say it works much better.
     
  11. mikeyk1985

    mikeyk1985 Registered

    Joined:
    Dec 27, 2011
    Messages:
    447
    Likes Received:
    3
    I installed Win 8 on these recommendations, absolutely no performance increase whatsoever, spa actually freezes in certain places now, will be going back to Win 7. The interface is horrible also and have already run into compatibility issues. There is no reason to bother with it in my opinion.
     
  12. Cristian Why

    Cristian Why Registered

    Joined:
    Mar 8, 2012
    Messages:
    201
    Likes Received:
    2
    i tried win8 for a few days and had no shuttering and no Sync needed, the performance is the the same as i had on the last build version with win7.
     
  13. D1Racer

    D1Racer Registered

    Joined:
    Jan 10, 2012
    Messages:
    193
    Likes Received:
    1
    You have a pretty good system, yet you limit it with 2GB of RAM and a 32 bit OS. No wonder you see no increase in performance. I have the same CPU as you, 2 x 9800GT's in SLI, but 8GB RAM on a 64 bit OS, and I saw performance increase from Win7 x64 to Win8 x64. And definitely no freezing in Spa.
     
  14. Satangoss

    Satangoss Registered

    Joined:
    Jun 2, 2011
    Messages:
    1,123
    Likes Received:
    7
    Interesting, we had to know if the improvement is from W8 itself or from disk defragment / formatting and a fresh and cleaned OS register which may possibly been done during system upgrade. Even keeping the same Windows installation, I got some good FPS from a full system and hard disk maintenance.

    I've built a SLI [MSI 580GTX @ 832Mhz ] x 2 + i7 2770K @ 4.8 Ghz and it’s running Metro 2033 @ 98 FPS FullHD in contrast to 80 FPS average before system cleaning, same Windows 7 64 bits before and after. However, in RFactor2, the improvement was quite disappointing to say the least, remaining FPS very close than I’ve got before (i7 920@4.0 and GTX 480 under screwed register and fragmented HD). Maybe I might consider an upgrade to Windows 8 as well.
     
  15. michael1

    michael1 Banned

    Joined:
    Mar 26, 2011
    Messages:
    283
    Likes Received:
    1
    [​IMG]

    Uploaded with ImageShack.us

    I just updated to W8 and my graphics got way better I only did fresh windows a few weeks ago rf2 is loading Faster I nearly got taken out by my Spanish friends taking this screen shot lol.


    [​IMG]

    Uploaded with ImageShack.us
     
    Last edited by a moderator: Jun 14, 2012

Share This Page