FXAA standalone does not work

Discussion in 'Technical Archives' started by Quo-Fan, May 19, 2013.

  1. Quo-Fan

    Quo-Fan Registered

    Joined:
    Oct 16, 2010
    Messages:
    55
    Likes Received:
    1
    Hi all,
    if i check FXAA without HDR a nearly black screen is visible in race, see attached picture.
    Only if i check both, means HDR and FXAA it looks normal, but because of HDR very comic style colors.
    Any chance to use FXAA alone?
    Or have i to use special settings (FXAA is allowed in Nvidia system settings) ?
    (GPU is Nvidia GTX670 with 4GB RAM, CPU is Intel i7-3820, System RAM is 16GB)
    Thanks...
     
  2. YoLolo69

    YoLolo69 Registered

    Joined:
    May 28, 2012
    Messages:
    978
    Likes Received:
    6
    I have the exact same problem with my GTX670 (2GB). I play with FXAA and HDR ON and change settings of the monitor itself to compensate when colors are "funny" (depends of the track) ;)
     
  3. Quo-Fan

    Quo-Fan Registered

    Joined:
    Oct 16, 2010
    Messages:
    55
    Likes Received:
    1
    That's what i did in the meantime too. A very uncomfortable way ...
     
  4. MJP

    MJP Registered

    Joined:
    Oct 5, 2010
    Messages:
    988
    Likes Received:
    20
    I remember getting that problem a few times but its been awhile since I've seen it. Seemed to occur if I was changing the HDR/AA/FXAA options in the menus rather than using the launcher. Have you tried deleting the contents of the UserData\Log\Shaders file and letting the game rebuild them?
     
  5. Quo-Fan

    Quo-Fan Registered

    Joined:
    Oct 16, 2010
    Messages:
    55
    Likes Received:
    1
    Hi,
    just deleted the content...helps nothing, same behaviour. FXAA as standalone doesn´t work in my case.
     
  6. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    I think the solution to tour problem is much more basic and stupid than you might ever think
    Press ALT+TAB to exit to desktop and do it again to get back to rf2. Tachaaaan!!!!!
     
  7. Quo-Fan

    Quo-Fan Registered

    Joined:
    Oct 16, 2010
    Messages:
    55
    Likes Received:
    1
    Very very funny...that trick really works!
    It helps at the moment, but the right way should be that the game starts "normal" after checking the FXAA box.
    ISI, a little bit of work for you and thanks to all:cool:
     
  8. zeXav

    zeXav Registered

    Joined:
    Feb 19, 2012
    Messages:
    25
    Likes Received:
    1
    Old problem
    http://isiforums.net/f/showthread.php/9173-AA-Black-Screen-and-beyond?p=123492&viewfull=1#post123492

    Me with last build (always the same thing)


    rFactor 2 becomes more and more a joke :(
     
  9. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    I would say that in my case it does not crash when pressing Alt+tab in multi player. I will check in any case

    Enviado desde mi GT-I9505 usando Tapatalk 2
     
  10. tjc

    tjc Member

    Joined:
    Jun 4, 2012
    Messages:
    5,841
    Likes Received:
    329
    I`ve had this problem too and found that if I turned HDR or FXAA or both on or off in sim it works fine.

    When I did that through "Configure Sim" I always got the black screen.

    In older builds this used to be the opposite but with b218 it works from in sim but not in the "Configure Sim" option...
     
  11. MJP

    MJP Registered

    Joined:
    Oct 5, 2010
    Messages:
    988
    Likes Received:
    20
    I only get the black screen if I set both FXAA and in game AA on. Setting just either whether I do it from the 'Configure Sim' or in game works fine.
     
  12. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    I confirm rf2 crashes when returning from desktop when playing online. In my case i get the black screen independently if i change the sattings from the launcher or from the game

    Enviado desde mi GT-I9505 usando Tapatalk 2
     
  13. Antaeus

    Antaeus Registered

    Joined:
    Jan 6, 2013
    Messages:
    198
    Likes Received:
    0
    i reduce AA from level 8 to level 7 and black screen disappear
     

Share This Page