freeze & crash

Discussion in 'Technical & Support' started by shrapnell, Sep 23, 2019.

  1. shrapnell

    shrapnell Registered

    Joined:
    Dec 30, 2016
    Messages:
    6
    Likes Received:
    1
    Hi
    I have a problem for about 3 months which I could not solve so far.
    RF2 was working about 4 months fine without any issue. And than...
    I think I have pretty much tried everything I could find on the web and here in the forum.

    After about 10-30 minutes, most after about 10 minutes the screen freezes.
    I can still hear racing sounds, if I press "I" the AI continue racing (recognizable in the telemetry). Only the screen is frozen. Sometimes if I Alt+TAB and go back to RF2, the game crashed without any error massage.


    I updated:
    graphics driver,
    use old an new drivers,
    tried all possible graphics settings (high/low),
    change the Hz,
    new installation,
    windows reinstall,
    ram tests (no issue),
    hard disk tests (no issue),
    monitor the heat development in the computer (cant see any issue),
    fan and hardware dedusted,
    create a new userfolder
    delete geforce experience ...

    nothing helps.

    The error usually occurs after 10-20 minutes, maybe 1 out of 5 times every 30-40 minutes, and about 1 time out of 10 and I can run an endurance race (1 1/2 - 3 hours) with finish.

    I have tested different vehicles and tracks. Can't see any difference. Unfortunately I do not know any more and am with my guide at the end.

    I hope someone can give here a decisive hint.

    Please let me know if you need any informations.


    thank YOU!

    *here some shots*

    graphic card is the NVIDIA GeForce RTX 2070

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
     
    Last edited: Sep 23, 2019
  2. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,509
    Likes Received:
    755
    Have you also tried to use a former rfactor 2 build?
    And have you enabled the game to generate trace files and have checked them?
     
  3. Coutie

    Coutie Moderator Staff Member

    Joined:
    Oct 5, 2010
    Messages:
    3,805
    Likes Received:
    2,262
    Do you ever get blue screens? I had a ram issue, ran a bunch of tests and it never showed anything wrong, but as soon as I replaced them, everything worked correctly.
     
  4. shrapnell

    shrapnell Registered

    Joined:
    Dec 30, 2016
    Messages:
    6
    Likes Received:
    1
    Thx for help.

    The problem started in april. Back then I tried 2 or 3 older builds in combination with previous graphics drivers . unfortunately also unsuccessful. currently everything is up to date. In addition, bios was also updated.

    I have not tried trace files yet. thanks for the note. I test today and post the log file then here.
     
  5. shrapnell

    shrapnell Registered

    Joined:
    Dec 30, 2016
    Messages:
    6
    Likes Received:
    1
    I never had a blue screen. the program is usually only ended and I land on the desktop if I try in vain by esc and then with two clicks to get to the main menu to save at least the replay.

    I also suspected that it is the Ram memory. I spent a few hours doing ram tests on bios at night. no errors were found. I do not know now if it would bring anything to swap the slots. unfortunately have no replacement ddr4 to make a test with other ram memory.

    Greetings
     
  6. Comante

    Comante Registered

    Joined:
    Nov 20, 2013
    Messages:
    1,700
    Likes Received:
    1,232
    I hope everything goes fine, I've just wiped rf2 folder and installing it again from scratch, had a similar problem for 7 years .
     
  7. shrapnell

    shrapnell Registered

    Joined:
    Dec 30, 2016
    Messages:
    6
    Likes Received:
    1
    .

    And now it works fine?

    I have already installed the program several times
     
  8. Comante

    Comante Registered

    Joined:
    Nov 20, 2013
    Messages:
    1,700
    Likes Received:
    1,232
    Still downloading 25gb of stuff.
     
  9. shrapnell

    shrapnell Registered

    Joined:
    Dec 30, 2016
    Messages:
    6
    Likes Received:
    1
    it seems that i have changed something that minimizes the freezes, maybe even fixes them.

    I found the following here in the forum and applied.

    - Windows 10 runtimes reinstalled / repaired. (two of them were missing)
    - applied all rF2 tips and tweaks from the thread "Tips for optimized rF2 performance / Guide on how to prevent low FPS" from Launger
    - used CCleaner


    what exactly fixed the error or at least minimized I can not say yet.


    I drove 2 races (2 x 1 1/2 hours) plus some qualification and training driven. Overall without a freeze. (about 4 hours drive)
    So I have not created any trace file yet. I hope it stays like this.


    Thank you all again for your helpful hints!
     

Share This Page