Framerate Stuttering

Discussion in 'Technical Archives' started by MarcG, Jan 10, 2012.

  1. Ghost_Unit13

    Ghost_Unit13 Registered

    Joined:
    Jan 11, 2012
    Messages:
    2
    Likes Received:
    0
    For my Geforce GTX460 Nvidia drivers 285.62 the PLR setting was the solution for the stutter. Got all on Full with 60fps. Gives me a big smile!
     
    Last edited by a moderator: Jan 14, 2012
  2. shum94

    shum94 Registered

    Joined:
    Oct 5, 2010
    Messages:
    375
    Likes Received:
    0
    Very nice find Marc !!

    Wonder why ISI turned that off.
     
  3. NitroStar

    NitroStar Registered

    Joined:
    Oct 5, 2010
    Messages:
    30
    Likes Received:
    0
    Is there a way to turn OFF the heat haze or exhaust heat visuals that are behind all the AI cars. It looks very fake on my system and the wing shadows on the Meganes almost flicker with it even while going down a straight.

    I've changed my Flush frames and I get no difference, but my system is not stuttering bad, I just am not getting many frames. Seems undrivable below 40fps in the Meganes.
     
  4. Slimjim

    Slimjim Registered

    Joined:
    Oct 5, 2010
    Messages:
    122
    Likes Received:
    2
    for me it's not a slide show, it's more like someone hit the slow motion button...lol
    my frame rates do not drop it's like driving in slow motion for maybe 1 or 2 seconds, then it returns to normal.
    i noticed this mostly driving at Mills short track online. have not had this happen offline.
     
  5. FOG>Daheee

    FOG>Daheee Registered

    Joined:
    Oct 5, 2010
    Messages:
    49
    Likes Received:
    0
    The stuttering for me is killing this at the moment. Portugal last bend was at 79fps and seemed like I was doing 10mph then it shoots forward. I have applied the fix which has not improved anything. Also the 4th corner on the exit is real bad for stuttering. There are also other places but these are the worst. Mills did a 30min race and had 4 stutters but minor compared to Portugal.

    Phenom II Quad@ 3.6
    ATI 5850 11.11 Drivers
    4GD DDR3 1333mhz
    Vist 64 SP2
     
  6. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    340
    Likes Received:
    2
    Ive tried all the suggestiosn mentioned here, but still get terrible stuttering. The main culprit is definatly on mills in the meganes when frame rates drop from 100 down to 20 or so (using fraps)
    Then when im away from the effected areas of the track, rates go right back up again.



    Gigabyte P55- USB3 motherboard LGA 1156
    Corei5 760 2.8ghz
    Arctic Cooling Freezer 7 Pro
    8gb Mushkin (2x4gb) DDR3 PC3-10666
    Win 7 64 bit Home Edition
    250 GB Western Digital WD2500AAKS Caviar Blue, SATA 3Gb/s, 7200rpm, 16MB Cache, 9 ms
    Palit Nvidia GTX 570 OC gfx 1280mb
     
  7. RussD

    RussD Registered

    Joined:
    Jan 12, 2012
    Messages:
    10
    Likes Received:
    0
    I had a similar issue, frame rate in Precision was pegged at 60 but what I was seeing on the screen was choppy and almost unplayable.

    What fixed it for me was the joystick fix in the knownissues.txt file. I changed update frequency and it runs really smoothly now.

    From KnownIssues.txt:

    Controllers
    ===========
    -Some older force feedback drivers cannot handle rFactor2's high-fidelity update rate and in fact make the simulation fall out-of-realtime (you'll notice if things get jerky and slow and the purple bar on the CPU Time graph goes to 100%). There are two possible fixes: 1) get updated drivers from your hardware manufacturer (recommended), or 2) open up controller.ini and set "Skip Updates" to a non-zero value. Note that the presets for new Thrustmaster wheels include the second fix in case users haven't updated their drivers. Again, we recommend updating the drivers and setting "Skip Updates" back to 0.


    So, just in case the .plr fix doesn't work, here is something else folks can try.
     
  8. TiTaN

    TiTaN Registered

    Joined:
    Jan 13, 2012
    Messages:
    236
    Likes Received:
    3
    I have very bad performance on my system too, tried the plr thing. Im sure my system can handle this in max. and hope soon will be optimized.

    CPU q9450 3.0Ghz O.C (I could try 3.4Ghz but I dont think that will help)
    4 Gb ddr3 1600
    ATI 3870x2
     
  9. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    340
    Likes Received:
    2
    One last thing I will try tonight is to lower sound settings.... I saw on one thread somewhere from somoene from ISI that if you lag at the start of a race it may be due to the noise of the crowd... well thinking about it, the areas where I suffer appear to be coming into the stadium areas where crowds are gathered. A long shot, but worth a try ...
     
  10. CordellCahill

    CordellCahill Registered

    Joined:
    Oct 14, 2010
    Messages:
    190
    Likes Received:
    0
    FIXED!!!! Thanks
     
  11. Jason Madigan

    Jason Madigan Registered

    Joined:
    Oct 6, 2010
    Messages:
    34
    Likes Received:
    0
    One small observation I have made today is that if I load any car and track combo and head out on track to do some laps, then exit to the garage and watch any part of the replay, as soon as I go back out on track I start to get the slow downs - game pauses - stutters.

    As a test I proceeded to turn off the replay function all together and it would appear that I no longer am having any real stutter issues at all. I will go and test some more car and track combos but for the time being I believe that this has solved my stuttering problem :)
     
  12. chuckyeager

    chuckyeager Registered

    Joined:
    Jan 11, 2012
    Messages:
    125
    Likes Received:
    15
    Maybe

    I first thought of some parameters in the cam files because this stuttering problem at mills and at estoril seems to be vehicule cam related, i just had a look and indeed there is a 1000 clip 2nd parameter for the megane in cockpit whereas its only 500 for the 60's open wheels and 600 for the F3.5 !

    I'm not sure it's the only problem but it should help.

    But ! i tried some modifications of cam files and it seems that it causes a rejection of the mod, there must be some kind of procedure to follow maybe a kind of update via the new package system, must have a look at it...
     
  13. OZCOL

    OZCOL Registered

    Joined:
    Jan 13, 2012
    Messages:
    4
    Likes Received:
    0
    I was getting very bad stuttering, & also minimal acceleration, I found turning off the force feedback worked, no more stuttering, & acceleration is now normal. Don't want to drive without force feedback though.
    BTW, my wheel is a Microsoft Sidewinder, not sure if it is part of the problem. I know it's not what the majority use but it works for my driving style:D
     
  14. Thomas

    Thomas Registered

    Joined:
    Dec 17, 2010
    Messages:
    31
    Likes Received:
    0
    I think you dont have to fully disable your ffb. Try to tweak things with this settings: http://isiforums.net/f/showthread.p...ls-out-of-realtime-CPU-is-100?highlight=jerky

    Im sure it will solve your issues, cause it seems that only older wheels have that problem.
     
  15. F2kSel

    F2kSel Registered

    Joined:
    May 28, 2011
    Messages:
    138
    Likes Received:
    2
    If it's an older wheel then it may well help but in my case G25 it does nothing. If the wheel is the problem wouldn't it be the same on every car and track?

    I did try the fix suggested by ISI and it made no difference and the other fix only works for Nvidia cards.

    It just seems like the old rFactor bug to me which was never fixed so it's hard to be positive they will find a fix for this, it's just pot luck if you get it or not.

    The best fix when using rF1 was to use a third party d3d9.dll which really helped eliminate most of the stutter, there was never any stutter in other racing titles.
     
  16. Neuro

    Neuro Registered

    Joined:
    Jan 12, 2012
    Messages:
    53
    Likes Received:
    0
    Hi! The .PLR setting "Flush Previous Frame="0" change to "1" solved my stuttering issues for the moment (on a GTX550ti, med. graphics, 20 cars on track). Thanks!
     
  17. Nizmo

    Nizmo Registered

    Joined:
    Jan 11, 2012
    Messages:
    77
    Likes Received:
    7
    Marc, you're the man!!! The only thing that I was running were the Historicals as the Megane was a slideshow everywhere. Came accross this post and your suggestion to change Flush Previous Frame="0" to "1" in the plr file and it works like a charm! Smooth as a baby's rear end. Awesome! Thank you very much!

    Todd
     
  18. MystaMagoo

    MystaMagoo Registered

    Joined:
    Oct 5, 2010
    Messages:
    774
    Likes Received:
    2
    It would help if people also posted what in game settings they use.
    What settings they use in their graphics cards software.
    Whether they set graphics/video details/settings in game or by the rF Config file?

    Just stating you get stuttering does not help.
     
  19. Novis

    Novis Registered

    Joined:
    Oct 7, 2010
    Messages:
    251
    Likes Received:
    4
    Thanks! This worked for me. :)
     
  20. Darkmater

    Darkmater Registered

    Joined:
    Jan 11, 2012
    Messages:
    18
    Likes Received:
    0
    Flush switch from 0 to 1 worked for me as well. Quite an improvement actually. I am able to run everything on its highest setting with acceptable frame rate. Nvidia 275, intel 930.

    Now just need to get more cores going.
     

Share This Page