Flickering colours on track and random change to colour

Discussion in 'Technical & Support' started by Bram Beelen, Feb 2, 2019.

  1. Bram Beelen

    Bram Beelen Registered

    Joined:
    Feb 2, 2019
    Messages:
    4
    Likes Received:
    0
    Dear Studio 397,

    You are my last hope Obi Wan o wait thats a different thing..

    I am having some weird issues with rFactor2 colours. Before i descibe the problem i have to give some side notes.

    Sidenote:
    The colour problems on track dont affect everything. The Hud is fine, the sky is fine, the ingame menus are fine. The rest on track is not. After things changed colours and i go to the pit the whole menu and standings are fine, just my on track window has changed colour (without the items described above).

    How it occurs:
    When i start the game all is fine, i start driving still all fine. Than at random moment i get a colour flickering, sometimes blue sometimes green, yellow etc..
    After a while at some point the whole screen turns a different colour (yellow most of the time). After that the only thing to fix it is to restart the game.

    In the last VEC race on Sepang i also had this problem but there it was on some parts of the track not permanent. And it seemed like it was programmed, so every lap on the same place the screen turned yellow and back to normal again after a section or corner. But always on the same point.

    I tried to mess with my settings but what ever i do it always gives me this problem, updated the drivers of the video card no succes.

    I really dont know what else to try anymore. And since the problem is so specific just for this game it must be something within the game?

    I will marry the one who helps me solve this issue.

    Best Regards,
    Bram
     
  2. Hazi

    Hazi Registered

    Joined:
    Jan 15, 2012
    Messages:
    737
    Likes Received:
    60
    Maybe overheating your GPU? Try a stress test....
     
  3. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    1,484
    Likes Received:
    876
    sounds like tearing. common with some Nvidia cards. If you are over-clocking the video, don't. Drop everything back to default. Take it out, clean out the fans and vents. Reseat the card. If you have other drives like a DVD or Blu Ray optical drive sucking even standby power, try disconnecting those temporarily to see if you are putting too much of a load on your power supply. Finally, I don't know which threads, (hopefully somebody will find them) there are several threads dealing with tearing and some procedures to help eliminate them. finally give us your system specs. cpu/memory/videocard/power supply rating/screen rez
     
  4. Bram Beelen

    Bram Beelen Registered

    Joined:
    Feb 2, 2019
    Messages:
    4
    Likes Received:
    0
    Thanks for the respons so far. How do i perform a stress test?

    The hardware specs have not changed over time, only replaced the hdd with an SSD some months ago. Problem was already there at that point. I must admit that now and then i had some issues with my pc starting up with the screens staying on stand by. I needed to unplug all and 1 by 1 put in the devices like screens and usb etc.. may there be a power supply issue?

    My current hardware specs are:
    CPU: Intel Core i7 2600K @ 3.40GHz Sandy Bridge 32nm Technology
    Ram: 8,00GB Dual-Channel DDR3 @ 824MHz (9-9-9-24)
    Motherboard: ASUSTeK Computer INC. P8Z68-V PRO (LGA1155)
    Graphicscard: 2048MB ATI AMD Radeon HD 6900 Series
    Screens: DELL S2330MX (1920x1080@60Hz) & DELL E176FP (1280x1024@60Hz)
    I use the DELL S2330MX for gaming, the other one for TS
    SSD: 465GB Samsung SSD 860 EVO 500GB ATA Device (SATA (SSD))
    Optical Drives:
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    HL-DT-ST BDDVDRW CH10LS28 ATA Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    DiscSoft Virtual SCSI CdRom Device
    Audio: AMD High Definition Audio Device

    This is what Speccy tells me.. why are there so much devices :(:(

    I also will post 2 screen shots of after it changed to yellow, they are below. As you can see what changes to yellow is very selective. 54F83038-A8D6-4290-9721-135AF905F02D.JPG 40E95FA9-D0E6-46CA-82D0-EADF9662C580.JPG
     
  5. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    1,484
    Likes Received:
    876
    Looking at your system specs, I'd guess the age of the video card is causing the problem. 2mb video ram is probably the absolute minimum to run rF2 these days. Add to that only 8 gb of system ram and there isn't a-lot of room left for windows to create swap pages to manage memory.
    In the rF2 launcher, the screen with the single helmet for offline and 2 helmets for online play, there is also a gear icon. click on that and look for a check box that says something like: Force 32bit. Check that and see if it helps. Warning, using 32 bit will limit the amount of ram your system can use and large tracks with lots of graphics, like the new Sebring, will probably cause your system to crash.
     
  6. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    396
    Likes Received:
    206
  7. Bram Beelen

    Bram Beelen Registered

    Joined:
    Feb 2, 2019
    Messages:
    4
    Likes Received:
    0
    The config i am using is there for like 8 years and i never had this issue before. I wonder if that can be the case.

    Will have a look a that, i indeed have that program installed. But if it helps for my issue we will see :)

    Also i must update my first post, there is no flickering its a flash. So sometimes i get a short colour flash and back to normal. Or the flash changes into a permanent yellow colour. But there is no flickering its always 1 short flash
     
  8. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    396
    Likes Received:
    206
    Can you try another monitor? Just to eliminate that from the equation.:)
     
  9. doddynco

    doddynco Registered

    Joined:
    Dec 13, 2017
    Messages:
    34
    Likes Received:
    16
    I get a similar problem sometimes. It happens a lot at Toban and I think some other places. Essentially the hue changes entirely, then switches back to normal around the next corner/section. For me it goes blueish, and seems to be track location specific, and is affected by the time of day. I'm using a 1070 and VR. I can't recall this happening on any other games.
     
  10. Bram Beelen

    Bram Beelen Registered

    Joined:
    Feb 2, 2019
    Messages:
    4
    Likes Received:
    0
    The monitor can be excluded

    At sepang i had the same thing, i could tel to the second now it turns yellow and when it turned back.. weird...
    The colours are also random, sometimes blue, yellow and black.. but mostly yellow...
     
  11. d0nd33

    d0nd33 Registered

    Joined:
    Dec 4, 2016
    Messages:
    106
    Likes Received:
    75
    Have you tried to play with Post Effects setting in Video Setup? I'd try to set it Off.
     

Share This Page