DX11 - Shadows and Shaders/Cbash folder

Discussion in 'Bug Reports' started by MarcG, Jun 3, 2017.

  1. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,523
    Likes Received:
    1,864
    I'm doing some benchmarks with different Shadow settings and found that of you don't delete the SHADERS and CBASH folders after each setting change then the Setting doesn't work correctly. I.e. Start with Low then change to Medium and there is no difference, delete those folders and rerun the have and you can see the difference between the two settings.

    Not sure if this is by design or not, but people may think they've changed this setting in game without noticing it's failure. Tested at Monte Carlo official track with civics.
     
  2. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    I don't think this is by design. Those files should be autorebuilt. At least that's the way it has worked so far when you changed some settings. Track loading times increased in those cases with respect to loading a second time the same configuration.

    I reported no performance change regardless the player detail setting being used. I only delete shaders and cbash after switching builds. I wonder if it is the same problem that you mention?

    What settings have you noticed to be affected?
     
  3. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,523
    Likes Received:
    1,864
    Shadows is the only one so far that requires a deletion of those folders that I've found, I have changed Opponent Detail and seen a difference without deletion I know that much.
     
  4. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,204
    Likes Received:
    1,316
    I've seen a difference in shadow details and FPS without deletion, the following FPS numbers I got last week without deleting anything:

    Dx11 Shadows Off 74
    DX11 Shadows Low 71
    DX11 Shadows Medium 57
    DX11 Shadows High 54
     
  5. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,523
    Likes Received:
    1,864
    I didn't check the FPS just visually it was blatantly obvious that changing settings purely in game made no difference, besides there's been Build updates since last week so maybe something broke in them.
     
  6. The Iron Wolf

    The Iron Wolf Member

    Joined:
    Feb 20, 2016
    Messages:
    966
    Likes Received:
    913
    Do you happen to know what's the visual difference between medium and high? Thanks.
     
  7. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,313
    Likes Received:
    6,553
    I'm seeing a drop in FPS changing shadow settings, without clearing shaders/cbash. Were you checking this only in VR?
     
  8. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,523
    Likes Received:
    1,864
    Yes sorry this was in VR Only.
     
  9. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,313
    Likes Received:
    6,553
    OK thanks, we'll check that.
     
    lagg and MarcG like this.
  10. Adrianstealth

    Adrianstealth Registered

    Joined:
    May 28, 2012
    Messages:
    4,452
    Likes Received:
    980
    Well spotted , I suspected there was something bit kooky

    The setting change doesn't delete & replace with new files
     

Share This Page