[DX11 beta] SLI compatibility bits

Discussion in 'Technical & Support' started by JetPistol, May 2, 2017.

  1. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,651
    Likes Received:
    656
    @M.Guenette I have forgot in my post`s one important detail which gives improvement to SLI.
    Nvidia controll panel.jpg

    Virtual Reality pre-rendered frames 2 :rolleyes:
     
    Last edited: Oct 30, 2017
  2. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    82
    Likes Received:
    15
    What version of the drivers are you running? I do not have the SLI rendering mode option.
    (running 388.00, 1080TI SLI)
     
  3. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,651
    Likes Received:
    656
  4. M.Guenette

    M.Guenette Registered

    Joined:
    Feb 12, 2013
    Messages:
    60
    Likes Received:
    5
    (running 384.76, 980 SLI)
     
  5. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,651
    Likes Received:
    656
    Guys regarding my post #61.
    If you have max load in both(all) GPU`s obviously you don`t have to use Virtual Reality pre-rendered frames 2.
    Virtual Reality pre-rendered frames is VR setting and it should not have any effect if you are not using VR. I am not sure if there is some bug in Nvidia driver or if this is related to rFactor 2.

    My GPU loads with default setting.
    GPU load V2 off.jpg

    Virtual Reality pre-rendered frames 2
    GPU load V2 on.jpg

    o_O
     
  6. M.Guenette

    M.Guenette Registered

    Joined:
    Feb 12, 2013
    Messages:
    60
    Likes Received:
    5
    Thanks For The Update Ari Antero !
     
  7. M.Guenette

    M.Guenette Registered

    Joined:
    Feb 12, 2013
    Messages:
    60
    Likes Received:
    5
    Hi Ari Antero
    Now that DX11 is the Rfactor 2 default I'm suffering some micro stutters in game play. Do you have any new suggestions for users running a SLI ,Triple Monitor , Multiview on setup? Any help would be appreciated!!
    Thank You
     
  8. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,651
    Likes Received:
    656
    I haven't had time to look closer to rF2 SLI setup but I do it in the next weekend and make a post about it.

    If your PC is able to keep fps at monitor hz (60, 120, 144) edit "Max Framerate":0, in player.JSON to match your monitor hz if you are getting micro stutters when higher fps then monitor hz. If you have micro stutters when fps is lower then your monitor hz you must lower in game settings to match performance which gives you equal or better fps then your monitor hz.
     
  9. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    82
    Likes Received:
    15
    I'll post my current setup, 2x1080ti, 2xPCIx16, i7-7700k and 7680x1440 120hz gsync

    I have locked the fps to 90 in the json file
    Changed from standard nvidia profile, using the latest 388.71 driver

    rf2settings.png

    With these settings it works ok, as Ari wrote, it seems important to find an setting where the fps is solid, and not above the refresh rate.

    I have recently got AMS who is using the rFactor1 motor, maybe not relevant but I got these result after changing the SLI bits:

    non limited fps
    no other cars - 180-230fps, intense micro stutter
    shadow max, visible ai, 60-180fps, intense micro stutter
    shadow medium, visible ai, 90-180fps, intense micro stutter
    with vsync, up to 120fps, micro stutter and warping

    locked 90fps in nvidia profile, a little less stutter, but not playable
    locked 90fps in-game, no stutters during an 20m race

    I have noted that shadows kills the fps at least in my setup, and I have now tried two different mb (previous with 2xPCIx8 and 1070 SLI, new w10 installs etc) with similar result. It usually work ok when at distance to the other cars but once bumper to bumper it just goes in slow motion stutter.

    And as always, suggestions for improvments always welcome :)
     
  10. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,651
    Likes Received:
    656
    Soft particles = High might be heavy hit to fps. Try with low and see if you notice any difference with performance and fps. I would also disable gsync and test video sync and see if it helps to get rid of micro stuttering ;)
     
    Wergilius likes this.
  11. M.Guenette

    M.Guenette Registered

    Joined:
    Feb 12, 2013
    Messages:
    60
    Likes Received:
    5
    I have played around with a few options . Both in-game and through Nvidia inspector with some degree of improvement. Still trying to find a sweet spot that yields the best results. Playing RFactor 2 with multiview enabled is way to hard on Video Cards. Running two GTX 1080 ti card should be overkill but that's simply not true when it comes to RFactor 2. I will wait on Ari Antero's findings this weekend to see if he has any luck.
     
  12. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    82
    Likes Received:
    15
    I have tried reducing the AA level but level 3 is minimum for decent AA for fences and so on, using None do however help performance (but kills your eyes instead)

    I have now lower my detail settings from full to high and soft particles from high to low, blur to optimal. This seems to be only way to have an decent performance, the fps drops to around 85 during start in an 16 car ai race, before it went as low as 65 and slow motion stutter.

    If using medium shadows, the fps is going below 50fps, 397 really needs to work on their sli/triple/multiview performance since it is bad (or more like broken), and i'm not using any post effect and don't think that will boost the performance.
     
  13. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,651
    Likes Received:
    656
    GPU loads and 100% working Nvidia driver is a must when using Nvidia SLI. With single screen SLI GPU loads are not a big problem but when using triples it can be a problem which many people are not able to solve. I have triples (35", 3440x1440) res. 10320x1440 but there are some limits in 1080Ti ports which forces me to use res. 7680x1440.
    There is no point to OC 1080Ti expensively with SLI becourse it is very hard to get Max GPU loads with triples and there is only slight fps improvement if 1080Ti is over clocked in rFactor 2.

    MSI Afterburner and Nvidia inspector are a great tool`s and they are a must when using SLI to be able to get maximum performance.
    http://www.guru3d.com/files-details/msi-afterburner-beta-download.html
    http://www.guru3d.com/files-details/nvidia-inspector-download.html

    NI.jpg

    Don`t mess with game settings first just use MSI afterburner and make sure that GPU close to pic below. You should never have lower GPU loads then 90% when sync or some other frame limiter are not used used with S397 DX11 content. Increase MSI Afterburner Core Voltage and Power Limit if you don`t get descent GPU Loads.
    GPU LOADS.jpg


    MSI Afterburner settings which gives me Max GPU loads
    MSI Afterburner.jpg

    I would also recommend to use WinSAT.
    Open Windows Command Prompt with admin rights. It's called "Command Prompt (Admin) > Type : winsat formal -restart clean , press enter on your keyboard. Give it a few minutes to do it's thing. Once done, close the window by typing exit and restart your PC.
    https://docs.microsoft.com/en-us/wi...nfigure-windows-system-assessment-test-scores

    Rfactor2 Launcher> Tick, Auto close Launcher

    My rFactor2 video settings:
    Resolution: 7680x1440 (120 hz)
    Mode > Fullscreen
    Anti Aliasing > 3
    Post Effects > Medium
    Sync> Video
    Multiview > on

    IN-GAME SETTINGS.jpg

    With settings above I am able to play with 1080Ti SLI all optimized S397 DX11 content no mater which weather options are used micro/stutter free at 120 fps with good game experience.
     
  14. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    82
    Likes Received:
    15
    Thank you Ari, i'll will for sure test this. But I wonder if you have some hw/sw combo that somehow is spot on? Regardless of setting, using medium shadows (with AI) my fps drop to 50fps, and I have now tried two different SLI setups, 2 different motherboards and new installs of w10 etc, all similar behavior (even thou 1080ti SLI and 2xPCIx16 did boost performance on all sims)

    And as of yesterday, my performance in rf2 dropped to 67fps and low gpu usage for some unknown reason. I have reinstalled the nvidia drivers (384 and 388), checked rf2 thru steam but if using anything else but std bits, the performance is bad... strange??

    If I use the standard profile (edit only 2 pre-rendered and maximum performance) I can get 90fps at 2x98-100% gpu load (with my previously dropped settings) but it drops and stutter some, very strange as it just started as I started a new session, so as of now rF2 is not playable.

    And I don't think an general fault in my setup, AC is still solid 100fps and AMS using SLI bits, is still 100 solid fps with 20 AI's

    But I will for sure test all your settings, one question you recommend gsync off, do you have gsync screens but still recommend them off??
     
  15. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    82
    Likes Received:
    15
    I did some quick test, removed my 90fps limit in player json, Silverstone, using the radical and GT pack 16 AI race

    alone, 80-115fps, some stutter issues
    race, 35-110fps, some stutter/slow motion issues

    gpu load
    upload_2017-12-31_15-32-44.png

    When disabled gsync and using sync video the stutter seems to be a bit better (shorter) but also the overall fps performance got about 5-15fps less.

    As of now it looks awesome, almost ok to use but not the performance one could expect with my hw but I continue to try some other settings and see if its improves the fps and eliminates the stutter.
     
  16. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    82
    Likes Received:
    15
    Change my in-game settings to my previously used one, and now the gpu is utilized as before, something in Ari's suggestion is helping with my previously low gpu load problem.

    alone 110-120fps
    race 85-120fps

    still small stutter when fps is changing, that seems to be an gsync problem?
    have noted that in ams as well (using rf1 motor)

    gpu load
    upload_2017-12-31_16-7-47.png

    Not there yet, but better :)
     
  17. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    82
    Likes Received:
    15
    I have now tried to lock the fps to 90 and my low gpu/fps lock got back again but now I think I found out what is happening

    Whenever my gpu load drops below around 40% it drops the fps to 67 and gpu stays around 35%. Not until gpu load rise around 45% the fps goes back to 90fps (i can do that by waiting for the AI pack to lap me as track itself is not high load enough)

    The problem is that, to have an non stutter experience I seems I have to lock the fps and scale down gfx if I don't want to use this as an hotlap simulator. But when I do that, the low gpu lock appears instead...

    This is the same with both nvidia drivers tested, and the low gpu is not an problem by itself, running an hotlap in AMS at 100fps has an gpu load around 20-30% and there it works fine.

    I will need to find an setting that loads the gpu when alone, but also low enough to keep the fps steady when around other cars
     
  18. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    82
    Likes Received:
    15
    After some more testing the specific load/fps is not specific, on another track the fps varies from 83-120fps

    Going into a corner at 100fps, then suddenly it jumps to 83fps.
    Next lap going behind another car the gpu load is a bit higher,
    then I have 100fps on the same straight, and game play is smooth as well during that period.

    When the load drops, it jumps back to 83fps and gets an non-smooth behavior

    IMO something is broken somewhere, to be forced have and setting loading the gpu enough
    but also in the same time find an setting low enough when ai is around tricky (possible?) and
    should not be the case to make it run smooth, a bit of catch 22
     
  19. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    82
    Likes Received:
    15
    And another car/track combo tested, fps lock to 100.

    alone on track (<65), 75fps, could sometime jump to 100fps
    during 16 ai race, when around cars, static 100fps
    if I let the pack go, fps drops to 75

    I'll guess next is maybe to try different sli bits to see if any other setting helps
     
  20. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,723
    Likes Received:
    1,004
    @Wergilius have you checked that your GPU clocks are both consistently fullspeed? Other than that, google suggests (in older posts, mind you) that sli + gsync and/or shadowplay can cause low FPS. Perhaps that was some issue that got fixed though.
     

Share This Page