[DX11 beta] SLI compatibility bits

Discussion in 'Technical & Support' started by JetPistol, May 2, 2017.

  1. MARVIN

    MARVIN Registered

    Joined:
    Nov 13, 2016
    Messages:
    11
    Likes Received:
    2
    With dx9 I managed to get work for 99% of the 2 VGA with a SLI profile other than the one selected by Nvidia, but I have to be in front of the pc to remember the name profile SLI used .
     
  2. suryaprihadi

    suryaprihadi Registered

    Joined:
    Apr 16, 2017
    Messages:
    87
    Likes Received:
    32
    Hi guys,
    I want to update.

    With Nvidia driver 378.92 , with its default DX11 SLI bit which is zero-zero all the way, a single 2560x1440 or a single 4K monitor, my 2nd GTX980 was sleeping at 2% or so and that Nvidia SLI indicator does not work.

    In DX11 with SLI Bits 0X080000F5, it work like magic...Single Monitor and SLI 2 way GTX980.
    Hence I was so happy and hoping this SLI bits will do good in 7680x1440 resolution and angled multiview.

    DX9, single 2560x1440 or single 4K, will work in SLI using the default Nvidia appointed Rfactor 2 SLI bits 0X2402005, but at best 60% both GPU-s.

    The default DX11 Nvdia sli bits all zero , in triple 2560 multiview angled aka 7680x1440, is a bit better than DX11 SLI bit 0X080000F5 because I experienced freeze up to 2 seconds with 0X080000F5 at full best setting. I am doing these all best setting to help document DX9 vs DX11 difference for this post :
    https://forum.studio-397.com/index.php?threads/official-dx9-vs-dx11-performance-difference.55385/


    Hardware :
    i7 5960X, 8 core, 16 threads. Memory 24GB. GTX980 4GB x 2 if in SLI, Driver 378.92
    Game Built 1802266 for DX11
    Game Built 1796904 for DX9

    Logging is PIT to rolling start running whole track back to Start line. AI driving. 10 AI cars in the list.
    Data points are 2 data per 1 second ( 500ms) using Afterburner

    Here is my test result : Single 2560x1440 monitor
    I am getting like 30% FPS gain using SLI Bits 0X080000F5 DX11
    Nvidia default SLI bit 0X2402005 for DX9 loads GPU poorly.
    TEST PARAMETER : NOLA C. ALL BEST in Display. Video Resolution AA at L4 to match DX9 which is limited to L4. FXAA is off. Surely Post Processing is NONE for DX11.
    Car is GTR500 - 2013
    DX9 & DX11 Single 2560 monitor - SLI and non-SLI.JPG


    7680 x 1440, multiview angled monitors. No useable FPS..so awful and give me headache.
    TEST PARAMETER : NOLA C. ALL BEST in Display. Video Resolution AA at L4 to match DX9 which is limited to L4. FXAA is off. Surely Post Processing is NONE for DX11.
    Car is GTR500 - 2013
    In 7680 x 1440, multiview angled monitors, SLI Bits 0X080000F5 cant help:(
    DX9 & DX11 Triple 2560 monitor - SLI.JPG

    I am kinda sad, looks like even when I order GTX1080Ti, in 2 way SLI , it wont do very well with this DX11 Post Effect thingy. ..hick hick hick. If only Nvidia has something twice the power of GTX1080Ti in 1 GPU. I want one. Single GPU is proven a better choice if such hardware exist...right guys ?

    My single GTX980 can't power 7680x1440..so I can't test its SLI scaling for triple 2560...dang.


    Now the sad part...........

    With DX11 default SLI bits all zeros , basic image setting at just a bit above medium and Post Processing effects at MEDIUM & ULTRA, this bad I am getting at 7680x1440 multiview angled :
    sad case DX11.JPG
    Look at the ULTRA....11 FPS average...LOL
    :(


    DX9 & DX 11 without Post Processing. Using default SLI bits as per Nvidia.
    This is the best I can get with reduced settings
    The best decent FPS I can get, DX9 vs DX11.JPG

    .
     
    Max Dralle likes this.
  3. Bart

    Bart Registered

    Joined:
    Nov 25, 2016
    Messages:
    6
    Likes Received:
    1
    Nice testing there, I`m having same problem with triple screens. What I can suggest only is bits for DX9 ver - 0x02D04005. There works great on my 970sli in dx9. Both cards ~99%.
     
    suryaprihadi likes this.
  4. suryaprihadi

    suryaprihadi Registered

    Joined:
    Apr 16, 2017
    Messages:
    87
    Likes Received:
    32
    Thanks Bart, I will test :)
     
  5. suryaprihadi

    suryaprihadi Registered

    Joined:
    Apr 16, 2017
    Messages:
    87
    Likes Received:
    32
    Hi Bart,
    I actually tried 0x02D04005 sometime ago and again today, it is LEGO.
    For me I cant get above 60ish% both GPU, all max best setting.
    The only time I can get near 90%-ish on both GPU is at medium something and not cockpit view , bonnet/hood view and others, that is with default Nvidia RF2 SLi bits.

    0x02D04005 is what Spinelli and old member tried in 2015, hence I read that and tried.

    Thanks
     
  6. Max Dralle

    Max Dralle Registered

    Joined:
    Mar 16, 2017
    Messages:
    238
    Likes Received:
    145
    Hi Guys.

    Thanx a lot for the intense testing. It seems running multiple displays is a totally different beast.
    In that context, did you setup your screens as independant displays or as one big stretched desktop ?
    That might make a fundamental difference.

    However, back in the days, I found these two SLI bits for DX9 working a lot better than the default profile from nVidia:
    0x00500005
    0x02502005

    Good Luck !
    Max
     
  7. suryaprihadi

    suryaprihadi Registered

    Joined:
    Apr 16, 2017
    Messages:
    87
    Likes Received:
    32
    Hi Max,
    Streched screen aka Nvidia surround and the wing monitors are software angled in multiview...the worst for GPU :)
    I will try your :
    0x00500005
    0x02502005

    Thanks
     
  8. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    827
    Compatibility Bits 0x02D04005 (LEGO Batman 2, etc) was working with BUILD 982 but only with NVIDIA Game Ready Driver WHQL 353.30 which gave 98% GPU loads for both GPU`s.

    This are settings I am using (DX9) which gives 95-99% GPU loads ( 2x 1080Ti) and 120 FPS game play for me.

    SLI comparability bits: 0x02D04004

    UserData > player folder and open player.JASON file and edit:
    "Max Framerate":120 ,(60 if 60hz monitor, 144 ............)
    "Max Framerate#":"0 to disable (note: positive numbers only, we always use the 'alternate' method now)",
    "Texture Sharpening":0,
    "Texture Sharpening#":"Sharpen textures using MIP LOD bias - 0=Off, 1=+2.0(very blurry), 2=+1.0(blurry), 3=-1.0(sharp), 4=-2.0(very sharp), 5=0.0(auto)",

    Nvidia Control Pane > rFactor2 profile:
    Maximum pre-rendered frames > 1
    Power management mode > Preferer maximum performance.
    Important: Do only this don`t mess with other settings

    rFactor2 video settings:
    Mode > Fullscreen
    Anti Aliasing > 3-4 (FPS killer #1 in rF2)
    HDR> on
    Sync> Video

    Inn Game > Options > Display:
    Circuit Detail > Full
    Player Detail > Full
    Opponent Detail > Full
    Texture Detail > Full
    Texture Filter > X16
    Special Effects > Full/High
    Shadows > Medium (FPS killer #2)
    Shadow Blur > Optimal
    Soft particles > Off
    Rain Drops > Yes
    Road Reflection > Off (Off gives better fps)
    Environment Reflection > Off (Off gives better fps)

    ;)
     
    suryaprihadi likes this.
  9. suryaprihadi

    suryaprihadi Registered

    Joined:
    Apr 16, 2017
    Messages:
    87
    Likes Received:
    32
    Thank you Ari. GTX1080Ti x 2 is my next shopping list too.
    Are you on triple 1080p or 1440p monitors ?
     
  10. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    827
    Triple 34" > 10320x1440
     
  11. suryaprihadi

    suryaprihadi Registered

    Joined:
    Apr 16, 2017
    Messages:
    87
    Likes Received:
    32
    Nice !! That means GTX1080TI scaling is very good... Yipeee.
    Thank u thank u :)
     
  12. suryaprihadi

    suryaprihadi Registered

    Joined:
    Apr 16, 2017
    Messages:
    87
    Likes Received:
    32
    Hi Ari,

    Thank you so much for DX9 SLI bits 0X02D04004.:) , GPU load now 90+% for both...awesome.
    Since I am IT dummy, I looked at Nvidia Inspector SLI bits list and cant find 0X02D04004, I then updated my
    Nvidia driver to latest one per 7 May 2017 and still I cant get 0X02D04004 LOL.
    Little that I know, I can actually just type 0X02D04004 and it works !!!
    ASK : So is SLI bits actually like an instruction to the GPU, to tell them what to do ?
    DX9 built 1796904 with default SLI bits vs Ari reccomended SLI bits.JPG
    Here I am seeing your recommended DX9 SLI bits offers consistent FPS, and GPU is really worked out ...awesome !!!



    The DX9 got updated by S397 a few days after DX11 beta was release.
    Supposedly Nola track and GTR500 2013 also get some extra texture or whatever they call it....which result to FPS reduction, compared to the older DX9* (*which I do not know the built number ) test I did before DX11 beta was in-gear. Good thing I keep the 1 generation down DX9 test.
    Since I am new to RF2, I do not know where the image quality difference are.
    Both DX9 different built, showed the same characteristic on my GTX980 2 way SLI, which is massive FPS drops in some corners of Nola-C track.
    DX9 built variations - same SLI default bits.JPG
    So here is the prove that your recommended DX9 SLI bits 0X02D04004 is so much better than the
    Nvidia default one.


    Below is for other members to have a feel of how weak a GTX980 in 2 way SLI compared to your ( Ari ) GTX1080Ti driving 10320x1440 instead of my lesser 7680x1440 I am using. It seems GTX1080Ti in this scenario is double the power of GTX980, which means it is good value for money.
    DX9 GTX980 2 way SLI - using Ari setting.JPG
    If the GTX1080TI at workload resolution of 10320x1440 can do 120 FPS assuming +-10 FPS, dang...it is an awesome hardware.



    Prior to the DX9 get updated, I still need to lower my settings to get decent 90-100 FPS.
    The top graph is your recommended SLI bits with newest DX9 built. The bottom graph is the older DX9 with default SLI bits. The only difference is the older DX9 test has FXAA ON and was on Nvidia driver 378.92. The red hand written indicator I place on bottom graph represent equal track distance between the 2 test, which is approx 209-211 data points (2 data point per second) or pit to 1 round of the track.
    DX9 new and old - lowest image setting to get decent FPS.JPG

    Here is where I got confused from consistency of FPS point of view :
    01. In all best graphic setting, SLI bits 0X02D04004 did good for FPS consistency, GPU load near max for both GPU, compared to default SLI bits and GPU load of only 60%-ish for both GPU.

    02. In reduced graphic setting, with SLI bits 0X02D04004 and GPU load near max for both GPU, the FPS drop is near identical with default SLI bits with GPU load only 70% at best. I accept slower FPS with latest DX9 built, but if in all best setting which I assumed harder work load, FPS consistency is actually better than in reduced setting, that is so confusing. :oops::D

    Anyway, I hope the above data maybe useful for others.

    Thanks again Ari.
     
  13. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    827
    Most of the numbers/letters in the bits are to other settings, located in the bottom of Nvidia Inspector can only be edited by Nvidia.
    Bit 0x02D04005 (LEGO Batman 2, etc.) last number (4) - Single GPU which means that the various compatibility bit settings for different sli configurations for rF2 are broken out by Nvidia Inspector's bit editor are listed below:

    0x02402004 - Single GPU
    0x02402001 - 2 Way SLI AFR (Alternate Frame Rendering)
    0x02402002 -SFR (Split Srame Rendering) (needs a minimum of 2 cards)
    0x02402003 - AFR-SFR (AFR of SFR gets around the 3 frame buffer limit of DX9. Try this if using a Tri- or Quad- SLI setup)
    0x02402006 - 3 Way SLI AFR (This setting does not provide increased performance for a Tri-SLI setup. There seems to be a limitation in scaling judging by the in-game SLI indicator which freezes at a set level for all sli settings except AFR-SFR where the scaling is higher.)
    0x02402005 - 4 Way SLI AFR (This is the stock setting.)

    NVidia profile (rFactor2 Mod Mode.exe, rFactor2.exe) is created 2011-09-22 . To my knowledge latest build of the rF2 executable s are not submitted to Nvidia since 2011-09-22 so that an updated working SLI profile can be created.
    What I am hoping is that when 0,4 %`s are getting VR support can also SLI users who are much bigger user group also get new updated SLI profile in the distant future. :rolleyes:
     
    Last edited: May 8, 2017
    suryaprihadi and Max Dralle like this.
  14. suryaprihadi

    suryaprihadi Registered

    Joined:
    Apr 16, 2017
    Messages:
    87
    Likes Received:
    32
    Thank u Ari :)
     
  15. MARVIN

    MARVIN Registered

    Joined:
    Nov 13, 2016
    Messages:
    11
    Likes Received:
    2
    I work with resolution 7840 X 1440 (with frame correction from Nvidia).
    With dx9 and modified SLI profile for over 1 year I can work with 99% GPU without problems and I have about 120FPS.

    With dx11, the SLI RF2 profile blocks the GPU job at 55-60%, and any SLI profile proves the result remains nearly the same. My impression is the SLI profile has not changed at the moment on dx11 whatever it is.
    It seems that this problem is only present if you have SLIs and multiviews
     
  16. theVenerable

    theVenerable Registered

    Joined:
    Mar 1, 2016
    Messages:
    25
    Likes Received:
    1
    Hi, please can you tell how you type 0X02D04004 ?
    Where exactly is it typed?

    Also, which setting is actually better to use for the game in its current state?
    The DX11 Sli profile, or the DX9 one?
    Sorry, this is very confusing for me.
    I don't even know how to tell the game to use either DX9 or DX11.

    Should I have both SLI profiles selected, or just the profile that I intend to use?

    Thanks
     
    Last edited: Jun 24, 2017
  17. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    827
    rFactor 2 Beta DX11 is unplayable with SLI and if you are using game as it is you are in DX9.
    Download Nvidia Inspector to manage Sli bits : http://www.guru3d.com/files-details/nvidia-profile-inspector-download.html
     
  18. theVenerable

    theVenerable Registered

    Joined:
    Mar 1, 2016
    Messages:
    25
    Likes Received:
    1
    Ok, I will wait.
    DX9 is not a huge step down anyway I think.
    Automobilista uses it still, and that is polished
     
  19. M.Guenette

    M.Guenette Registered

    Joined:
    Feb 12, 2013
    Messages:
    65
    Likes Received:
    8
    Any news on SLI compatibility for RFactor 2 with DX 11? Still hoping someone has found a Fix / Solution.Please Help !!
     
  20. JetPistol

    JetPistol Registered

    Joined:
    Jan 5, 2017
    Messages:
    19
    Likes Received:
    6
    0x080000F5 works perfectly in DX11, go for 0x02D00405 in DX9
     
    Max Dralle likes this.

Share This Page