Released DX11 and VR Open Beta, Is Here!

Discussion in 'News & Notifications' started by Christopher Elliott, May 1, 2017.

  1. ZED

    ZED Registered

    Joined:
    Oct 5, 2010
    Messages:
    16
    Likes Received:
    4
  2. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,821
    Likes Received:
    1,170
    Thanks Mate, weird as i had the watch this thread ticked with email but haven't received anything from it, lol
    Oh well did it again anyway.
    Cheers @ZED and S397.
     
  3. Radar

    Radar Registered

    Joined:
    Oct 20, 2010
    Messages:
    687
    Likes Received:
    60
    Is it just my recent update or has the one that just came through made things worse ? Frames are lower, the in-car Menu (Enter to change Tires, Splits etc) now looks like it's from Dev and the car position marker was at the bottom is now across the top and also looking like it's from Dev.
     
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    10,620
    Likes Received:
    5,426
    @Radar Sounds like your on screen display has reverted to default. Just change that in the settings and you should be fine. Same ones all exist in devmode, you probably just never changed it there. That's not necessarily anything to do with dx11; I once had mine revert to default out of nowhere, ages ago. More often it seems to happen during updates though.

    Someone else mentioned slightly lower frames with the latest build.
     
    Radar likes this.
  5. Korva7

    Korva7 Registered

    Joined:
    May 22, 2014
    Messages:
    701
    Likes Received:
    206
    I'm having lower frames too.
     
    Alex72 likes this.
  6. Alex72

    Alex72 Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,317
    Likes Received:
    988
    Yeah i just mentioned it as the last posts were about it not being fixed. :)

    And yes i also have lower performance now with the latest updates. Last one i tested was 2 udpates ago and i never dropped under 60FPS for the first time since beta release even when around 15 AI cars, and now i drop here and there even when not around any AI cars.
     
  7. RoWo

    RoWo Member

    Joined:
    Jul 16, 2014
    Messages:
    519
    Likes Received:
    547
    Yes, I also perceive worse FPS with the last updates. Sadly I don't remember, which build was the best for me, but it was
    definitely better than now. So from FPS side it's a step backwards. :(
     
  8. ucfquattroguy

    ucfquattroguy Registered

    Joined:
    Dec 23, 2011
    Messages:
    133
    Likes Received:
    25
    Lower performance in general here. Lots of stuttering and general lower performance than DX9 on my system.

    i5 2.8gHz
    GTX560 2Gig
    4GB RAM

    I know the GPU is on the older side of things, but other DX11 titles like Dirt Rally runs much smoother.
     
  9. vegaguy5555

    vegaguy5555 Registered

    Joined:
    Jan 28, 2017
    Messages:
    960
    Likes Received:
    503
    DX11 never did work until I reinstalled DX9. Tried DX11 again yesterday and wow!! FFB and VR is working now.
     
  10. Andregee

    Andregee Registered

    Joined:
    Jun 23, 2012
    Messages:
    863
    Likes Received:
    339
    I can confirm this. Overall the performance is worse than under DX9. The CPU is still the bottleneck instead of improvements under DX9 and the GPU load is higher than under DX9. My hope for stable 60fps is gone because there is no CPU on the market with the capability for it while using multiview.
     
    multivac likes this.
  11. vegaguy5555

    vegaguy5555 Registered

    Joined:
    Jan 28, 2017
    Messages:
    960
    Likes Received:
    503
    I was getting between 98 to 119fps with DX11 maxed with my new 1080Ti on the weekend with triples but I had been pressed to get much more then 60 the earlier weekend, before I reverted to DX9 and then back to DX11. Don't know why that made a difference with fps and ffb?

    Looks pretty good now. Approaching the clearest sim in VR. I think it was 90fps for the most part.

    Good work guys!!
     
  12. bwana

    bwana Registered

    Joined:
    Dec 25, 2011
    Messages:
    2,139
    Likes Received:
    1,040
    I noticed better performance with more AI.??strange compared to others .. Tire wear and temp UI now back to normal . Thanks S397.
     
  13. vegaguy5555

    vegaguy5555 Registered

    Joined:
    Jan 28, 2017
    Messages:
    960
    Likes Received:
    503
    Everything is looking very clear with good performance. I notice some mod tracks are jerking while most are good.
    Load time is improved here by a lot.

    Thanks guys. Good work.
     
    Last edited: Jun 14, 2017
  14. vegaguy5555

    vegaguy5555 Registered

    Joined:
    Jan 28, 2017
    Messages:
    960
    Likes Received:
    503
    Tried using the vr mirror and for some reason that fixed the jerking and I can super sample more.

    How can that be?

    Maxed out x1 ss 90 fps. I can get a little better than 45 at 1.3 with the 1080Ti.
     
  15. Adrianstealth

    Adrianstealth Registered

    Joined:
    May 28, 2012
    Messages:
    4,550
    Likes Received:
    1,055
    I have an increasing phobia against mod tracks , Zanderfort coming & will be another addition to the small pool of rfactor 2's high quality track offerings
     
    gabrielof and vegaguy5555 like this.
  16. Korva7

    Korva7 Registered

    Joined:
    May 22, 2014
    Messages:
    701
    Likes Received:
    206
    Maybe rf2 got updated at the same time. My vr performance was better yesterday than last time i played it.
     
  17. vegaguy5555

    vegaguy5555 Registered

    Joined:
    Jan 28, 2017
    Messages:
    960
    Likes Received:
    503
    That's a good point but I was using it hours before and thought I would try the mirror option.

    I will have to try it without again and see if it makes a difference.

    Hopefully it was an update.
     
  18. Isosceles Kramer

    Isosceles Kramer Registered

    Joined:
    Jan 2, 2015
    Messages:
    49
    Likes Received:
    7
    After the DX11 update my performance has gone to shit, I've lost around 30 FPS, at least. CPU usage hovers around 25-50%.

    Q9550 @ 3.4
    GTX960
    6 GB RAM
     
  19. FuzzyFassbender

    FuzzyFassbender Registered

    Joined:
    Apr 26, 2015
    Messages:
    100
    Likes Received:
    42
    Are you comparing apples to apples... what do you have post processing set at (DX9 doesn't have PP - start at LOW for DX11)?
     
  20. Isosceles Kramer

    Isosceles Kramer Registered

    Joined:
    Jan 2, 2015
    Messages:
    49
    Likes Received:
    7
    PP effects are at "none". Aggressive threading makes no difference. I haven't changed any video settings after going to DX11.
     

Share This Page