[REL] DX11 and VR Open Beta, Is Here!

Discussion in 'News & Notifications' started by Christopher Elliott, May 1, 2017.

  1. hitm4k3r

    hitm4k3r Registered

    Joined:
    Jun 15, 2016
    Messages:
    755
    Likes Received:
    1,544
    Got the same problem as by many other people reported before: performance if very low and even setting the graphics lower has allmost no impact. So good decision to make it an open beta. I experienced stuff like that with other games so no biggy for me if the DX9 version is still usable.

    Could play with allmost all settings on high and 20 AI DW12 at NOLA at steady 60 FPS before and now I am alone on track and down to 30 FPS. PP makes a 10 FPS difference, but not really that much that I would call it a big difference as the game is running right now in DX11, so basicly terrible. Got to test the DX9 version and other content tomorrow to see how it is running in comparison. The visual improvements are noticable though, especialy the reflections and shadows. Now the performance needs to be fixed.

    Sys specs: Win 7 64bit, AMD Phenom II X4 955 @ 3.2 GHZ, 4GB DDR 1333, Geforce GTX 770
     
    rubennaatje likes this.
  2. Louis

    Louis Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,379
    Likes Received:
    838
    us2000/Silverstone
    posteffects: ultra -> extreme lights reflection
    posteffects: none ->everything normal
    fences flashing like hell. Cars are beautiful and track surface
    triple screen working, triple screen tool working but seems smaller
    around 60 to 70 fps alone
    48 on start
    20~30 using quick replay (almost unwatchable - i dont know if this is a word)
     
  3. Jake Loewenstein

    Jake Loewenstein Registered

    Joined:
    Mar 31, 2017
    Messages:
    64
    Likes Received:
    27
    Thank you for this!
    How do you know which are DX9?
     
  4. burgesjl

    burgesjl Registered

    Joined:
    Feb 2, 2013
    Messages:
    155
    Likes Received:
    294
    Various problems here. Like many others, getting only 20fps with DX11 when was getting 110fps+ on DX9. Also AMD hardware. Reports video mem as -1048 in the launcher, and also reports the wrong Windows version (I'm on 10, not 8).

    Further, it has removed and not re-downloaded many pieces of content, such as Indianapolis. I see in the Workshop several pieces with a May 1st date but none of those downloaded. However, I don't see some items such as NOLA and GT500 in there, but they did download.

    Finally, opting into the beta causes a redownload of all 3Gb of data associated with it each time you enable it. Yes, its one click, but really?

    A lot of work to be done to get this usable. Hope you can do some proper testing before the next attempt because this was pretty shoddy.
     
  5. ECAR_Tracks

    ECAR_Tracks Registered

    Joined:
    May 1, 2016
    Messages:
    453
    Likes Received:
    452
    No noticeable FPS hit in cockpit camera, but lot of stuttering in outside cameras.

    i7-4790 + 980 GTX

    Image looks better, but I'm reverting to DX9 until the DX11 technology gets more mature.

    BTW F12 informs me Screenshot was taken but I could'n find them in proper folder, maybe a bug.

    Edit> Reviewing my post: Post Process was none. In Ultra, the FPS hit is 120 > 80, very significant in inside cameras. External cameras very laggy, bad to watch the race action.
     
    Last edited: May 2, 2017
    Louis likes this.
  6. Carbon

    Carbon Registered

    Joined:
    Jun 12, 2016
    Messages:
    11
    Likes Received:
    0
    Any plugins that display information on the screen need to either be removed or disabled. ie Trackmap
     
  7. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    2,784
    Likes Received:
    1,612
    AMD users seem to be suffering the most. (and those that didn't follow the install instructions!) I know for my card, dx11 was a weakpoint. So this may not be a rf2 issue, but how AMD's cards handle dx11.
     
  8. jayarrbee36

    jayarrbee36 Registered

    Joined:
    May 9, 2016
    Messages:
    513
    Likes Received:
    1,482
    Thanks for all your hard work on this, Studio 397. Can honestly say, no problems so far.
     
  9. Sebastien Sestacq

    Sebastien Sestacq Registered

    Joined:
    Jan 11, 2016
    Messages:
    827
    Likes Received:
    1,355
    thanks very nice for a first beta DX11 really good job Studio397 it's good way!!
    [​IMG]
     
  10. PLorenti

    PLorenti Registered

    Joined:
    Jul 27, 2011
    Messages:
    13
    Likes Received:
    10
    Same here, in fact i noticed that in the video config window, show mi RX480 as a 1024mb ram when is a 8gb video card.
    I did a rollback and in the old video settings windows shows 4096mb , still no 8gb but is playable.

    Now i download the latest driver and again download the DX11 to test.

    Lated i will coment my experience.
     
  11. ECAR_Tracks

    ECAR_Tracks Registered

    Joined:
    May 1, 2016
    Messages:
    453
    Likes Received:
    452
    It's interesting to post your hardware to guide people. @jayarrbee36 would you confirm your replay external cameras are smooth as they were in DX9? Just out of curiosity, maybe I might keep DX-11 if it's something miss-configured.
    In time, I'm using Nvidia and the Video info is also showing -1024 Mb, but I think it has no impact on the game performance.
     
  12. Erick3331

    Erick3331 Registered

    Joined:
    Jan 25, 2017
    Messages:
    43
    Likes Received:
    9
    I also have an AMD graphich card , Unfortunately, it does not work for me :(:(:(
    But not problem, because I'm use again to use the previous version ;)
    I hope that there will be some update for AMD as well ;)
     
  13. walken

    walken Registered

    Joined:
    May 24, 2012
    Messages:
    13
    Likes Received:
    2
    i was using the urd jt5 mod, from URD. Changed car and now it works with every combo.
    thank you !
     
  14. Emery

    Emery Registered

    Joined:
    Oct 24, 2010
    Messages:
    2,643
    Likes Received:
    1,283
    First thing I've noticed is that there are now 5 levels of AA where there used to be only 4 levels. Marking level 4, as I had run in my benchmark testing before the update, AA is better than the previous level 4 and fps took a hit. Therefore I suspect we need an explanation about how the new AA levels correspond to the old AA levels before making a further judgement on fps performance.
     
    alpha-bravo, Ernie and FS7 like this.
  15. iceagecoming

    iceagecoming Registered

    Joined:
    Dec 3, 2012
    Messages:
    68
    Likes Received:
    20
    Stutters sound like video memory issues for me. In the old days when my 5970 only had 2GB, it ran smooth (at a certain fps) until it ran out of VRAM and had to swap in and out textures from the HDD, causing hitches and stutter. Considering rf2 thinks you only have 1 gb, it would be a good guess to say that the game is swapping in and out textures to keep usage below 1gb. It might be a card identification issue
     
    PLorenti likes this.
  16. walken

    walken Registered

    Joined:
    May 24, 2012
    Messages:
    13
    Likes Received:
    2
    I was using the urd jt5 mod, from URD. Changed car and now it works, in 32 bit mode only, with every combo.
    thank you !
     
  17. Alex72

    Alex72 Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,260
    Likes Received:
    952
    I havent been able to test yet, but those complaining about lower FPS did you check video setting that Hz was set properly? I saw only one person saying the Hz had gone down to 24Hz after installation locking FPS in VSYNC to very low FPS.

    BTW: Does CrewChief plugin work with DX11 update?
     
  18. The Iron Wolf

    The Iron Wolf Member

    Joined:
    Feb 20, 2016
    Messages:
    963
    Likes Received:
    906
    Yes :)
     
    Alex72 likes this.
  19. F1Fan07

    F1Fan07 Member

    Joined:
    Jan 11, 2012
    Messages:
    625
    Likes Received:
    46
    That info display likely has some legacy code in it because it hasn't read right for me for a long time. My 8 GB card shows as -81 MB, 16 GB RAM is shown as 15 GB, OS says Windows 8 when I'm running Win 10.

    FWIW, for those unable to resolve crashing or poor performance on triples, maybe try dialing back the post processing and AA. For me with 5760x1200 resolution and an 8 GB video card I was seeing nearly 6 GB in use with AA one step down from max and post effects on Ultra.
     
  20. melanie

    melanie Registered

    Joined:
    Mar 4, 2012
    Messages:
    11
    Likes Received:
    3
    rFactor 2 is reading my Video card memory incorrectly.
    rFactor2 Video Setup DX11 v2.2.0.0
    Reads that my Nvidia Geforce GTX 970 - only has 1024MB of ram, it is a 4GB video card not 1GB

    And the in game Video RES Menu reads my Video Card as

    NVIDIA Geforce GTX 970 -88 MB.

    Though I have 32GB of system ram installed, it also reads that I have 31GB of ram installed, hope this gets fixed, because this misleading system readout was also in rFactor 2 before it switched to steam.
     

    Attached Files:

    Rony1984 likes this.

Share This Page