[REL] DX11 and VR Open Beta, Is Here!

Discussion in 'News & Notifications' started by Christopher Elliott, May 1, 2017.

  1. patchedupdemon

    patchedupdemon Registered

    Joined:
    Jan 3, 2017
    Messages:
    1,602
    Likes Received:
    1,150
    thos release has changeds rf2 into a new game,it just feels so much better,I know nothing was change in the physics but it just feels different.
    It's like a brand new game for me ,thanks s397
     
  2. green serpent

    green serpent Registered

    Joined:
    Feb 2, 2016
    Messages:
    248
    Likes Received:
    186
    Something strange is going on. I followed all the instructions in the OP, but unfortunately I am still getting really low fps. Then I remembered something about changing the color of the ripple strips at Silverstone, so I fired up Silverstone and it still has the old red ripple strips? Thoughts anyone?
     
  3. Ernie

    Ernie Registered

    Joined:
    Oct 5, 2010
    Messages:
    333
    Likes Received:
    200
    Have you subscribed to Silverstone 2012 in steam workshop?

    Edit: Look here -> https://forum.studio-397.com/index.php?threads/subscribe-to-the-latest-dx11-updated-content.55273/
     
    Last edited: May 3, 2017
  4. Alex72

    Alex72 Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,268
    Likes Received:
    953
    Yeah me too i think. I guess we have to subscribe to another set of content that is for DX11 (post above).

    EDIT: Yeah click WORKSHOP and then look for BROWSE that is under the rF2 banner, below the menus like "Discussions", "Screenshots", "Artwork" etc etc. In BROWSE click "COLLECTIONS" and then choose "Studio 397 content". I think thats it cause even though i have those in DX9 it says i dont have them.
     
  5. Hedlund_90

    Hedlund_90 Registered

    Joined:
    Apr 12, 2012
    Messages:
    1,683
    Likes Received:
    40
    New update looks great, although it needs some tweaking, bloom effect is too strong in some situations. Just tried the Formula 2 at Silverstone and the steering wheel display had too strong bloom effect, but I also had a big fps drop in cockpit view. I had only 50 fps in cockpit view, when alone on track. When switching to nose cam it jumped to 100 fps. Disabling mirrors gave me another fps boost, bigger than I can remember it was before.

    So it seems bloom effect is the big fps killer?
     
    ECAR_Tracks likes this.
  6. Nitrometh

    Nitrometh Registered

    Joined:
    Dec 28, 2014
    Messages:
    1,097
    Likes Received:
    443
    Guys I did a fresh install and rf2 is redownloading subscribed contend since the new beta is out. Yep my wlan is horribly slow. I copied the package folder before uninstalling the game. If I copy all the mods in the folder again, does steam still redownload all subscribed tracks and cars or just the ones which have been updated?
    Cheers
     
  7. Alex72

    Alex72 Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,268
    Likes Received:
    953
    Hmm. So basically i didnt test DX11 content yet as i never subbed to the Studio 397 content collection. Maybe it will do something good to FPS... Do you see any difference on that collection in the sim? Does it say for example "Nissan GT500 DX11" in the car menu or will it be double entries with the exact same name? Cause i still have the stuff i subbed before for DX9.

    EDIT: Yeah i can see i have "ISI_Howston_G4 1.3" and now i also have "Howston_G4 1.4" installed in launcher. Will check if its double exact names in the sim later when i get the chance. I guess we have to unsub otherwise to all that is not DX11 content.
     
    Last edited: May 3, 2017
  8. green serpent

    green serpent Registered

    Joined:
    Feb 2, 2016
    Messages:
    248
    Likes Received:
    186
    Thanks Ernie, I didn't realize I had to subscribe to the content. I subscribed to Silverstone and USF2000, but still no luck with fps :(
     
  9. bravotangosix

    bravotangosix Registered

    Joined:
    Nov 21, 2015
    Messages:
    265
    Likes Received:
    277
    Edit* Subscribed to the newly updated content in Workshop, plus I deleted my player.Json file. It's all so beautiful now. Getting between 120-160 fps.
     
  10. Adrianstealth

    Adrianstealth Registered

    Joined:
    May 28, 2012
    Messages:
    4,452
    Likes Received:
    980
    Need a "very low" setting for bloom
     
  11. Nibiru

    Nibiru Registered

    Joined:
    Dec 24, 2011
    Messages:
    1,198
    Likes Received:
    1,269
    Your probably still useing DX9 tracks and cars. You need to subscribe to the new content in the workshop
     
  12. Nibiru

    Nibiru Registered

    Joined:
    Dec 24, 2011
    Messages:
    1,198
    Likes Received:
    1,269
    Most DX9 content will have bloom. DX11 content should be fine.
     
    papaosa likes this.
  13. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,826
    Likes Received:
    579
    In addition to bloom, I think some DX9 content can have very low FPS if used on DX11 beta build.
     
    The Iron Wolf and Nibiru like this.
  14. TonyRickard

    TonyRickard Registered

    Joined:
    Jun 5, 2011
    Messages:
    184
    Likes Received:
    38
    Probably a dumb question but how can we easily tell which is DX11 content?
     
  15. Nibiru

    Nibiru Registered

    Joined:
    Dec 24, 2011
    Messages:
    1,198
    Likes Received:
    1,269
    At this stage AFAIK only s397 content on steam and barbagallo have DX11.
     
    Last edited: May 3, 2017
  16. ZED

    ZED Registered

    Joined:
    Oct 5, 2010
    Messages:
    16
    Likes Received:
    4
    Help please.
    I have followed the instructions in the op.
    Upon verification, I have 2 files to be fixed for validation. Done.
    Launcher works....go to single/multiplayer and then the icon "RF2" shows...... then nothing, it just stays there.(minutes waiting)
    Click on the icon then pop up says, rF2 not responding. Go back to verification and it says 2 files to fixed again.
    I have done this a dozen times.
    Mod manager fires up the UI, but not in single/multiplayer.
    I went back to V1108 and the same thing.

    Something is corrupt, I'm guessing.
     
  17. Max Dralle

    Max Dralle Registered

    Joined:
    Mar 16, 2017
    Messages:
    210
    Likes Received:
    128
    Maybe there's an error on your harddisk ?
    Have you tried chkdsk ?
     
  18. F1Aussie

    F1Aussie Registered

    Joined:
    Apr 1, 2011
    Messages:
    614
    Likes Received:
    262
    I have deleted and uninstalled all non dx11 content. Atm it is a little sparse but I only want to use the new dx11 content, hopefully it won't take too long for the new improved dx11 mods to appear.
     
  19. ZED

    ZED Registered

    Joined:
    Oct 5, 2010
    Messages:
    16
    Likes Received:
    4
    Thanks Max
    I hadn't...just did it and it read no problems.
     
  20. LokiD

    LokiD Registered

    Joined:
    May 3, 2017
    Messages:
    1,270
    Likes Received:
    1,192
    Just want to say good job on Rf2 new look. It feels like another Sim totally! and even i know suzuka isn't optimised has anyone seen it at night looks amazing!! Thanks s397!
     

Share This Page