DX 11 beta - Can't enable Vsync

Discussion in 'Technical & Support' started by Kondor, May 2, 2017.

  1. Kondor

    Kondor Registered

    Joined:
    Jan 27, 2012
    Messages:
    18
    Likes Received:
    17
    Build 1108 beta DX11.

    None of the Vsync options work. Even the Nvidia control panel can't force it, whether Vsync is set for all games, just RF2 or both.

    I have tried all permutations of Vsync options and it simply will not work on my GTX1080, Win 10 x64, latest drivers.

    Dropped back to DX9 and all Vsync modes now work fine.
     
    Alex72 likes this.
  2. CamiloNino

    CamiloNino Registered

    Joined:
    Apr 5, 2017
    Messages:
    153
    Likes Received:
    131
    Try enabling it on windowed mode, that worked for me, although I think that shows another bug, that it doesn't really run in full screen mode. Check bug report thread
     
  3. Kondor

    Kondor Registered

    Joined:
    Jan 27, 2012
    Messages:
    18
    Likes Received:
    17
    That didn't work for me. And I'm having a very hard time seeing any difference in image quality. Oh well, it's a Beta. I decided to blow out my install and just start over to see if maybe that'll work.
     
  4. Kondor

    Kondor Registered

    Joined:
    Jan 27, 2012
    Messages:
    18
    Likes Received:
    17
    After reinstalling from scratch, same thing. Can't enable Vsync with Nvidia. The only thing I can do is limit fps to 60 using Afterburner's screen server until. But then you get tearing because it's just a frame cap.
     
  5. Patrick.B

    Patrick.B Registered

    Joined:
    Jun 13, 2016
    Messages:
    22
    Likes Received:
    26
    Vsync doesnt work here ... bad
     
  6. mrsmr2

    mrsmr2 Registered

    Joined:
    May 13, 2013
    Messages:
    89
    Likes Received:
    17
    Mine seems to be using some form of adaptive vsync or even adaptive window mode (the only way I can describe it).

    Even full screen and limiting the frames to 60fps with RTSS/Afterburner I had no tearing but bits of stutter (tell tale sign I'm in windowed mode using Win 7's aero mode triple buffering).

    I could only introduce tearing by turning off aero, which confirms the game is running in windowed mode (launcher and in game options both say full screen).

    I think it might have been full screen the first time I played it but once I'd fiddled with the windowed mode settings in game, it seems to be stuck in windowed mode.

    My comment about adaptive vsync/windowed mode is that in the pit of AMP with the GT500 I'm getting 29.7 fps! That rises to 60 when driving (locked at 60). It was 60 before I messed with windowed mode.

    Then, when driving it plays too smoothly for non vsync for parts, then drops vsync and tears, then smooth again - so like adaptive vsynch.

    I'll have a play with the settings but performance is probably worse than before.

    This is with PP effects off (can't stand the Outrun 2 levels of bloom), on a 970 at 1080 with max settings.
     
  7. pinkimo

    pinkimo Registered

    Joined:
    Dec 23, 2016
    Messages:
    5
    Likes Received:
    1
    Same probleme for me (W7x64, GTX 1070), no way to enable the Vsync, from the game or the drivers/NV Inspector, in fullscreen or window mode. The only "Vsync" which works is the ingame software mode, which seems to be nothing more than a frame limiter (massive stuttering).
    The AA can't be forced either, but the ingame level 5 is great.
     
  8. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    284
    Likes Received:
    949
    Hi guys, in the next beta updates we will enable vsync from the game.
     
  9. mrsmr2

    mrsmr2 Registered

    Joined:
    May 13, 2013
    Messages:
    89
    Likes Received:
    17
    Presumably that means full screen is back? AFAIK you can't apply vsync to windowed mode.
     
    jayarrbee36 likes this.
  10. LokiD

    LokiD Registered

    Joined:
    May 3, 2017
    Messages:
    1,282
    Likes Received:
    1,207
    you can force it thru plr. file.. but its not very smooth
     
  11. mrsmr2

    mrsmr2 Registered

    Joined:
    May 13, 2013
    Messages:
    89
    Likes Received:
    17
    How?
     
  12. rogue22

    rogue22 Registered

    Joined:
    Jan 14, 2012
    Messages:
    261
    Likes Received:
    18
    Open your json player file and look for max framerate. Its probably set to 0 right now, change it to whatever fps you want it to max out at.

    "Max Framerate":0,

    Change 0 to whatever you want.
     
  13. mrsmr2

    mrsmr2 Registered

    Joined:
    May 13, 2013
    Messages:
    89
    Likes Received:
    17
    Thanks but that's a framerate limiter. Has nothing to do with vsync.
     
  14. Patrick Craenmehr

    Patrick Craenmehr Registered

    Joined:
    Nov 5, 2016
    Messages:
    29
    Likes Received:
    22
    What about G-sync? The beta seems to ignore all G-sync settings in Nvidia control panel and even worse, makes G-sync stop working in other games as well until I restore defaults in Nvidia control panel.
     
  15. Lino Carreira

    Lino Carreira Registered

    Joined:
    Jul 4, 2016
    Messages:
    20
    Likes Received:
    1
    Either other software is misleading or VSYNC can be enabled on Windowed mode, Examples, Assetto Corsa , not selecting fullscreen rendering will keep Vsync enabled ( and no its no frame limiter its really Vsync ) World of Warcraft and Diablo come to mind too...

    In DX9 only way for me to have decent and stutter free framerate would be to have VSYNC set to Video, GPU and Software wont cut it... now aparently only Software works and not even forcing VSync thru inspector works.... software is spiky so the experience is pretty bad....
     
  16. joekart

    joekart Registered

    Joined:
    Dec 24, 2011
    Messages:
    55
    Likes Received:
    33
    Yes , Vsync that doesn't work is the most important thing to fix in priority.
     
  17. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    Not for me.
    I have other bigger problems
     
  18. mrsmr2

    mrsmr2 Registered

    Joined:
    May 13, 2013
    Messages:
    89
    Likes Received:
    17
    If you are in windowed mode, you are using Windows' method of vsync. If you have Aero on, then you get Windows' triple buffer vsync. If Aero is off, you don't get any vsync.

    That might explain why you have vsync with AC in windowed mode - it's using Windows' Aero mode in that case, not AC's settings.
     
  19. Richard729

    Richard729 Registered

    Joined:
    Apr 24, 2016
    Messages:
    28
    Likes Received:
    8
    Thanks for your help about this.
    Windowed mode with Aero on - should RFactor's fps display (ctrl-f) show 60 fps? I'm not getting tearing, but the frame rate is not locked to 60 fps.
     
  20. mrsmr2

    mrsmr2 Registered

    Joined:
    May 13, 2013
    Messages:
    89
    Likes Received:
    17
    Fps will still vary, so it's like a variable v-sync. A common practice is to use RTSS (comes with Afterburner) to lock the framerate to 60 (or whatever) and then use Aero's vysnc to add the smoothness.

    Full screen vsync will lock to monitor refresh rate while windowed mode is uncapped unless locked by using rtss (or even the frame limiter in the player.json).
     

Share This Page