Does any one have good performance with a HD7970 GPU

Discussion in 'General Discussion' started by cookie, Mar 10, 2012.

  1. cookie

    cookie Registered

    Joined:
    Mar 7, 2012
    Messages:
    144
    Likes Received:
    1
    Hi, I was just wondering if any one has been able to get good performance out of there HD7970 .
    My FPS range from 45, 16 car grid to 75-100 in race ,I have the latest 12.2 drivers installed .
    My settings are : 2560x1440 [native resolution Dell u2711 ] SYNS GPU this helps
    AA none , most setting on full except shadow blur off ,sun occlusion off ,road refl off , env off .
    HDR ON , makes the road look more real . I do get slight stutter the latest drivers help this .
    I would like to run two more monitors but will that take a 2/3 performance hit ? any advice .
     
  2. THracing

    THracing Registered

    Joined:
    Oct 17, 2011
    Messages:
    38
    Likes Received:
    1
    It's a known issue, I think the devs are working on it...
     
  3. Bty

    Bty Registered

    Joined:
    Sep 15, 2011
    Messages:
    112
    Likes Received:
    0
    AI cars will slow you down. And while you have a monster CPU, this game is a 2 thread.

    Overclock the CPU while keeping Turbo boost enabled and your frame rate will improve.

    If you want to know is the GPU is your bottleneck, scale down resolution and AA, if the FPS don't improve you know it's not the GPU.
     
  4. ORA-Quasi

    ORA-Quasi Registered

    Joined:
    Dec 13, 2010
    Messages:
    129
    Likes Received:
    0
    He's running a HD7970, I hardly think the GPU will be the bottleneck :)

    Cookie, I'm running a Gigabyte 1Gb HD6950 OC, and before that a Gigabyte 1Gb HD5850 OC, and both cards gave me great performance and frame rates, with everything on 'HIGH' setting (Sun Occ and 1 or 2 other effects off mostly as they annoyed me), at 1920x1080 on a 23" LED.

    After looking at your specs, I can only summise that the screen resolution is having a much bigger impact than I would have thought. Try knocking your graphic levels down to 'HIGH' and see how that goes. Once RF2 is fine tuned a little more things should improve, but the system specs appear fine.
     
    Last edited by a moderator: Mar 10, 2012
  5. cookie

    cookie Registered

    Joined:
    Mar 7, 2012
    Messages:
    144
    Likes Received:
    1
    Hi, thank you for the advice, I set the screen resolution to 1920x1200 which added 10 to 15 FPS improvement but has decreased the quality of the picture. I have tried the asus auto over clocking and set it to fast,which has caused the game to drop to the task bar 4 laps into the race. Have tried reverting to the standard settings but is continuing to do the same thing. Might have to try reinstalling the game, any suggestions . There could be be an underlying problem with gaming rig which could be causing these problems.
     
  6. Bart S

    Bart S Member

    Joined:
    Oct 5, 2010
    Messages:
    821
    Likes Received:
    84
    If you had an ATI/AMD card before I suggest a clean install, may not fix anything for you but it helps to be sure. Theres a great guide over at 3dguru. Dont use CCleaner trust me. All in all tho I think your numbers add up in the first post, dont expect too much more at this time in beta build 60.
     
  7. Marek Klyk

    Marek Klyk Registered

    Joined:
    Jan 15, 2012
    Messages:
    5
    Likes Received:
    0
    In my opinion ATI for rFactor was not right chooise, its known that Nvidia perform lot beter with rf,rf2 for a example I run
    rf2 on Ci7 920 non OC 2.66 ,6gb ram ,GTX480 which is set to deliver max quality thru driver settings(x32 AA fullscreen forced,all picture quality settings set to highest quality ,ambient oclusion which by default is off set to quality) ,screen res is 1920x1080 ,in rf2 all picture quality settings on highest possible and it run smooth on 60fps(v-sync) all time even with 20 cars on grid.I found that ambient oclusion which is off by default in driver settings improve weather effects
     
  8. Bart S

    Bart S Member

    Joined:
    Oct 5, 2010
    Messages:
    821
    Likes Received:
    84
    Cookie its a possibility that rFactor is loosing focus when it drops to desktop, does it crash ordoes it just drop to task bar and you arnt able to re-focus it. Many programs on your system can make rFactor drop to desktop especially with the UAC active.
    Try kill all unnecessary processes and services and reduce your clock to medium OC.
     
  9. cookie

    cookie Registered

    Joined:
    Mar 7, 2012
    Messages:
    144
    Likes Received:
    1
    Hi, Bart yes I can re-focus it , but I gave up on the prolbem and reformat the SSD loaded windows rfactor and drives only.Improved FPS + 10 still slight stutter in Mills , but runs smooth at portugal with lower FPS [65] , and I must say Portugal looks Simply Stunning.
     
    Last edited by a moderator: Mar 12, 2012
  10. Bart S

    Bart S Member

    Joined:
    Oct 5, 2010
    Messages:
    821
    Likes Received:
    84
    Have u tried stopping replay recordings?
     
  11. D1Racer

    D1Racer Registered

    Joined:
    Jan 10, 2012
    Messages:
    193
    Likes Received:
    1
    Agreed, stopping replay recording gave me a fairly huge FPS boost.
     
  12. Bty

    Bty Registered

    Joined:
    Sep 15, 2011
    Messages:
    112
    Likes Received:
    0
    Before and after you overclock check you CPU temperature.

    If it goes above 70C, stop. You will need a better cooler to make it work.
     
  13. cookie

    cookie Registered

    Joined:
    Mar 7, 2012
    Messages:
    144
    Likes Received:
    1
    Yes stop replay recordings but made no improvement .

    CPU temperature stock clock = 35deg c /30% over clock = 55 deg c
     
  14. Bart S

    Bart S Member

    Joined:
    Oct 5, 2010
    Messages:
    821
    Likes Received:
    84
    Try install MSI Afterburner if you havn't already and overclock your card slightly from there turn off overdrive. Try get the onscreen overlay to display your 3D-2D mode onscreen in AB while playing, see if your clock is switching between 2d and 3d mode if thats not the issue see if the clock is jumping up and down at all. You will have to configure MSI AB to display the details you need onscreen.
    If your card is running as it should keeping clock, I would start looking into your system for slowdowns perhaps you have a large paging file or something. Or some background routine task is kicking in.
    Also you should know do not have Firefox running turn it off and any other large apps.
    Also you could look into your cpu clock multiplier to see if that is shifting.
    Hope it helps.
     
  15. Jani Kankaanpää

    Jani Kankaanpää Registered

    Joined:
    Dec 30, 2011
    Messages:
    177
    Likes Received:
    1
    http://www.guru3d.com/article/radeon-hd-7970-overclock-guide/

    Very good overclocking guide to 7970, i followed instructions and works like a charm, no even need to use OC programs.
    7970 is really easy and safe overclock with those instructions.
    I dropped about 25 in both gbu and memory max setting and working.

    Difference was in 3d mark 2011, no overclocking about 7800 with overclocking 8900 points.
     
  16. bander

    bander Registered

    Joined:
    Jan 10, 2012
    Messages:
    57
    Likes Received:
    0
    now have the same nvidia 9500 gt performance an ati hd a 5750 in rfactor2.
    in rfactor 1 with the HD5770 I take my brother more than 70 frames.

    bone that something is happening within the game or ati drivers is wrong. I hope you fix it please.
     
  17. Lecram

    Lecram Registered

    Joined:
    Mar 14, 2012
    Messages:
    202
    Likes Received:
    12
    I have a ati hd 6800 and had really low framerates (15ish) on Spa for example but after turning off hdmi audio in the device manager and setting sync to gpu, things went berserk! :D 100 at spa alone, 90 at monaco, its runnin so smooth, I'm so happy my armpits are sweating lol
     
  18. cookie

    cookie Registered

    Joined:
    Mar 7, 2012
    Messages:
    144
    Likes Received:
    1
    HI , Jani what settings did you use in 3d mark 2011 [1280x720 ]

    My score was 8389 no over clock @ 1280x720 , It said this is low for my system .
     
  19. Jani Kankaanpää

    Jani Kankaanpää Registered

    Joined:
    Dec 30, 2011
    Messages:
    177
    Likes Received:
    1
    Default settings, same res, actually you cannot change settings without bought the software.

    You got good points without OC, if you oc your gpu you go nicely over 9000 points.

    Be sure you update 3dmark for latest version too, it offers it to you when you start it if needed.
     
  20. bastins

    bastins Registered

    Joined:
    Mar 15, 2012
    Messages:
    67
    Likes Received:
    2
    I don't know if this is of any use to anyone, but I've been getting great performance from my HD 6870 (12.2). In-game settings are high/max(?), and gameplay has been flawless so far.
     

Share This Page