Disable LEDS on Fanatec P1 wheel

Discussion in 'General Discussion' started by BeefyPeeg, Oct 11, 2019.

  1. BeefyPeeg

    BeefyPeeg Registered

    Joined:
    May 7, 2016
    Messages:
    10
    Likes Received:
    6
    Does anyone know of a way to disable the LED display on the Fanatec P1 Xbox/PC wheel? I've tried Fanaleds, but it doesn't seem to be working. Any help would be really appreciated.
     
  2. Powersky

    Powersky Registered

    Joined:
    Oct 3, 2019
    Messages:
    6
    Likes Received:
    3
    Black tape.
     
  3. Bidle

    Bidle Registered

    Joined:
    Jul 13, 2019
    Messages:
    21
    Likes Received:
    14
    Not yet using Fanaleds, maybe you already tried it. Just to be sure.

    rFactor 2


    • Before playing you need to install the rFactor plugin. This file should be located in the "additional\rFactor2 plugin" folder in the Fanaleds installation path.
    • Copy the "FanaLEDsPlugin.dll" file to your "rFactor2\Plugins" folder. Example: D:\rFactor2\Plugins
    Navigate to "rFactor2\UserData\Controller\ClubSport Wheel.ini" and look for these two lines:


    • Use Additional Hardware Features="1" // Whether to use additional hardware features like steering wheel LEDs
    • Hardware 3Digit Display="1" // If hardware has 3-digit display, 0=off, 1=gear, 2=speed
    If you change the "1" values to "0", native support will no longer be enabled so it does not interfere with Fanaleds.

    Note: If you're using a custom profile, edit the corresponding .ini file!
     
  4. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,520
    Likes Received:
    927
    All my LED and even OLED screen on my Formulav2 don't work anymore in rF2 at all.
     

Share This Page