Did the Stable Horizon setting break?

Discussion in 'Technical & Support' started by Gevatter, Apr 6, 2019.

  1. Gevatter

    Gevatter Registered

    Joined:
    Dec 23, 2015
    Messages:
    45
    Likes Received:
    19
    I like my cockpit to not move, and setting Stable Horizon to Off did the trick in the previous versions. This is the first ime I've played since the last update, und now setting it to Off looks the same as setting it to High. Low and Med still change the behaviour, it's just not posible atm to turn cockpit movements off atm.
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,996
    Likes Received:
    2,800
    Do you still have head movement off?

    *I mean "Head Physics"
     
    Last edited: Apr 6, 2019
  3. Gevatter

    Gevatter Registered

    Joined:
    Dec 23, 2015
    Messages:
    45
    Likes Received:
    19
    Ah sorry, I forgot. Yes head physics are off, also the cockpit vibration settings in the player.json file are set to 0. It only started happening after the last update for me as well, was OK before.
     
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,996
    Likes Received:
    2,800
    Mine stays still fine, with head physics on 0 and stabilize horizon set to Off. I've probably also set the player.json vibration settings, was a long time ago.

    Are you using VR or screen(s) ?
     
  5. Gevatter

    Gevatter Registered

    Joined:
    Dec 23, 2015
    Messages:
    45
    Likes Received:
    19
    Triple screens. You're on the latest version as well I presume, as per Steam auto updates?
    Just wanted to pose the question before going on to reconfiguring all my settings, but ifit also still works correctly for other people I'll do the ususal procedure, Steam Integrity check -> delete player profile -> reinstall.
     
  6. Gevatter

    Gevatter Registered

    Joined:
    Dec 23, 2015
    Messages:
    45
    Likes Received:
    19
    Upon further testing it is now clear that only the Reiza DLC cars display this behavior. Stock S397 content and mods work as intended, so the setting itself is fine I guess. I discovered that if you set the "Stable Horizon" setting in rF2 to low, med or high it works as intended and the amount of cockpit movement changes accordingly, but if you set it to off, it behaves like the high setting.

    There is already an ongoing discussion about this in the Reiza forums, do I guess this thread could be closed as it's no fault with rF2 imo.
     
    Last edited: Apr 6, 2019
  7. Davvid

    Davvid Registered

    Joined:
    Feb 11, 2012
    Messages:
    142
    Likes Received:
    22
    But it's bad if purely rF2 setting can be somehow overridden in the mod. It's not the way it should be.
     
  8. Gevatter

    Gevatter Registered

    Joined:
    Dec 23, 2015
    Messages:
    45
    Likes Received:
    19
    I don't think it's overridden, more that the OFF setting somehow doesn't register correctly for these cars. It's been logged as a bug in Reiza's forum so it will be sorted out in due time.
     
  9. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,996
    Likes Received:
    2,800
    Off just means you only see what the car is generating, and for the game settings to not control the head movement (fully) in that case means the cars are doing something different to the rest of them. Strange one indeed.

    I do recall seeing this mentioned early on in one of the Reiza threads, but I forgot about it when responding to this thread. At least we know the cause now.
     
    Gevatter likes this.

Share This Page