[DevMode] Waypoints deselection mess

Discussion in 'Technical Archives' started by Kev, Mar 9, 2013.

  1. Kev

    Kev Registered

    Joined:
    Oct 28, 2010
    Messages:
    156
    Likes Received:
    0
    When i modifying corridors, weird behavior of waypoints selection happens really often.
    What i do is this: select group of waypoints, modify their corridors with Ctrl+Shift+Arrows, deselect some of waypoints, modify corridors of remained waypoints, deselect, modify, deselect, etc...
    But when i try to deselect second time (sometimes at first deselect too), seems like something internally messed up and deselected become totally different waypoints then that were inside of selection rectangle. If rect is small - no waypoints affected (nothing happens), if rect is big - deselecting random waypoints, sometimes one over one.
    This bug really pissed me off while i worked with one AIW, i almost abandoned it.

    One thing i understood in my life is that its really difficult to teach developers to fix all tinny bugs before add huge new features. And thats sad... Is it hard to understand that customer buy product for features and calls refund for this tinny bugs and issues? Althrough they are tinny, but they affecting impression pretty much. Ugh...
     
  2. MikeZ

    MikeZ Member

    Joined:
    Oct 11, 2010
    Messages:
    94
    Likes Received:
    1
    Thanks for the info. I've managed to reproduce this & we're looking into a fix for it.
     

Share This Page