SOLVED Dedicated server weather settings not working

Discussion in 'Technical & Support' started by Andy Bonar, Oct 10, 2020.

  1. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    614
    Likes Received:
    76
    Hi all
    I am trying to setup a 40 minute race with weather dry at the start, turning to wet through the race.

    Practice is wet, qualifying dry.

    I have set this up in the dedicated server tool, and all looks good.
    Practice and quallifying work as expected, but the race goes all wrong.
    It starts light rain around the time I would expect, but then stops again soon after.
    Checking back in the server weather settings, and they have changed all by themselves. If these settings were what I had put in, then the race weather would most likely be correct.

    Pulling my hair out here, and suggestions?


    Here are the practice settings, all works ok
    practice.JPG



    Here are the qually settings, again works fine:
    q.JPG

    Here are the race settings: (I have tried loads of different weather rain levels etc but nothing seems to work)
    raceinitial.JPG


    So, you race in these settings, and it briefly rains, then stops, and the skies clear.

    I check the server settings, and see this:

    brokenrace.JPG


    Ive been trawling through json files but im at a loss.
    Tried on a different server, same problem.

    Just to add, ignore the random weather tick, as i was messing around with that when i took the screenshots
     
    Last edited: Oct 10, 2020
  2. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    884
    Likes Received:
    1,334
    try disabling "Random" at the bottom
     
  3. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    614
    Likes Received:
    76
    Hi Corti
    I edited my post to say ignore the tick box for random. I had put that in after I had done loads of different testing and then took the screenshots
     
    Corti likes this.
  4. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    614
    Likes Received:
    76
    Ok, so I have found the .wet file in the settings folders.
    Having a look at that as it seems to correlate with the server settings.
    Bit of a pants way to set up a race, but it looks promising.....
     
    Corti likes this.
  5. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    614
    Likes Received:
    76
    Well, ive got it working.

    In typical rf2 fashion, setting it up with the dedicated server tool, it doesnt apply the settings correctly.
    Editing the .wet file with the settings you want seems to do the trick and is then saved,

    What I dont understand is why the tool doesnt appear to save changes ot it, after it it created the file in the first place, so its not a file permissions issue.

    I suppose it could be just my system thats weird, but it seems a bit botched.
     
  6. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    614
    Likes Received:
    76
    Just wondering if anyone has successfully used the dedicated server tool to create a changing weather race?
    Im trying to setup a race but the settings just arent applying correctly.
    You can set it up, save it, join the server and its not how it should be.
    Go back onto the server, check the settings, and they have changed.
    Tried deleting the wet file but still the same.
     
  7. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    884
    Likes Received:
    1,334
    I'm sorry we do not configure the weather, we use the plugin (Real Weather). But I can only think of thinking if you have activated the option "Weather Type" = "scripted"
    Sin título.png
     
    Andy Bonar likes this.
  8. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    614
    Likes Received:
    76
    Thanks for the reply Corti
    Yes, I do select scripted, but that seems to change to that automatically as soon as you make a change to the weather in the previous settings.
    It just doesnt make sense why you set it up and they arent saved.
    Im testing a manually edited wet file, and hopefully this looks like it might work, but it really is wrong.
    The sim looks pretty darn great now with the new wet reflections, but it shouldnt be this hard to setup a wet to dry or dry to wet race to see it in all its glory.
    The dedicated server really needs an overhaul.
    So many things are having to be set up in json files, wet files, and who knows what else....
     
  9. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,579
    Likes Received:
    656
    [​IMG]

    You use this one?

    Make sure your UID matches what is in the customplugins JSON and that your API key is working.
     
    Corti likes this.
  10. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    614
    Likes Received:
    76
    I havent seen that one before....I'lll have a search
     
  11. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    614
    Likes Received:
    76
    Thanks Woodee
    Found it, that looks grat for live weather, will maybe use that at some point.
    Shame you dont seem to be able to set more than one period of weather change if you use it manually, or it would be perfect for us
     
    Corti likes this.

Share This Page