Dedcated server won't upgrade to ver 1128

Discussion in 'General Discussion' started by JohnW63, May 15, 2022.

  1. JohnW63

    JohnW63 Registered

    Joined:
    Dec 13, 2011
    Messages:
    177
    Likes Received:
    2
    I've run the update batch file on my server a number of times but it stays at 1126. It gets small updates, but does not move to ver 1128.

    Anything I should try?
     
  2. Lars

    Lars Registered

    Joined:
    Apr 29, 2017
    Messages:
    58
    Likes Received:
    28
  3. JohnW63

    JohnW63 Registered

    Joined:
    Dec 13, 2011
    Messages:
    177
    Likes Received:
    2
    I edited the suggested batch file to the below, to make sure it installed in my rF2 folder.
    steamcmd +force_install_dir +login anonymous C:\Games\rFactor\rfactor2-dedicated +app_update 400300 -validate -beta v1128 +quit

    Every time I run it, it looks to be installing stuff, but if I run it a second time, it does not say that it's up-to-date and runs again.

    My path to c:\games\ has rFactor and rfactor2-dedicated and steamCMD in the directory. In other words the following are directories.

    c:\games\rfactor
    c:\games\rfactor2-dedicated
    c:\games\steamCMD

    I run the command from the c:\steamCMD\ directory.
     
  4. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,183
    Likes Received:
    817
    Your command is a bit mixed up here... below shows the install dir directly after the force install_dir command
    Code:
    steamcmd +force_install_dir C:\Games\rFactor\rfactor2-dedicated +login anonymous +app_update 400300 validate +quit
    This leads me to a question...where exactly is your dedi server setup? In your install command it's;
    C:\Games\rFactor\rfactor2-dedicated but below you say it's;
    c:\games\rfactor2-dedicated

    If it's the 2nd one then you'll need to edit your install command to;
    Code:
    steamcmd +force_install_dir C:\Games\rfactor2-dedicated +login anonymous +app_update 400300 validate +quit

     
  5. JohnW63

    JohnW63 Registered

    Joined:
    Dec 13, 2011
    Messages:
    177
    Likes Received:
    2
    Good catch.
    My fractor2 icon lists this path:
    C:\Games\rfactor\rfactor2-dedicated\Bin64

    So my batch file should look like this:
    steamcmd +force_install_dir C:\Games\rFactor\rfactor2-dedicated+login anonymous +app_update 400300 -validate -beta v1128 +quit

    When I run that version I ended up with an error
    "[ 0%] Checking available updates...
    [----] Verifying installation...
    Steam Console Client (c) Valve Corporation - version 1652487999
    -- type 'quite' to exit --
    Loading Steam API ....OK
    ERROR! Failed to request AppInfo update, not online or not logged into Steam. "
     
  6. JohnW63

    JohnW63 Registered

    Joined:
    Dec 13, 2011
    Messages:
    177
    Likes Received:
    2
    I changed the order of the batch file to have " login anonymous" before the "force_install" part and it gave me a warning to force dir before login but it then installed the update. The error above made me think it didn't get logged in. I may try putting the order of the commands back, to test this.

    So, it worked in this form: ( With a warning )
    steamcmd +login anonymous +force_install_dir C:\Games\rFactor\rfactor2-dedicated +app_update 400300 -validate -beta v1128 +quit
     
    Last edited: May 16, 2022
  7. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,183
    Likes Received:
    817
    Yep, you need a space between dedicated and +login
     

Share This Page