[REL] DAMPlugin for rF2

Discussion in 'Other' started by Lazza, Jul 18, 2015.

  1. Dave^

    Dave^ Registered

    Joined:
    Oct 14, 2019
    Messages:
    263
    Likes Received:
    121
    Sorry, yes, I meant filename.

    Mine already separates log files into track subfolders, and I'm sure I saw the option to separate into class subfolders too.


    ETA - snip from ini file:

    [Logging]
    Capture partial log = 2 // Whether a 'partial' log will be saved:
    // 0 = log every time we entered the car
    // 1 = vehicle must have moved
    // 2 = vehicle left the pits
    // 3 = started a timed lap (including race start)
    // 4 = completed a timed lap
    Log dir = "<DATA_PATH>\LOG\" // Directory to log to; relative to rFactor root if not absolute (e.g. "C:\Log files\")
    // the token <DATA_PATH> at the *START* of the dir will be replaced by the current data path,
    // while <USER_PATH> at the *START* of the dir will be replaced by the player folder
    Use class subfolder = 0 // Log to a subfolder equal to the vehicle class; 1=yes, 0=no
    Use track subfolder = 1 // Log to a track subfolder (can be combined with the class subfolder); 1=yes, 0=no
    Idle log cycles = 25000 // Log build cycles to perform per frame when idle (at monitor)
    Duty log cycles = 2500 // Log build cycles to perform per frame when busy (in-car, driving)
    Realtime building = 1 // Whether to start building completed logs while still in-car; 1=yes, 0=no
    Save Setup File = 1 // Save a copy of the current garage setup file with the log; 1=yes, 0=no
     
    Last edited: Jul 30, 2020
  2. John R Denman

    John R Denman Registered

    Joined:
    Mar 18, 2018
    Messages:
    485
    Likes Received:
    579
    Worked fabulous until a recent major Windows update.
    After exiting the on track session to the paddock it takes 2 minutes or sometimes not at all for the audio command signalling the end of the Motec session. When exiting rFactor to desktop it hangs in a loop.

    I'm sure its a Windows configuration setting, just can't figure out which.

    Any ideas?
     
  3. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,000
    Likes Received:
    5,694
    Make sure you have the latest version, this cropped up a while ago and I made changes which seemed to fix it.

    @Dave^ thanks for pasting that in mate, I forgot I added the option to use a track folder :p
     
    Dave^ likes this.
  4. Han131

    Han131 Registered

    Joined:
    Aug 26, 2020
    Messages:
    11
    Likes Received:
    1
    Hi, very nice knowing i can change the way for logged directory, but is there a way to change the filename itself though???
     
  5. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,000
    Likes Received:
    5,694
    No, at this stage it's set. What were you thinking? I could add more options or even let you set a format yourself.
     
  6. Han131

    Han131 Registered

    Joined:
    Aug 26, 2020
    Messages:
    11
    Likes Received:
    1
    Hi Lazza, thanks for the reply.

    So currently, all logged data will comes out in this format (YYYY-MM-DD - hr-mm-ss - Circuit - session)
    Was wondering if there can be an option where we can change the order of these just like how we can change the directory of the logged data, and also maybe include other options such as Driver Name or Vehicle etc (can be based on motec's selection column in the Open Log File window)

    So perhaps it can be done by creating separate bit code for each syntax that make up the logged data name such as:

    Logged data name: (0 - 1 - 2 - 3)
    // 0 = date (YYYY-MM-DD)
    // 1 = time (hr-mm-ss)
    // 2 = Circuit
    // 3 = session
    // 4 = Driver Name
    // 5 = Vehicle

    And we can then change it according to what we like such as (0 - 4 - 5) which will result in (YYYY-MM-DD - Driver Name - Vehicle) or even (0 - 1 - 2 - 3 - 4 - 5).

    Is that possible or perhaps abit too cumbersome to do?
     
  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,000
    Likes Received:
    5,694
    Definitely possible, I was mainly curious if there was something specific you wanted (or something currently used you didn't like) but allowing a custom format would make sense.

    It's not really something I'd thought to add because I rarely look at the files directly, I just open them from i2Pro which provides its own display anyway.

    I'll add some options for that, plus a check to avoid duplicate names (something currently avoided by always including the time).
     
  8. McFlex

    McFlex Registered

    Joined:
    Feb 23, 2012
    Messages:
    942
    Likes Received:
    291
    Hi Lazza today i noticed that the Lap Distance Channel has no unit. Is it posssible to add that?
     
  9. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,000
    Likes Received:
    5,694
    Yep :cool:

    I guess I didn't notice I hadn't done that. Thanks!
     
  10. McFlex

    McFlex Registered

    Joined:
    Feb 23, 2012
    Messages:
    942
    Likes Received:
    291
    Thanks alot
     
  11. Sufrazgil

    Sufrazgil Registered

    Joined:
    Aug 29, 2020
    Messages:
    7
    Likes Received:
    1
    Hi. Installed automatically. The installer has identified the game folder. In the folder "rFactor 2\Bin64\Plugins" appeared DAMPlugin.dll. When running, Rfactor2 does not detect the plugin. Please help.
     
  12. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,000
    Likes Received:
    5,694
    Can you create and check a trace file to confirm it's being picked up?

    Second I'd try running all the files in Support\runtimes just to make sure nothing is missing there.

    I assume it doesn't show up in the plugin list in the game?
     
    Sufrazgil likes this.
  13. Sufrazgil

    Sufrazgil Registered

    Joined:
    Aug 29, 2020
    Messages:
    7
    Likes Received:
    1
    Right.

    The Support\runtimes folder contains four files: vcredist_2012_x86.exe, vcredist_2012_x64.exe, vcredist_2013_x86.exe, vcredist_2013_x64.exe. I started them. Visual C++ 2013 has been installed, but nothing has changed.

    What should I do? I didn't understand.
     
  14. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,000
    Likes Received:
    5,694
    Sufrazgil likes this.
  15. Sufrazgil

    Sufrazgil Registered

    Joined:
    Aug 29, 2020
    Messages:
    7
    Likes Received:
    1
    I attach the trace file.
     

    Attached Files:

  16. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,000
    Likes Received:
    5,694
    Ok, that does help, but it also raises a question.

    Code:
      27.00s PluginManage  390: Analyzing plugin "DAMPlugin.dll"
      27.07s PluginManage   86: Could not load plugin Bin64\Plugins\DAMPlugin.dll with LoadLibrary(); GetLastError()=126
      27.07s PluginManage  390: Analyzing plugin "KnockoutQualifying.dll"
      27.12s PluginManage   86: Could not load plugin Bin64\Plugins\KnockoutQualifying.dll with LoadLibrary(); GetLastError()=126
      27.12s PluginManage  390: Analyzing plugin "MotecPlugin_x64.dll"
      27.18s PluginManage  417: Successfully loaded plugin "MotecPlugin_x64.dll"
      27.18s PluginManage  390: Analyzing plugin "rFactor2SharedMemoryMapPlugin64.dll"
      27.21s PluginManage  417: Successfully loaded plugin "rFactor2SharedMemoryMapPlugin64.dll"
      27.21s PluginManage  390: Analyzing plugin "StockCarRules.dll"
      27.25s PluginManage   86: Could not load plugin Bin64\Plugins\StockCarRules.dll with LoadLibrary(); GetLastError()=126
      27.25s PluginManage  390: Analyzing plugin "TrackIR_rF2_Plugin.dll"
      27.28s PluginManage  417: Successfully loaded plugin "TrackIR_rF2_Plugin.dll"
      27.28s PluginManage  390: Analyzing plugin "TrackMapPlugin_64.dll"
      27.31s PluginManage  417: Successfully loaded plugin "TrackMapPlugin_64.dll"
    
    As you can see, my older MotecPlugin is loading, but my DAMPlugin and the KnockoutQualifying & StockCarRules plugins aren't loading (those last 2 are standard ones, and come with the game). This would suggest a missing dependency of some sort - either some runtimes not installed, or a required dll/library missing on your system.

    Now, the last one: TrackMapPlugin. That hasn't worked (as in, actually done anything) since we switched to dx11 about 3 years ago. This suggests there could be old files floating around and interfering with things.

    For those ones not working, are you sure you ran and installed all 4 of those runtimes? For my first motec plugin to work, but not the second, would suggest one of the newer runtimes DAMPlugin uses isn't available, or something about the interaction of that runtime and the game isn't working.

    You could also try verifying your rF2 files through steam just to make sure something required isn't missing. Other than that we're down to the runtimes, and that's probably it - if the game is working otherwise then most requirements should be taken care of.

    On a positive note, it's definitely installed correctly and seen by the game.

    You may, at some point, want to clean out the folder completely and start fresh. That may help this issue, depending what's causing it. You can move/delete everything except the Installed folder, verify files with a modest download, and that will be completely fresh. The Installed folder has the actual content and you shouldn't need to download all that again (hopefully there's no old files in there that might also cause issues...)
     
    Sufrazgil likes this.
  17. Sufrazgil

    Sufrazgil Registered

    Joined:
    Aug 29, 2020
    Messages:
    7
    Likes Received:
    1
    DECIDED

    1. Checked my rF2 files via steam.
    there was one broken file, but it didn't solve the problem
    2. Once again, I started all the "vcredist*" files in the "SteamLibrary\steamapps\common\rFactor 2\Support\Runtimes" folder, rebooted the computer.
    everything worked

    7.37s PluginManage 390: Analyzing plugin "DAMPlugin.dll"
    7.37s PluginManage 417: Successfully loaded plugin "DAMPlugin.dll"

    THANK YOU
     
    Lazza likes this.
  18. Han131

    Han131 Registered

    Joined:
    Aug 26, 2020
    Messages:
    11
    Likes Received:
    1
    Hi Lazza, Thanks for the reply and look forward to the next update from you, hopefully with the mentioned functionality.

    Yea unfortunately, I sometimes would need to go through 20 or more different runs and it can sometime be a nightmare, in real life we specified the file name when we download from the car which is not an issue, but yea thank you again for the attention, top job !

    Looking forward !
     
  19. Arcturus

    Arcturus Registered

    Joined:
    Feb 22, 2020
    Messages:
    5
    Likes Received:
    4
    Friends, please help!
    Day after day, I struggle with a problem and I can not solve it.
    The plugin does not log.
    The DAMPlugin_Error.txt file says:
    09/14/20 01:12:15 Error: Can't create output subfolder:
    09/14/20 01:12:15. \\ DAMPlugin \ LOG \ IC18 \
    09/14/20 01:12:15 Error creating file:
    09/14/20 01:12:15. \\ DAMPlugin \ LOG \ IC18 \ 2020-09-14 - 01-12-15 - Louisiana - Indy Grand Prix - P1.ldtemp
     
  20. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    3,042
    Likes Received:
    1,950
    Have you tried to create the path manually?
     

Share This Page