CSL Pedals LC

Discussion in 'Technical & Support' started by MARLINLEG, Apr 7, 2019.

  1. MARLINLEG

    MARLINLEG Registered

    Joined:
    Feb 5, 2017
    Messages:
    15
    Likes Received:
    7
    Hello and thank you all in anticipation

    I am a 71 yr old simmer and my problem is I can’t get the CSL Elite LC pedals to work in rFactor 2 I have uninstalled Fanatec drivers then reinstalled

    well they stop the car in a fashion but no way good enough to race with . They work in Assetto Corsa /Project cars2 / automobilista but still not good enough to race with

    I press the brake as hard as I can but they don’t stop the car as they should no way I can race . The wheel works fine and the pedals they all show in Fanatec tuning screen on pc before loading game via steam. I haven’t touched the on wheel tuning

    It will be me missing something . You advice please

    Kind regards to everyone



    ClubSport Wheel Base V2.5

    CSL Elite Steering Wheel McLaren GT3

    CSL Elite Pedals LC


    My pc spec

    Intel i7 Skylake 6700K 4Ghz CPU

    Akasa Heat Sink & Fan

    Gigabyte Z170-HD3P Motherboard

    NVidia GTX 1080 DDR 5 8Gb Graphics

    16GB Kingston Hyper X Fury DDR4 2400MHz

    Iiyama 27" Prolite 2790HS x 3

    Samsung 1TB SSD 850 EVO Series

    DVD Re-Writer

    Lan

    USB2.0/3.0/3.1

    Aerocool Deluxe Midi Tower Case

    Bequiet 700w PSU

    Windows 10 Operating System 64 Bit
     
  2. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    825
    Go to single player > Options > Controls and assign Throttle, Brake and Clutch.
    71.jpg
     
  3. 006

    006 Registered

    Joined:
    May 5, 2017
    Messages:
    30
    Likes Received:
    26
    I have the csl elite base so im not sure if the tuning menu on the wheel is the same, but with the pedals connected to my base there is a brf or brakeforce option in the tuning menu which may help you. The lower you set it the less force is required to achieve maximum braking.
    If you've connected them to your pc via usb then there should be a slider to adjust it in the properties page for the pedals in windows. Maybe this will help.

    Edit: and if your wheel tuning menu doesnt have the brf option also have a rummage around in the properties page for the wheel in windows, im sure the option must be around there somewhere! (sorry im pretty much useless with everything to do with computers :p)
     
    Last edited: Apr 7, 2019
  4. MARLINLEG

    MARLINLEG Registered

    Joined:
    Feb 5, 2017
    Messages:
    15
    Likes Received:
    7
    Thanks
     
  5. Akela_DE

    Akela_DE Registered

    Joined:
    Jan 23, 2018
    Messages:
    372
    Likes Received:
    253
  6. MARLINLEG

    MARLINLEG Registered

    Joined:
    Feb 5, 2017
    Messages:
    15
    Likes Received:
    7
    Thank you I have sorted the brakes ,I plugged the pedals via wheel base ( they were plugged into usb on pc) and it’s now showing
    BRF range: OFF 010 ... 100 BRF default: 050
    GOOD TO RACE there is VAST improvement
    Many thanks you ALL
     

Share This Page