creating a server with triggered ports

Discussion in 'Online Racing Discussion' started by grblade954, Apr 1, 2020.

Tags:
  1. grblade954

    grblade954 Registered

    Joined:
    Mar 11, 2020
    Messages:
    11
    Likes Received:
    2
    Untitled.png

    hello guys!

    managed to create a server and open those ports.

    i still cannot see the server I created, in the multiplayer rfactor 2 section.

    am i doing something wrong?

    thank you!
     
  2. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    390
    Likes Received:
    92
    port triggering is not the same as port forwarding.

    edit
    Having a second look, it looks like they have relabelled port forwarding to port mapping
     
    grblade954 likes this.
  3. grblade954

    grblade954 Registered

    Joined:
    Mar 11, 2020
    Messages:
    11
    Likes Received:
    2
    also says port mapping

    in firewall menu only says on/off
    and firewall level
     
  4. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    767
    Likes Received:
    470
    Yes, if you read your screen shot you can see that you're port triggering and you have no port mapping (the description in your screenie for port mapping is "port mapping allows remote computers to connect to a specific within your private network") My interpretation of that is that you need to go to port mapping.
     
    grblade954 likes this.
  5. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    767
    Likes Received:
    470
    upload_2020-4-2_7-52-14.png
     
    grblade954 likes this.
  6. grblade954

    grblade954 Registered

    Joined:
    Mar 11, 2020
    Messages:
    11
    Likes Received:
    2
    came up with this error
     

    Attached Files:

  7. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    390
    Likes Received:
    92
    open a command prompt/cmd and type in ipconfig and press enter.

    Look in the results for ip4 address
     
  8. grblade954

    grblade954 Registered

    Joined:
    Mar 11, 2020
    Messages:
    11
    Likes Received:
    2
    Connection-specific DNS Suffix . : station
    Link-local IPv6 Address . . . . . : fe80::59cc:ecf0:e185:f532%10
    IPv4 Address. . . . . . . . . . . : 192.168.2.7
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.2.1

    refers to my PC, cannot understand what is the change in LAN subnet as that error says
     
  9. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    390
    Likes Received:
    92
    the ip address you've entered is correct.
    reboot router and pc
     
  10. grblade954

    grblade954 Registered

    Joined:
    Mar 11, 2020
    Messages:
    11
    Likes Received:
    2
    managed to do it but still cannot find the server I create

    needs reboot after mapping?
     
  11. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    390
    Likes Received:
    92
    on the old routers, the new settings wouldn't take effect until it was rebooted.
     
    grblade954 likes this.
  12. grblade954

    grblade954 Registered

    Joined:
    Mar 11, 2020
    Messages:
    11
    Likes Received:
    2
    mine is quite new vdsl
    so it had to work right away
     
  13. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    390
    Likes Received:
    92
    I'm wondering if your router is telling you to change the subnet for security reasons. the subnet is the number 2 in the ip address. it would mean you would have to assign your pc a static ip address in your home network.

    example 192.168.3.7
     
  14. grblade954

    grblade954 Registered

    Joined:
    Mar 11, 2020
    Messages:
    11
    Likes Received:
    2
    its okay but still cannot see the server after mapping.
    gonna find out tomorrow
    G N and thank you so much!!!!
     
    Mangoletsi likes this.
  15. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    390
    Likes Received:
    92
  16. Stefan_L_01

    Stefan_L_01 Registered

    Joined:
    Nov 18, 2012
    Messages:
    425
    Likes Received:
    244
    try disabling ipv6 support in your router
     
  17. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    767
    Likes Received:
    470
    When you go to rf2 multiplayer look in the LAN view (see pic). I can only see my server in that view but my mates can see it in WAN. This is a FEATURE of my router not allowing me to see my PC on WAN from inside the LAN network.
    upload_2020-4-3_7-51-44.png

    Hope that helps.
     
  18. grblade954

    grblade954 Registered

    Joined:
    Mar 11, 2020
    Messages:
    11
    Likes Received:
    2
    thank you! already tried this with no luck
     
    JimmyT likes this.
  19. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    767
    Likes Received:
    470
    So is the server on the same PC as your client?
    Have you checked in your Multiplayer.json on your server to see if the ports you've opened are the ones stated in the json?
    "HTTP Server Port":64297,
    "Simulation Port":54297,
     
  20. grblade954

    grblade954 Registered

    Joined:
    Mar 11, 2020
    Messages:
    11
    Likes Received:
    2
    just checked it! it is all as u mentioned
     

Share This Page