create car’s folder

Discussion in 'Car Modding' started by elec86, Feb 8, 2021.

  1. elec86

    elec86 Registered

    Joined:
    Jan 7, 2021
    Messages:
    78
    Likes Received:
    0
    I want to create a car for rfactor2
    in the CAR MODDING TUTORIALS WORKFLOW 01 i see

    Recommended setup for you car’s folder :
    1 - Create a new folder in Vehicles directory (we’ll use “test_car” as example here)
    2 - open the rTrainer main folder and copy all files

    where are located these files to be copied ?

    thanks
     
  2. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,976
    Likes Received:
    687
    I suppose that the Skip Barber Car is meant.
    rTainer was a similar Car in rFactor 1.
    The Files can be found in the Folder
    ...\rFactor 2\ModDev\Vehicles\SkipBarber
     
  3. elec86

    elec86 Registered

    Joined:
    Jan 7, 2021
    Messages:
    78
    Likes Received:
    0
    thank you
    I have indeed looked the skip barber but I do not see the files susp.pm and tires files (version stream )
     
  4. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,976
    Likes Received:
    687
    You have to "translate" the Descriptions from the CAR MODDING TUTORIALS WORKFLOW as it seems.
    The susp.pm is the SkipBarber.pm (the File Extension is the important Thing) and the Tire Files are the *.TGM Files and the *.TBC File(s) belong to the Tires too.
     
  5. elec86

    elec86 Registered

    Joined:
    Jan 7, 2021
    Messages:
    78
    Likes Received:
    0
    the files in the photo are the right ones
    [​IMG]

    thank you
     
  6. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,976
    Likes Received:
    687
    Yes, but as you can see, there are 2 *.tbc Files.
    That can be used for different Classes of a Car for Example or also for different Tire Combinations, as it gets used in the F1 for Example.
    You always have to check the whole "Package". ;)
    And i forgot to mention, that normally the *.pm Files are not in use anymore.
    In rF2 it's a Chassis.ini.
    But to be sure, check if the *.pm File is linked in the HDV File in the [SUSPENSION] Section.
    If it's there and has 2 Slashes // in Front of the Entry, it's deactivated.
    And if a *.pm AND a Chassis.ini are linked and none of them is deactivated, the Chassis.ini gets used by deafult.
     
  7. elec86

    elec86 Registered

    Joined:
    Jan 7, 2021
    Messages:
    78
    Likes Received:
    0
    when i want Getting your first mesh in showroom I cannot rename , the Sub-Material” fields with “temp_test”
    as requested in workflow 1
    if I select the field sub materialI go to materal map browser
    [​IMG]
     
  8. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,976
    Likes Received:
    687
    That is correct and in the Material/Map Browser, you select the gMotorMaterial as shown in the below Screenshot.
    If it is not there, click on Rendering in the main Menu and then "Render Setup" and in the 3rd Dropdown "Renderer:" select the Scanline Renderer and close the Render Setup Window.
    Now the gMotorMaterial should be available.

    gmotor-mat-in-mat-browser.jpg
     
  9. elec86

    elec86 Registered

    Joined:
    Jan 7, 2021
    Messages:
    78
    Likes Received:
    0
    I’m looking for the file to use for the curent scene files

    can you guide me ?[​IMG] thanks
     
  10. elec86

    elec86 Registered

    Joined:
    Jan 7, 2021
    Messages:
    78
    Likes Received:
    0
    in which directory must be passed current scene file
    can you help me ?

    thank
     
  11. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    1,976
    Likes Received:
    687
    You can ignore that, because you are working at a Car as you write.
    A scn File is used for Tracks and is located in the Folder/Subfolder of a Track.
     
  12. elec86

    elec86 Registered

    Joined:
    Jan 7, 2021
    Messages:
    78
    Likes Received:
    0
    when i export with GMT Outpout
    it use a Multi/Sub material as a container for gMats (see)

    [​IMG]

    i have the message " top level materiel be multi /sub"
    can you help me ?
     
  13. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,719
    Likes Received:
    1,366
    If you're trying to export with the material in that image, it's not a multi/sub object.
     
    redapg likes this.
  14. elec86

    elec86 Registered

    Joined:
    Jan 7, 2021
    Messages:
    78
    Likes Received:
    0
    here is the approach I use

    [​IMG]
     
  15. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,719
    Likes Received:
    1,366
    Ok, if you do that, it'll work, but the first image you posted is not using a multi/sub.
     
    redapg likes this.
  16. elec86

    elec86 Registered

    Joined:
    Jan 7, 2021
    Messages:
    78
    Likes Received:
    0
    I exported my first test (box 001)
    here is the result obtained
    [​IMG]


    I put the file box 001 . gmt in my file .... devmod/vehicule/maps..but in my showroom my box001 does not appear

    that this is happening"he?
     
  17. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,719
    Likes Received:
    1,366
    Did you add it to the spinner file?
     
  18. elec86

    elec86 Registered

    Joined:
    Jan 7, 2021
    Messages:
    78
    Likes Received:
    0
    Is the following procedure correct?

    - Open “test_car_Spinner.gen” file
    - Delete everything under the Actor=VEHICLE line except for } at the last line.
    - replace MeshFile=rter_body_max.gmt with MeshFile=test_cube.gmt
     
  19. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,719
    Likes Received:
    1,366
    You'll need something like:
    Instance=XXX
    {
    Moveable=True
    MeshFile=XXX.gmt CollTarget=False HATTarget=False LODIn=(0.0) LODOut=(30.0) ShadowCaster=(True, Solid) ShadowReceiver=True
    }
     
  20. elec86

    elec86 Registered

    Joined:
    Jan 7, 2021
    Messages:
    78
    Likes Received:
    0
    I applied the changes

    here is the image I have when starting rfactor 2
    [​IMG]



    when I activate race I have the message

    [​IMG]
     

Share This Page