crashes to launch panel

Discussion in 'Technical & Support' started by reginald mitchell, Mar 15, 2018.

  1. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    884
    Likes Received:
    557
    Darrel, the 4 runtime files in the directory are the installation executable files, you should run them and they will repair / re-install the required applications into your rF2 main game. The runtime files can be corrupted when installing drivers that interact with rF2, it was a good and valid suggestion to try.
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,489
    Likes Received:
    4,514
    Just a correction, the runtimes are installed into windows. The game doesn't look for those files itself or care if they're there - it just needs them installed to run.

    I'm not even sure one of them missing will cause this error (or, cause steam to fail to run the game and then pop this error up, which is the more likely sequence) so this could be a good learning.
     
  3. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,657
    Likes Received:
    2,580
    In Steam, make sure the box under launch options is empty. Follow Lazza's advice and right click on each one of those files in the Support\Runtimes folder and RUN THEM.(open) Launch from Steam, run the video config first. Then click ok on the video config box(after ensuring your vid card and screen resolution is correct) Then press play again and choose the first option.
    upload_2021-5-25_23-9-33.png
     
  4. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,657
    Likes Received:
    2,580
    Yes it MUST be an error with rF2, that is why it does not work for any of us. We haven't been able to play it for years, we were just to embarrassed to tell anyone. You are launching via steam correct?
     
  5. durielk

    durielk Registered

    Joined:
    Dec 19, 2016
    Messages:
    41
    Likes Received:
    2
    OK, I ran all 4 files, and as suggested above, it does not help.
    If they want to stay in the business, they probably need to retain some people that understand how their program works and know something about it.
     
    Last edited: May 26, 2021
  6. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,489
    Likes Received:
    4,514
    You need to help yourself as well. From the start you're blaming rF2 despite the fact it isn't running, and I pointed this out so you don't do the pointless reinstalling we often see - there's no issue with any of the game files, because it isn't even getting to the point of using any of them. It simply isn't running.

    If you didn't already I would suggest uninstalling and reinstalling those runtimes, just to rule them out as an issue. Then you're back to searching for possible fixes, which will be easier if you accept rF2 doesn't have an internal issue. (I've suggested two or three times already to search and find things to try, but you just stamp your feet and demand rF2 fix what isn't an rF2 problem)

    But from your post in another thread you apparently did "everything" to uninstall your video drivers, so it's anybody's guess what might be broken on your system.
     
  7. durielk

    durielk Registered

    Joined:
    Dec 19, 2016
    Messages:
    41
    Likes Received:
    2
    I completely reinstalled rf2 & steam, all new. What is the issue? It still does not run, AC does, everything else does. I don't know what else to do.
    I don't know and you don't either, quit with the victim blaming.
     
  8. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    525
    Likes Received:
    126
    Guys,

    Someone explain to @durielk how to create a shortcut to rFactor2.exe from inside the BIN64 folder, onto his desktop.

    Then right mouse click on the shortcut, and click on properties, and delete the \Bin64 part in the Start in section.
    Untitled.png

    This shortcut will BYPASS STEAM, and will show 100% if its a Steam or rFactor2 issue.
     
  9. durielk

    durielk Registered

    Joined:
    Dec 19, 2016
    Messages:
    41
    Likes Received:
    2
    OK, I tried that from post #28, it started rF2! I didn't go to a track, but got the opening screen up and it looked like it works. So we are back to steam. Why is steam involved again?
    Kudo's, you win the banana!!! WTG!
     
  10. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    525
    Likes Received:
    126
    Steam is involved, as the mods and tracks are hosted on Steams servers. The shortcuts point to steam on startup, as it checks for new content, and updates for mods and tracks.

    The primary reason why you experience a failed launch, is the steam database/log corruption, and doesn't know you own rFactor2. The only way I have found to combat this, is to log out of steam, restart the pc, log into steam using your user name and passward, then steam sends your pc a update of what games you own.

    The other issue has been anti virus randomly blocking steam games launching.
     
    lagg likes this.
  11. durielk

    durielk Registered

    Joined:
    Dec 19, 2016
    Messages:
    41
    Likes Received:
    2
    Hey thks Man'si. That sounds like it could be it and I haven't tried that yet.
    I'm traveling till tomorrow night and check this out. I hope that is it.
    I don't run anti virus programs other than standard W10, had too many problems with them before.
     
    Mangoletsi likes this.
  12. durielk

    durielk Registered

    Joined:
    Dec 19, 2016
    Messages:
    41
    Likes Received:
    2
    OK, once I got it started doing as per post 28. Then back at home I tried post 30. It reverted back to the old build and only had one track, old menu, etc. Tried again and verified the file, the new build started but then the same shit started happening " +path , +...."
    So, looks like they made it so good it will not run, end of racing for me, I quit.
     

Share This Page