Crash problem on converted mod

Discussion in 'Third Party Content' started by SmashingPants67, Feb 3, 2017.

  1. SmashingPants67

    SmashingPants67 Registered

    Joined:
    Oct 9, 2015
    Messages:
    76
    Likes Received:
    14
    Hi, I'm converting one of my rFactor 1 mods to rFactor 2, it appears well on the menus and spinner, but when I go race with the car it gives me a "stopped working" message the second I click "RACE" on race direction menu.
    The contents of "trace.txt" follows as a spoiler:
    TRACE LEVEL = 3
    0.07s tracelog.cpp 218: Command line: "+path=".." "
    0.07s main.cpp 358: Version=1.1108 Build=1108
    0.07s main.cpp 359: FPU=0x0008001f
    0.07s game.cpp 1421: Setting Mod Path "Packages" 1 0
    0.07s game.cpp 1817: Entered Game::Enter()
    0.07s osman.cpp 901: Entered OSMan::Enter()
    0.07s osman.cpp 963: exe is 64-bit
    0.07s hwinput.cpp 7898: Entered HWInput::Enter()
    0.07s hwinput.cpp 7899: HKL=0x04160416
    0.12s plrfile.cpp 2934: Entered PlayerFile::Enter()
    0.29s game.cpp 1012: Setting RFM "AllCarsTracks.rfm"
    1.14s setup.cpp 2420: Drivers repeated for vehicles C:\PROGRAM FILES (X86)\STEAM\STEAMAPPS\COMMON\RFACTOR 2\MODDEV\VEHICLES\SKIPBARBER\TEAMS\SKIPBARBER_05B.VEH and C:\PROGRAM FILES (X86)\STEAM\STEAMAPPS\COMMON\RFACTOR 2\MODDEV\VEHICLES\SKIPBARBER\TEAMS\SKIPBARBER_05.VEH
    1.15s setup.cpp 2420: Drivers repeated for vehicles C:\PROGRAM FILES (X86)\STEAM\STEAMAPPS\COMMON\RFACTOR 2\MODDEV\VEHICLES\SKIPBARBER\TEAMS\SKIPBARBER_07B.VEH and C:\PROGRAM FILES (X86)\STEAM\STEAMAPPS\COMMON\RFACTOR 2\MODDEV\VEHICLES\SKIPBARBER\TEAMS\SKIPBARBER_07.VEH
    1.21s setup.cpp 2339: ATTENTION: Skipping vehicle because the filename skipbarber_05.veh matches an existing vehicle
    1.21s setup.cpp 2339: ATTENTION: Skipping vehicle because the filename skipbarber_05b.veh matches an existing vehicle
    1.21s setup.cpp 2339: ATTENTION: Skipping vehicle because the filename skipbarber_07.veh matches an existing vehicle
    1.21s setup.cpp 2339: ATTENTION: Skipping vehicle because the filename skipbarber_07b.veh matches an existing vehicle
    2.21s plrfile.cpp 2102: Attempting to save to C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\ModDev\UserData\player\player.TMP
    2.25s plrfile.cpp 2126: Retcode: 0 for renaming to C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\ModDev\UserData\player\player.JSON
    2.25s PluginManage 336: Analyzing plugin "KnockoutQualifying.dll"
    2.25s PluginManage 375: Successfully loaded plugin "KnockoutQualifying.dll"
    2.25s PluginManage 336: Analyzing plugin "SteamPlugin.dll"
    2.25s PluginManage 375: Successfully loaded plugin "SteamPlugin.dll"
    2.25s PluginManage 336: Analyzing plugin "StockCarRules.dll"
    2.25s PluginManage 375: Successfully loaded plugin "StockCarRules.dll"
    2.25s PluginManage 336: Analyzing plugin "TrackIR_rF2_Plugin.dll"
    2.25s PluginManage 375: Successfully loaded plugin "TrackIR_rF2_Plugin.dll"
    2.26s PluginManage 996: Unloading plugin "KnockoutQualifying.dll" because it is disabled according to custom plugin settings
    2.26s PluginManage 996: Unloading plugin "StockCarRules.dll" because it is disabled according to custom plugin settings
    2.26s vidman.cpp 1924: Entered VidMan::Enter()
    4.81s specialfx.cp 3773: Entered SpecialFX::Enter()
    4.81s dynman.cpp 689: Entered DynMan::Enter()
    4.84s sound.cpp 1314: Entered Sound::Enter()
    4.89s onscreen.cpp 4053: Entered OnScreen::Enter()
    4.89s game.cpp 1888: Entered Game::Setup()
    4.89s hwinput.cpp 7983: Entered HWInput::Setup()
    5.00s hwinput.cpp 7966: DirectInput enumerated 2 game controller(s)
    5.00s hwinput.cpp 1428: Controller was enumerated ...
    5.00s hwinput.cpp 1576: ... and successfully initialized
    5.00s hwinput.cpp 1428: Controller was enumerated ...
    5.00s hwinput.cpp 1576: ... and successfully initialized
    5.00s options.cpp 4686: Entered Options::Setup()
    5.07s O_AppObj.cpp 2808: Initiate options object creation
    5.57s O_OSC.cpp 2857: Entered Options_OSC_Reader::ReadOSC()
    7.65s vidman.cpp 1458: Trying to Play Video File: C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\ModDev\Options\MODMode\ISILogo.bik
    7.65s MovieMan.cpp 120: Error locating video file C:\PROGRAM FILES (X86)\STEAM\STEAMAPPS\COMMON\RFACTOR 2\MODDEV\OPTIONS\MODMODE\ISILOGO.BIK
    7.65s MovieMan.cpp 120: Error locating video file C:\PROGRAM FILES (X86)\STEAM\STEAMAPPS\COMMON\RFACTOR 2\MODDEV\OPTIONS\MODMODE\ISILOGO.BIK
    7.65s vidman.cpp 1458: Trying to Play Video File: C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\ModDev\Options\MODMode\AllCarsTracks.bik
    7.65s MovieMan.cpp 120: Error locating video file C:\PROGRAM FILES (X86)\STEAM\STEAMAPPS\COMMON\RFACTOR 2\MODDEV\OPTIONS\MODMODE\ALLCARSTRACKS.BIK
    7.65s MovieMan.cpp 120: Error locating video file C:\PROGRAM FILES (X86)\STEAM\STEAMAPPS\COMMON\RFACTOR 2\MODDEV\OPTIONS\MODMODE\ALLCARSTRACKS.BIK
    7.65s vidman.cpp 1458: Trying to Play Video File: C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\ModDev\Options\MODMode\PreGame.avi
    7.65s MovieMan.cpp 130: Error opening AVI file C:\PROGRAM FILES (X86)\STEAM\STEAMAPPS\COMMON\RFACTOR 2\MODDEV\OPTIONS\MODMODE\PREGAME.AVI
    7.65s MovieMan.cpp 130: Error opening AVI file C:\PROGRAM FILES (X86)\STEAM\STEAMAPPS\COMMON\RFACTOR 2\MODDEV\OPTIONS\MODMODE\PREGAME.AVI
    7.89s tire_manager 1435: Non-existent tire brand ""
    7.89s tire_manager 1435: Non-existent tire brand ""
    7.90s O_OSC.cpp 3081: Exited Options_OSC_Reader::ReadOSC()
    7.90s O_AppObj.cpp 2895: Options object creation successful
    20.29s game.cpp 1012: Setting RFM "AllCarsTracks.rfm"
    26.40s plrfile.cpp 2102: Attempting to save to C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\ModDev\UserData\player\player.TMP
    26.42s plrfile.cpp 2126: Retcode: 0 for renaming to C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\ModDev\UserData\player\player.JSON
    26.42s game.cpp 2604: Entered Game::Exit()
    26.43s sound.cpp 1675: Entered Sound::Exit()
    26.45s specialfx.cp 4543: Entered SpecialFX::Exit()
    26.46s hwinput.cpp 8197: Entered HWInput::Exit()
    26.46s hwinput.cpp 1616: Unacquiring device "Controller (Gamepad F310)" (if this is the last line in your trace.txt, your controller driver is probably buggy)
    26.46s hwinput.cpp 1624: Now releasing same device (if this is the last line in your trace.txt, your controller driver is probably buggy)
    26.46s hwinput.cpp 1626: Device successfully uninitialized
    26.46s hwinput.cpp 1616: Unacquiring device "Controller (Gamepad F310)" (if this is the last line in your trace.txt, your controller driver is probably buggy)
    26.46s hwinput.cpp 1624: Now releasing same device (if this is the last line in your trace.txt, your controller driver is probably buggy)
    26.46s hwinput.cpp 1626: Device successfully uninitialized
    26.46s dynman.cpp 3051: Entered DynMan::Exit()
    26.46s render.cpp 3068: Entered Render::Exit()
    26.46s onscreen.cpp 4224: Entered OnScreen::Exit()
    26.46s vidman.cpp 3083: Entered VidMan::Exit()
    26.62s osman.cpp 971: Entered OSMan::Exit()
    Tried to install updated drivers and the game still crashed.
    PS: Is my first mod for rFactor 2, so I don't know much about the differences on rF2 cars structures.
     
  2. Bjørn

    Bjørn Registered

    Joined:
    Oct 4, 2010
    Messages:
    1,675
    Likes Received:
    612
    My bet would be that the problem lies in the tyres. Either in the TGM, TBC or HDV (tirebrand line, pointing towards the TBC).
     
  3. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,591
    Likes Received:
    3,213
    Note the controller ones you've highlighted mean exactly what they say; if they aren't the final lines in the log (as they aren't in yours) they're probably not the issue.
     
  4. toebee

    toebee Member

    Joined:
    Oct 5, 2010
    Messages:
    380
    Likes Received:
    389
    If you are having trouble tracking down the issue you may be able to find a clue in the garage, before you click race. The few times I have had this happen I was able to look in the garage and find the issue. Look for something that doesn't belong. Like an extremely high value for tire pressure, spring rates, ect...
     
  5. Schumi

    Schumi Registered

    Joined:
    Jan 2, 2012
    Messages:
    254
    Likes Received:
    673
    99% is a problem in TGM
     
  6. SmashingPants67

    SmashingPants67 Registered

    Joined:
    Oct 9, 2015
    Messages:
    76
    Likes Received:
    14
    Good news: I solved this problem, and is really an incorrectly-named TGM, all I had to do is rename the "TGM=" to match the TGM file in the "MAIN" folder and the problem is solved. I hope this helps other modders (especially the ones that use the "ZR" as base)... :)
     

Share This Page