cpu demand

Discussion in 'Technical & Support' started by Elyess, Aug 26, 2017.

  1. Elyess

    Elyess Registered

    Joined:
    Jul 5, 2017
    Messages:
    10
    Likes Received:
    0
    When i play the game alone the performance is great but when i play with ai the game starts to lag because it takes too much oh my cpu... it starts to stutter, ai cars start going really fast and i have 3 seconds input lag...
    is there a way to lower the graphics even more or improve the performance?
    specs:

    Processor Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz, 2601 Mhz, 2 Core(s), 4 Logical Processor(s)
    AMD Radeon R7 M260
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,910
    Likes Received:
    3,407
    I guess you could try reducing resolution (fullscreen mode preferably) to try and reduce CPU load, but your CPU is very marginal so you are going to struggle with a few AI. Some cars you may even struggle to stay in realtime by yourself.

    You can't reduce the CPU requirement on the physics itself, as the physics are calculated the same on all machines and your CPU speed doesn't really match the game requirement (the game is aimed at a certain level, and yours is nearly below it).
     
  3. Elyess

    Elyess Registered

    Joined:
    Jul 5, 2017
    Messages:
    10
    Likes Received:
    0
    i have all the graphics and resolution at minimum... other sims run well but rf2 does not. By the way, the game max out at 40% cpu usage... is there a way i can make it use more than 40%?
     
  4. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,222
    Likes Received:
    1,335
    40% is probably total usage of all 4 cores. The problem is per core usage, once a single core reaches 100%, the game will start to stutter, as rF2 physics run on one core (and graphics on another).

    There is no graphics option to reduce CPU usage. The Intel U CPU's are lower clocked laptop ones, but normally I think they should still be fine for rF2. I suspect your CPU isn't operating at full clock/performance. Try to see what the actual clock frequency is while gaming by using a tool like CPU-Z. Some laptops don't allow max effect unless AC is plugged in. The other problem can be CPU throttling due to heat, as laptops often have poor cooling solutions.
     
    Elyess likes this.
  5. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,910
    Likes Received:
    3,407
    The CPU only has 2 physical cores, with 4 logical. This may actually be worse than 2 logical, as background processes can interfere despite being 'on another core'. Anything you can do to maximise CPU speed (but constantly - not a turbo that changes the clock speed dynamically) and minimise other tasks will help, but it's going to be difficult.

    Press Ctrl-C while in the car to better gauge CPU use by the game. Overall CPU usage isnt as relevant, as stonec says. rF2 needs to calculate physics each step (100Hz, perhaps) while reading your input. It can't wait 0.2 secs and then continue on like nothing happened, which is what many games will do.
     
    sherpa25 likes this.
  6. Elyess

    Elyess Registered

    Joined:
    Jul 5, 2017
    Messages:
    10
    Likes Received:
    0
    the clock frequency is around 1600 to 2000 mhz
     
  7. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,222
    Likes Received:
    1,335
    1600 MHz sounds seriously low to me, it's almost twice less than the specified turbo boost clock. Even with all cores in use, it should be able to at least keep the base clock of 2 GHz at all times. So to me this suggests heat/power issues.
     
  8. machine

    machine Registered

    Joined:
    Jan 31, 2011
    Messages:
    366
    Likes Received:
    257
    I have a Core i7 960, the first i7. It runs at 3.2ghz. So 2ghx sounds slow for an i7.
    Anyway, I had lag issues at a race only a week ago. Lagging for 2-3 seconds every lap. Lag on Brookdale with 22 cars. (online not AI) I immediately switched from DX9 to DX11 and put aggressive threading on. Immediately the processor ran smoothly and never deviated from abound 60% (according to in game processor graphic)
     
  9. Elyess

    Elyess Registered

    Joined:
    Jul 5, 2017
    Messages:
    10
    Likes Received:
    0
    what can i do to make it higher then??
     
  10. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,910
    Likes Received:
    3,407
    machine hasn't looked up your CPU, ignore that.

    Turn off hyperthreading, turn off speedstep, probably turn off idle states. Normally I'd also advise turning off turbo boost but you're between a rock and a hard place - you may need it to get the clock high enough, but it won't be consistent which can cause its own issues. If you can overclock your CPU to 2.4 as a base that would be better, but I'm not even sure the other options I've mentioned will be available on a laptop.
     
  11. Elyess

    Elyess Registered

    Joined:
    Jul 5, 2017
    Messages:
    10
    Likes Received:
    0
    but project cars, assetto corsa and f1 2015 run at 60 fps... I hope the devs can optimize the game...
     
  12. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,910
    Likes Received:
    3,407
    It's not about FPS, it's about physics loops running each and every fraction of a second in realtime.
     
    Elyess likes this.
  13. nurogize

    nurogize Registered

    Joined:
    Jul 1, 2018
    Messages:
    54
    Likes Received:
    22
    Reducing "visible cars" from 60 to 24, stopped the AI stuttering on my system, when racing against 39 other AI opponents with the GT3 World Series Mod.

    CPU occupancy was brought down from 100 to around 80%.
     

Share This Page