Converting a track from rFactor 1 to 2 - I really have tried.

Discussion in 'Track Modding' started by jstoezel, Apr 1, 2020.

  1. jstoezel

    jstoezel Registered

    Joined:
    Oct 23, 2017
    Messages:
    3
    Likes Received:
    0
    Hello:

    I have watched this video on how to convert a track from rFactor 1 to 2:
    rFactor2 crashes while loading the track. I have spent a lot of hours converting and adding GMT files, editing paths in text files, reviewing trace files for errors...
    I still can't get this to work.
    I am sure there is somebody out there that knows exactly what would need to be done for converting the track I am working on. This is our local sport car club track, it is simple, there is not much to it. We would love to bring it from rFactor to rFactor2.

    Would somebody out there be available to lend a hand converting this track?

    Regards,
    JS
     
  2. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    2,931
    Likes Received:
    275
    Send me a PM
     
  3. Oskart

    Oskart Registered

    Joined:
    Jun 22, 2017
    Messages:
    10
    Likes Received:
    0
    Maybe the name of any file ir wrong or bad linked, in video says that have to export textures into assets/gmt but I did with maps in it worked
     
  4. Goncalo Costa

    Goncalo Costa Registered

    Joined:
    Feb 21, 2019
    Messages:
    33
    Likes Received:
    26
    Yeah me too! Can´t figure it out. Have you made any progress?
     
  5. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    799
    Likes Received:
    550
    How far does the yellow loading bar get before it crashes? If it gets all the way to the end, generally it’s the gbd file not pointing to the correct tdf file. Open the gbd with notepad++ (that’s what I use) and see what tdf it’s pointing to.
     
  6. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    1,578
    Likes Received:
    997
    The best way to learn it is to edit the SCN and GDB of Joesville
    • Copy the structure of the paths of the SCN.
    • Check if the path of the tdf is correct
    • Check if the first line of the SCN is correct
    • Check if the name of the files, of the main dir and the layout dir, have the same structure than the Joesville ones
    I'm not at home now but if i remember correctly, this should be enough to load the circuit in Devmode
    If you don't get this, send me your circuit and i'll check what's wrong
     
    Last edited: Apr 23, 2020
  7. Goncalo Costa

    Goncalo Costa Registered

    Joined:
    Feb 21, 2019
    Messages:
    33
    Likes Received:
    26
    @Goanna you were right. The terrain detail file was the Joesville one. Thanks now it starts in Devmode.
     
    lagg likes this.
  8. Goncalo Costa

    Goncalo Costa Registered

    Joined:
    Feb 21, 2019
    Messages:
    33
    Likes Received:
    26
    So I managed to follow the video along and got everything packed but now I get this errors
     

    Attached Files:

  9. Oskart

    Oskart Registered

    Joined:
    Jun 22, 2017
    Messages:
    10
    Likes Received:
    0
    You should did something wrong during the packaging
     
  10. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    1,578
    Likes Received:
    997
    Is the trackmain.dds in any of the mas files?
     
  11. Goncalo Costa

    Goncalo Costa Registered

    Joined:
    Feb 21, 2019
    Messages:
    33
    Likes Received:
    26
    No it isn't. And I don't have any in my files
     
  12. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    2,931
    Likes Received:
    275
    There's ya problem then. Find the object that texture is applied to and comment it out of the SCN.
     
  13. Marco Boy

    Marco Boy Registered

    Joined:
    Jan 14, 2012
    Messages:
    72
    Likes Received:
    2
    ..it could be something wrong in the DXT5 format of the DDS... in the texturer vbrowser windows of 3DsimEd select the DDS and press the ->DDS button on the right...

    (usually it works but in case not try to save it a TGA or BMP then reload it and save it again as DDS DXT5...)
     
  14. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    1,578
    Likes Received:
    997
    Or the material ROADUNUSED points uses the trackmain.dds texture and it doesn't exists
     
  15. Goncalo Costa

    Goncalo Costa Registered

    Joined:
    Feb 21, 2019
    Messages:
    33
    Likes Received:
    26
    @Marco Boy the problem is that the files the error talks about aren't in my original files
    @lagg But I also can't find the material ROADUNUSED
     
  16. Goncalo Costa

    Goncalo Costa Registered

    Joined:
    Feb 21, 2019
    Messages:
    33
    Likes Received:
    26
    So I was looking in the files to see if I could find anything I couldn't but I tryed to use devmode and it also doesn't work there (same error) so it isn't a packaging problem.
     

Share This Page