Constant High CPU Usage Spikes in 4 Threads

Discussion in 'Technical & Support' started by Mark Krus, Mar 23, 2021.

  1. Mark Krus

    Mark Krus Registered

    Joined:
    Sep 15, 2020
    Messages:
    19
    Likes Received:
    3
    My specs:
    Ryzen 5900x @4.6Ghz
    32GB 3600Mhz CL16 ram
    RTX 2070

    I have tried a whole slew of things and I can't get my computer to stop doing this. It does this in the menu before I load a track and during and after and while I race; all the time. Below is a screenshot of my CPU usage.

    https://imgur.com/a/gYYzYos

    This program, Process Explorer, tells you what is using the most percentage of your CPU by hovering your mouse over the graph and at any point in those 4 threads the most usage will be rfactor 2.exe.

    I do the tweaks listed in Risto Kappet's thread: https://forum.studio-397.com/index....rmance-guide-on-how-to-prevent-low-fps.61265/

    Here is a short list of some stuff I've tried that didn't work:
    -Tried all different sync settings in launch graphics settings
    -Selected GPU in graphics settings
    -Set "use thread" to true and false
    -Launched in single screen or triple screen
    -Disabled all plugins
    -Deleted cbash and shaders content
    -Uninstalled all non-S397 content
    -Tried factory settings on BIOS
    -Updated BIOS and drivers
    -Tried different AMD overclocking configurations
    -Updated Windows
    -Updated nvidia drivers
    -Tried disabling fullscreen optimizations on rfactor 2.exe
    -Disabled anti-malware, windows defender
    -Created exceptions in firewall
    -Turned hyperthreading off
    -Disconnected wheel and pedals
    -Switched audio device to monitor and disabled Realtek audio device in BIOS
    -Tried Game Mode on and off
    -Updated AMD Chipset Drivers
    -Tried setting "autonomous render thread" to false
    -Tried deleting the Userdata folder and letting rF2 replace it


    What causes these high CPU usage spikes? I can't be the only person experiencing this.
     
    Last edited: Mar 23, 2021
  2. bobbie424242

    bobbie424242 Registered

    Joined:
    Oct 17, 2017
    Messages:
    221
    Likes Received:
    316
    Maybe in player.json, try setting "UI autonomous renderer thread" to "false".
    And try with a clean user profile (rename the UserData folder)
     
  3. Mark Krus

    Mark Krus Registered

    Joined:
    Sep 15, 2020
    Messages:
    19
    Likes Received:
    3
    Neither of these solved the issue.
     

Share This Page