Competitor cars stuttering (like lag but not lag)

Discussion in 'Bug Reports' started by David O'Reilly, Aug 28, 2015.

  1. David O'Reilly

    David O'Reilly Registered

    Joined:
    Jun 12, 2012
    Messages:
    1,043
    Likes Received:
    752
    See post on sept 14. Solved but thanks.

     
  2. Led566

    Led566 Registered

    Joined:
    Jan 25, 2012
    Messages:
    358
    Likes Received:
    24
    How much is your CPU bar now?
    Mine still at 90%+ but in fact no more lag except some occasional stutters on race start.
     
  3. Sergi_racing

    Sergi_racing Registered

    Joined:
    May 18, 2016
    Messages:
    10
    Likes Received:
    0
    I'd like to bring back to life this discussion as I'm facing similar stuttering problems that may be caused by some potential CPU lag. The solution provided to change the Sim Processor Thresh value from 255 to 3 it seems to be removed from the latest build 1084 because I can't find it in the player json file.

    I don't know what can I do to solve this issue, so any new ideas would be very welcomed.

    I run rfactor2 on my laptop which is a msi GE70 2QE: intel i7 4720-HQ 2.6 GHz, nvidia GTX960M 4GB, 18GB of RAM. I think that these characteristics are enough to run this game on medium-low graphic settings.

    In addition, I use video sync settings and the game runs on a constant 60fps value. And I use a PS4 gamepad as a Xbox controller.The FFB update rate is set to 1, to try to skip updates.

    Thanks in advance.

    EDIT: I did the ctrl+c thing to see the graphs in game (green and purple bars) and when the stuttering appears, the purple bar goes to the right side at a 100% value. That mostly happens when I start the race and there's the rest of the AI cars as well.
     
    Last edited by a moderator: May 19, 2016
  4. F2kSel

    F2kSel Registered

    Joined:
    May 28, 2011
    Messages:
    139
    Likes Received:
    4
    Yes it doesn't seem to be present although you might just be able to add it to the list.
    I don't have time to test right now.

    I also noticed the stutter which has only started happening in the latest build.
     
  5. Sergi_racing

    Sergi_racing Registered

    Joined:
    May 18, 2016
    Messages:
    10
    Likes Received:
    0
    I tried to editthe .JSON file and I put this at the end but it didn't work because when I run the game I got a pop up message saying that the player .JSON file was wrong or something like that and it was automatically replaced by a new fresh one:
    },
    "Multicore":{
    "Sim Processor Thresh":3,
    }
    }


    As I said before editing my previous post,I did the ctrl+c thing to see the graphs in game (green and purple bars) and when the stuttering appears, the purple bar goes to the right side at a 100% value. That mostly happens when I start the race and there's the rest of the AI cars as well. Then the game runs smoothly almost all the times during a race.
     
  6. argo0

    argo0 Registered

    Joined:
    Jan 22, 2012
    Messages:
    624
    Likes Received:
    8
    Are you sure it isn't the new FFB thread option in the controller file that's causing the stuttering? Set it to false, see if that works.
     
  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,025
    Likes Received:
    5,697
    Assuming there's some reason you did that in the past, then do this:

    The skip updates no longer works, it's been replaced by "Use thread". But setting it to false may help, as weird as that sounds.
     
  8. Sergi_racing

    Sergi_racing Registered

    Joined:
    May 18, 2016
    Messages:
    10
    Likes Received:
    0
    I tried that, and I tested it at indianapolis and I had the same problem. Just when the 5 lights go off and I accelerate, in the very first few meters the purple bar rises to a 100% and starts the stuttering problem till all the AI cars overtakes me (the cars behind me crashes into mine and my car seems to be slower than the rest of the field). Then, the game runs pretty decently.

    Any new ideas would be very welcomed. Thanks!
     
  9. Comante

    Comante Registered

    Joined:
    Nov 20, 2013
    Messages:
    1,527
    Likes Received:
    1,035
    It looks like your I7 processor is too busy doing things.. are you sure there are no applications or other stuff running in background that suck so much processing power? I have a I5, and I've never seen the purple bar go to 100%
     
  10. Sergi_racing

    Sergi_racing Registered

    Joined:
    May 18, 2016
    Messages:
    10
    Likes Received:
    0
    I'm monitoring CPU usage while playing, and it only arrives to a maximum usage of 20%. So, my CPU is not busy at all when I play rfactor2.
     
  11. stonec

    stonec Registered

    Joined:
    Jun 19, 2012
    Messages:
    3,321
    Likes Received:
    1,444
    Press Ctrl+C while in game and monitor the purple bar, it shouldn't go much above 50%. If it goes to 100% during stutters, then the physics run out of realtime. The in-game bar is the only way to tell if rF2 gets enough CPU resources.
     
    nurogize likes this.
  12. Sergi_racing

    Sergi_racing Registered

    Joined:
    May 18, 2016
    Messages:
    10
    Likes Received:
    0
    I did that yesterday and this morning and when the stuttering appears, the purple cpu bar goes to 100%. So, what can I do to avoid this?
     
  13. stonec

    stonec Registered

    Joined:
    Jun 19, 2012
    Messages:
    3,321
    Likes Received:
    1,444
    Then it means rF2 physics are falling out of realtime due to not enough CPU resources. It sounds like your CPU is downclocking or not running at max resources, i7 4K should be enough for rF2. Sometimes laptop games don't run at best FPS unless you plug in the power cable.
     
  14. Sergi_racing

    Sergi_racing Registered

    Joined:
    May 18, 2016
    Messages:
    10
    Likes Received:
    0
    I never use the battery on my laptop, which means that I always use it with the cable plugged in. At least, thanks to you I know what is causing the problem. No it's see if a solution can be found.

    I double checked on my bios and the Intel SpeedStep feature is disabled, so that no reduction in CPU clock speed is made. And I run my power options to high performance. All the other games that I have runs smoothly and this is the only one that causes me problems, not to mention engineering software that requires a high amount of computer resources.

    Thanks!
     
    Last edited by a moderator: May 19, 2016
  15. Gijs van Elderen

    Gijs van Elderen Registered

    Joined:
    May 1, 2014
    Messages:
    1,393
    Likes Received:
    469
    Your CPU should eat rF2 for breakfast even with 100 AI. :)

    I've a MSI GS70 laptop. It's the GE70's little brother. I've no CPU problems.

    Check your MSI preformance profile and shift mode.

    [​IMG]
     
  16. Associat0r

    Associat0r Registered

    Joined:
    Oct 5, 2010
    Messages:
    307
    Likes Received:
    9
    I assume you have tried all the suggestions here http://steamcommunity.com/app/365960/discussions/0/371918937264935679/#c371918937265820836

    If those don't help, maybe your system is overheating due to dust built-up and the combination of high GPU/CPU usage and is automatically throttling down your CPU. I know some do, even when you tell them not to. There are tools to check if that's the case.

    Dust blowing your system internals (worked for me) and/or limiting the framerate might help in that case.
     
  17. Sergi_racing

    Sergi_racing Registered

    Joined:
    May 18, 2016
    Messages:
    10
    Likes Received:
    0
    Shift mode is set to speed, the maximum one. Everything is set to maximum performance settings.


    Yes, I've tried these suggestions with no success at all. When the stuttering appears I've double checked that the CPU usage reaches its top value at 48%. I've tried to reduce the AI cars from 21 to 5 to give it a try and I have the same problems.

    Finally, I did the dust blowing thing a couple of weeks ago. I do that on a regular basis because I'm also used to do that with my desktop computer (which is not capable of running rfactor). And what about limiting the framerate? How can I do that? For your information, I have a constant framerate of 60 fps.
     
  18. Comante

    Comante Registered

    Joined:
    Nov 20, 2013
    Messages:
    1,527
    Likes Received:
    1,035
    Rfactor product family enjoy to set V-sync OFF , or any form of Sync off, and use instead a player.json string, that if memory don't trick me sound like "maximum framerate" and to achieve the same 60 fps you havbe to put 59 as a value in that string.
    With this, you achieve 2 things: 1) the CPU is not forced to wait the GPU that is not forced to wait the video refresh. Limiting the FPS output is a way to reduce GPU load, giving you a smooth FPS rate (actually you may enjoy FPS value higher than your monitor refresh rate ( I do) ).
    So, to make sure everything is ok, make sure no sync is enabled in the RF2 control panel, that no FPS setting is enable in the video option inside the game.
     
  19. Sergi_racing

    Sergi_racing Registered

    Joined:
    May 18, 2016
    Messages:
    10
    Likes Received:
    0
    I did what you suggested, and there is no change at all :(

    BTW, here you have my current video settings. Am I doing something wrong?

    View attachment 20016
    View attachment 20017

    In the 2nd screenshot I know that the sync option is activated. But I did what you suggested, to set it to off with no improvement at all.
     
  20. stonec

    stonec Registered

    Joined:
    Jun 19, 2012
    Messages:
    3,321
    Likes Received:
    1,444
    Those graphic settings would have little impact on CPU usage, CPU usage depends mostly on physics. Maybe MSI gaming center software is causing problems by somehow affecting the CPU performance. I really have no other suggestion. Also make sure the "Use thread" setting in Controller.JSON is set to false.
     

Share This Page