Car skin DDS export and C6.R template questions

Discussion in 'Car Modding' started by MetalMania, Oct 16, 2017.

  1. MetalMania

    MetalMania Registered

    Joined:
    Feb 5, 2017
    Messages:
    20
    Likes Received:
    2
    I've decided to try a repaint or two in RF2. Please bear with me, this may be a somewhat lengthy post as I try to explain what I've done. I searched for tutorials, and found enough to get started. I'm trying this with GIMP, and I downloaded a DDS plugin to export the skin. As a test run, I tried to take the default ISI C6.R template and just export it as-is and make an alt_skin for an existing car, just to go through the process and see if I successfully got it in game. I did... but I think something's not right.

    One of the tutorials I found showed a screenshot of what I guess is the "official" nVidia DDS plugin for photoshop, with what I assume are the preferred settings for the DDS file. I don't presently have an account for an image hosting site to attach a screenshot, so i'll try to explain. The selection in the top header of the nVidia plugin box read "DXT5 ARGB8 8 bpp | interplated alpha", then a selection for "2D Texture", "Generate MIP maps", and the rest are buttons that I can't see what the options are for.

    The DDS plugin for GIMP however doesn't appear to have an exact match for those settings - at least in name. I get a compression selection menu that includes BC3/DXT5, BC3nm/DXT5nm, RXGB (DXT5), Alpha Exponent (DXT5), YCoCg (DXT5), and YCoCg scaled (DXT5). Then there's a format menu, that most closely offers RGBA8, ABGR8, RGB8, BGR8, and others... but not "ARGB 8pp" as the actual nVidia plugin shows. I think I'm good with the MIP map part... it has what seems a straightforward "Generate mipmaps" option, until I get to the advanced options offering Mipmap filters and "wrap mode" options - which not knowing what they do I left at default.

    So, for just taking a shot at it, I selected BC3/DXT5, ABGR8, Generate mipmaps, and left the rest at default. I "flattened" the template and exported it to DDS. The skin is in the game... but in the template there's a layer called "shads", which I thought was maybe "shadows", but if I turn it off it removes all of the color for the entire template - and it is NOT the "base color" layer. There's an element to it that makes the sides of the car, and front and rear bumpers have sort of a "washed out" look to them - the base color in the template is red, so these regions look sort of like a faint pink while the layer is on. Off, everything is white.

    If I try to erase these "washed out" areas from the "shads" layer in the template, the underlying color shows up like on the rest of the car, but it also removes the body panel lines and some other things, even though they're all actually part of other layers. I'm not completely inexperienced with painting with layered templates - I did one for flight simulator several years ago as well as one for GTR2 but using Paint Shop Pro, and this is the first time I've seen a layer mess with stuff that's part of another layer.
    While in game, the car appears as it looks with the "shads" layer on - the bumpers and sides have that washed out, pinkish look. I'm not sure it's actually supposed to look that way though. So, I'm wondering if I either selected some wrong options in the DDS plugin from GIMP, or maybe I shouldn't have "flattened" the template before exporting it? Or is it really supposed to look like that? It seems like you can't really erase or turn off this "shads" layer without screwing up other elements of the template, making it difficult to actually do a repaint with.

    I hope that makes sense to someone with painting experience, and/or with the original ISI C6.R template. I apologize for the lack of screenshots - I wasn't sure at first if I could just attach them from my local files or if I needed to link to an image hosting site. It appears the latter, which I don't have at the moment.
     
  2. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,524
    Likes Received:
    1,311
    Don't flatten it. The shadow layer should be set to multiply, and flattening it may mess that up. You can use imgur.com to upload images.
     
  3. Alexandr Meshkov

    Alexandr Meshkov Registered

    Joined:
    Jun 20, 2017
    Messages:
    132
    Likes Received:
    53
    GIMP has some problems with shadow layers in .PSD templates. It's not transparent. I always add alpha layer to "shadow" for white color to get transparency and then flatten image just before export in DDS. For export you can use simple BC3/DXT5 compression it looks Ok.
     
    Bogdy likes this.
  4. T1specialist

    T1specialist Registered

    Joined:
    Jan 11, 2012
    Messages:
    237
    Likes Received:
    163
    Instead of flattening the image use "new from visible". If you accidentally save your xcf and exit after flattening you can not edit it later because all the layers are combined.

    For shadow you can use multiply or burn (select layer and top of the layers options change mode to one or other). You can also use opacity to control the strength. If you want even more strength you can duplicate the shadow layer. The shadow layer needs to be over the color layers for it to work. Also in gimp save xcf while working. If you save into psd your layer groups get flattened.

    If the texture you are exporting into dds has alpha channel then use BC3 / DXT5. If not alpha channel then use BC1 / DXT1. If you export to BC3 / DXT5 and don't have alpha then gimp puts white alpha there for you. Also export minimaps (default settings is ok).
     
  5. MetalMania

    MetalMania Registered

    Joined:
    Feb 5, 2017
    Messages:
    20
    Likes Received:
    2
    Thanks for the replies everyone. I found a basic tutorial that was specifically for GIMP, and it fits right in with what you're saying - that it has some issues with shadow layers from PSD templates. One thing it said to do was to remove any layers with multiply or screen modes from within a group, and make them standalone layers outside the group. Once I did that, the "washed out" shadow zones in the template cleared up. I've never used GIMP before, this is something of a crash course for me. That tutorial also showed how to "extract" the alpha layer from an existing DDS skin and then apply the "visible" layer to it from the template. I made just a basic color change to the stock template and exported it, got it showing in game and looked OK.

    Thanks again for helping me out, now to get to work...
     
  6. T1specialist

    T1specialist Registered

    Joined:
    Jan 11, 2012
    Messages:
    237
    Likes Received:
    163
    What kind of problems exactly are you having with multiply or shadow layers?
     
  7. MetalMania

    MetalMania Registered

    Joined:
    Feb 5, 2017
    Messages:
    20
    Likes Received:
    2
    Hi T1,
    Sorry for the late reply, I haven't visited the forum since my last post to this thread. I'm afraid I don't think I can give a knowledgeable answer to exactly what the problem was. My experience with GIMP began with this project, and the only template I've tried so far is the stock ISI C6.R. At first, the best way I can describe is that the shadow layers seemed "permanently baked" onto the skin - it looked like a sort of haze that never changed and washed out the appearance of the colors underneath.

    One of the tutorials I found that was specifically written for using GIMP, just said that GIMP has some kind of problem processing some photoshop layer effects and modes for layer groups. Honestly, I don't even really know what that means, other than "GIMP doesn't work with some features of .psd files the same way Photoshop does." The instructions for GIMP said to remove the single layers from the "shadows-lines" group, and search any other existing layer groups and also remove any layers with "multiply" or "screen" mods. Not delete them from the template, just move them out of the group folder they were in - so they're still there but out of the "group" folder they started in. Essentially, just stack them as individual layers in the same order but not within a group/folder. I didn't change their individual layer modes after moving them outside their original group folder.

    As soon as I did that, the "hazy" look over sections of the template disappeared, and it looked more like a uniform color with a natural shading where the shadows were. I don't know the technical explanation of why that worked, but it did. From there, I did my paint layers and sponsor logo layers.

    After that, as you suggested I saved the template as an .xcf, used the "new from visible" instead of flattening and exported as BC3/DXT5 (I combined the new visible layer with the alpha channel from an existing car's .dds file - per the instructions in the guide I was using).

    I'm not sure if that is a satisfactory answer for you, but it's the best I can offer without really knowing or understanding the details of GIMP (or any other image editor, really). I just followed the instructions from a tutorial and it worked out. I can't call my skins high art, but I'm happy with them and they appear to look fine in RF2.
     
    Last edited: Oct 30, 2017

Share This Page