Car Parts Position

Discussion in 'Car Modding' started by Tobi Coats, Jan 18, 2012.

  1. Tobi Coats

    Tobi Coats Registered

    Joined:
    Jun 7, 2011
    Messages:
    63
    Likes Received:
    0
    hey
    im trying to load my car in game but when i do the parts dont seam to load in the positions of the scene from 3ds max
    please help
     
  2. Johannes Rojola

    Johannes Rojola Registered

    Joined:
    Sep 8, 2011
    Messages:
    1,038
    Likes Received:
    38
    You have to adjust all the car part pivots to 0,0,0, except for tires, rims and steering wheel.
     
  3. Tobi Coats

    Tobi Coats Registered

    Joined:
    Jun 7, 2011
    Messages:
    63
    Likes Received:
    0
    Hey . What piviot point do i have set the tires to. I font know how to set up the tires right they keep going spastic and i dont know how to set them up right
     
  4. Tim Bennett

    Tim Bennett Registered

    Joined:
    Nov 4, 2011
    Messages:
    63
    Likes Received:
    0
    Also the spindle gets pivot at object instead of 0 0 0
     
  5. mianiak

    mianiak Registered

    Joined:
    Oct 5, 2010
    Messages:
    691
    Likes Received:
    46
  6. Tobi Coats

    Tobi Coats Registered

    Joined:
    Jun 7, 2011
    Messages:
    63
    Likes Received:
    0
    Nope still can't get my head around it. It says in the work flow that to get a car ingame not on spinner u just need the cockpit,and four tyres I don't understand why I'm having so many problems
     
  7. D1Racer

    D1Racer Registered

    Joined:
    Jan 10, 2012
    Messages:
    193
    Likes Received:
    1
    You also need Instance=SLOT<ID> (Main body) to get the car on track.
     
  8. Tobi Coats

    Tobi Coats Registered

    Joined:
    Jun 7, 2011
    Messages:
    63
    Likes Received:
    0
    Okay lol an the slot id. I cant seam yo make the three rotate right
     
  9. websta

    websta Registered

    Joined:
    Jan 12, 2012
    Messages:
    186
    Likes Received:
    1
    xform maybe?
     
  10. Tobi Coats

    Tobi Coats Registered

    Joined:
    Jun 7, 2011
    Messages:
    63
    Likes Received:
    0
    Hey mianiak, see you've done some tuts for animation and stuff would you be able to wip up a tut on setting up a tyre and exporting it to thevgame?
     
  11. Tobi Coats

    Tobi Coats Registered

    Joined:
    Jun 7, 2011
    Messages:
    63
    Likes Received:
    0
    this is what my car is doing

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
     
  12. toebee

    toebee Member

    Joined:
    Oct 5, 2010
    Messages:
    380
    Likes Received:
    390
  13. D1Racer

    D1Racer Registered

    Joined:
    Jan 10, 2012
    Messages:
    193
    Likes Received:
    1
    Set the pivot points to object (tires) centre. Also, Make sure all your curly bracket thingy's i.e } are in the correct location. I've noticed that if they are wrong it can cause some funny stuff.
     
  14. DarkEraser84

    DarkEraser84 Registered

    Joined:
    Dec 28, 2011
    Messages:
    2
    Likes Received:
    0
    Hey guys, same problem here.

    Pivot of the tires and spindles are center of the objects, but it doesn´t work at all.
    I dont have an idea what i can do.

    Thanks in Advance

    View attachment 920 View attachment 921

    ( susp.pm, .hdv .. based on rtrainer )
     
  15. websta

    websta Registered

    Joined:
    Jan 12, 2012
    Messages:
    186
    Likes Received:
    1
    I'm not sure if this is your problem, but it looks as though your pivots are not happy, You can try this...
    select an object, check pivot is where it's meant to be, then 'reset xform' and collapse the object and re-export.
    As far as I know, the pivots need to be placed where you want the object to pivot (in most cases) although I have not got to that part yet, but will be looking at it soon...
    hope this helps
     
  16. Devin

    Devin Member

    Joined:
    Dec 30, 2011
    Messages:
    179
    Likes Received:
    77
    I always have to set all pivots to 0,0,0 except the helmet and steeringwheel ones.
    Works like this.
     
  17. DarkEraser84

    DarkEraser84 Registered

    Joined:
    Dec 28, 2011
    Messages:
    2
    Likes Received:
    0
    Thx websta and Devin.
    xform doesn´t work, but setting all pivots to 0,0,0 was the key ! ;)

    They are a second funny problem, shrinking rims and tires, when AI control is on .

    View attachment 925 switching to ai View attachment 926

    Thx
     
  18. websta

    websta Registered

    Joined:
    Jan 12, 2012
    Messages:
    186
    Likes Received:
    1
    Ah yes, I just looked at my old files and most parts are indeed set to 0,0,0 except the wheels.
    I must look into the pivots for suspension. I did not make any suspension parts in rF1, but intend to for rF2.
     

Share This Page