[SOLVED] Can't see my own dedi using my new Mikrotik router

Discussion in 'Hosting Help' started by zmitya, Nov 10, 2019.

  1. zmitya

    zmitya Registered

    Joined:
    Jun 29, 2011
    Messages:
    84
    Likes Received:
    7
    Hi All,

    A few days ago I bought a new router, since then I am unable to play on my own dedicated server.
    The new router is one from Mikrotik (http://bit.ly/34PFyYi) .

    I have set up the same port forwarding rules I had previously (in a Linksys WRT54G) without success.

    The interesting thing is that my friends can see my server in the list and they CAN CONNECT and PLAY on it.
    But my rFactor does not see my dedi in the match maker list for some reason.

    Here are my rules from the config: http://bit.ly/2Q1EEns
    This is how these rules looks like in the web config: http://bit.ly/2q28dL0

    I assume that this is a router config issue, but what is that ?
    Could somebody please help me out ?

    Thanks,
    Mitya
     
  2. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,288
    Likes Received:
    613
    @zmitya Maybe your router don't supports the NAT-Loopback.
    If that is the case, search this forum.
    If i remember it right, there have been some threads about it already.
     
  3. GrimDad

    GrimDad Registered

    Joined:
    Oct 9, 2010
    Messages:
    531
    Likes Received:
    304
  4. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    725
    Likes Received:
    445
    @zmitya is the dedicated server at the same location as your client PC. If so, when you start the game and go to multiplayer, check in the LAN listing for your server. That was the issue I was having as my router doesn't support NAT loopback. I can join on LAN while my friends join via WAN and it all works fine here. Hope this helps.
    upload_2019-11-11_6-56-54.png
     
  5. zmitya

    zmitya Registered

    Joined:
    Jun 29, 2011
    Messages:
    84
    Likes Received:
    7
    Hi Guys,

    Thank you very much for the answers.

    I read about the NAT-loopback issue. I'll check this in the evening how I can do it in a Mikrotik router.

    In my understanding the NAT loopback issue causes that the user is not able to join (but others saw themselves on the list).
    So can the NAT loopback issue cause that I can't even see my server on the list ?
     
  6. zmitya

    zmitya Registered

    Joined:
    Jun 29, 2011
    Messages:
    84
    Likes Received:
    7
    Hi Guys,

    I read this doc:
    https://wiki.mikrotik.com/wiki/Hairpin_NAT

    I have these rules:

    Code:
    [admin@MikroTik] /ip firewall nat> print
    Flags: X - disabled, I - invalid, D - dynamic
     0    chain=srcnat action=masquerade out-interface=pppoe-out1
     1    chain=dstnat action=dst-nat to-addresses=10.177.177.121 protocol=tcp dst-port=54297
     2    chain=dstnat action=dst-nat to-addresses=10.177.177.121 protocol=udp dst-port=54297
     3    chain=dstnat action=dst-nat to-addresses=10.177.177.121 protocol=udp dst-port=64298
     4    chain=dstnat action=dst-nat to-addresses=10.177.177.121 protocol=udp dst-port=64299
     5    chain=dstnat action=dst-nat to-addresses=10.177.177.121 protocol=tcp dst-port=64297
     6    chain=srcnat action=masquerade src-address=10.177.177.0/24 dst-address=10.177.177.121 out-interface=bridge
    [admin@MikroTik] /ip firewall nat>
    
    It works now, the only issue is that I have my server listed 140 times in the lobby and I can connect any of them
    :)
    I am curious how I could eliminate that ...

    Thanks for the help...
     
  7. zmitya

    zmitya Registered

    Joined:
    Jun 29, 2011
    Messages:
    84
    Likes Received:
    7
    The above roles are not correct.
    Here are the good ones:
    Code:
    [admin@MikroTik] /ip firewall nat> pr
    Flags: X - disabled, I - invalid, D - dynamic
     0    chain=srcnat action=masquerade out-interface=pppoe-out1
     1    chain=dstnat action=dst-nat to-addresses=10.177.177.1 protocol=tcp in-interface=pppoe-out1 dst-port=54297
     2    chain=dstnat action=dst-nat to-addresses=10.177.177.1 protocol=udp in-interface=pppoe-out1 dst-port=54297
     3    chain=dstnat action=dst-nat to-addresses=10.177.177.1 protocol=tcp in-interface=pppoe-out1 dst-port=64297
     4    chain=dstnat action=dst-nat to-addresses=10.177.177.1 protocol=udp in-interface=pppoe-out1 dst-port=64298
     5    chain=dstnat action=dst-nat to-addresses=10.177.177.1 protocol=udp in-interface=pppoe-out1 dst-port=64299
     6    chain=dstnat action=dst-nat to-addresses=10.177.177.1 dst-address=91.82.3.193 in-interface=bridge
     7    chain=srcnat action=masquerade src-address=10.177.177.0/24 dst-address=10.177.177.1 out-interface=bridge
    
    Where 91.82.3.193 is my current public IP. I still need to get a workaround for the case when I get a new IP.

    Edit:
    10.177.177.1 is the PC where my dedi server runs and this is the SAME pc where my rF2 client runs as well.
     
    Last edited: Nov 25, 2019

Share This Page