can't join multiplayer - unable to download mod

Discussion in 'Technical & Support' started by montor, Nov 20, 2021.

  1. montor

    montor Registered

    Joined:
    Nov 20, 2021
    Messages:
    5
    Likes Received:
    2
    Hi,
    i am new,
    i have bought the base game.
    All working fine but when i try to enter in any server of multiplayer,
    i get after 1 second the popup :
    An error occurred
    Unable to download mod
    Please try to returning to the main menu, or restarting the game.

    Tried any server(same version flagged), or removed and redownloaded the game from steam.
    Could you suggest me any tips?

    Thanks
    [​IMG]
     
  2. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,624
    Likes Received:
    695
    Try an "ISR" server.... and see if you see any difference. This may be a server setup issue (which is out of your control) and not your local install problem.
     
  3. montor

    montor Registered

    Joined:
    Nov 20, 2021
    Messages:
    5
    Likes Received:
    2
    tried also isr server, same situation.
    is there a possibility to view the log?
    I have the log analyzer but i think it show only the telemetry, not the application log.

    Thanks
     
  4. montor

    montor Registered

    Joined:
    Nov 20, 2021
    Messages:
    5
    Likes Received:
    2
    I finally managed to activate the log trace, the main error is :
    HTML:
    Multiplayer::processState() mod download failed with error code : 9
    full log :

    Code:
    28.78s JNILog.cpp     33: [qtp766524074-52] Open UI WebSocket channel, session id = 1
      28.79s JNILog.cpp     33: [qtp766524074-49] UWSC got message Message[messageType=GET_ASYNC, topic='FavoritesServerList', body=null]
      28.79s JNILog.cpp     33: [qtp766524074-49] Started TopicProvider for topic FavoritesServerList
      30.82s JNILog.cpp     33: [AsyncProviderExecutor_FavoritesServerList] Stopped TopicProvider for topic FavoritesServerList
      53.75s JNIMultiplay  255: Multiplayer::processState() attempting mod download ~IsR~F3_Series_25.rfmod from 85.93.88.202 : 6009
      53.82s JNIMultiplay  262: Multiplayer::processState() mod download failed with error code : 9
      54.21s JNILog.cpp     33: [qtp766524074-54] Close UI WebSocket channel, session id 1, reason
      93.29s JNILog.cpp     33: [qtp766524074-53] Open UI WebSocket channel, session id = 2
      93.39s JNILog.cpp     33: [qtp766524074-50] UWSC got message Message[messageType=GET_ASYNC, topic='InternetServerList', body=null]
      93.39s JNILog.cpp     33: [qtp766524074-50] Started TopicProvider for topic InternetServerList
      93.39s JNILog.cpp     33: [qtp766524074-50] UWSC got message Message[messageType=GET_ASYNC, topic='FavoritesServerList', body=null]
      93.39s JNILog.cpp     33: [qtp766524074-50] Started TopicProvider for topic FavoritesServerList
      95.40s JNILog.cpp     33: [AsyncProviderExecutor_FavoritesServerList] Stopped TopicProvider for topic FavoritesServerList
     100.96s JNILog.cpp     33: [AsyncProviderExecutor_InternetServerList] Stopped TopicProvider for topic InternetServerList
     113.31s JNIMultiplay  255: Multiplayer::processState() attempting mod download Road_Atlanta_Endurance.rfmod from 78.112.220.51 : 57297
     113.42s JNIMultiplay  262: Multiplayer::processState() mod download failed with error code : 9
     113.45s JNILog.cpp     33: [qtp766524074-54] Close UI WebSocket channel, session id 2, reason
     119.15s JNILog.cpp     33: [qtp766524074-47] Open UI WebSocket channel, session id = 3
     119.23s JNILog.cpp     33: [qtp766524074-51] UWSC got message Message[messageType=GET_ASYNC, topic='InternetServerList', body=null]
     119.23s JNILog.cpp     33: [qtp766524074-51] Started TopicProvider for topic InternetServerList
     119.23s JNILog.cpp     33: [qtp766524074-51] UWSC got message Message[messageType=GET_ASYNC, topic='FavoritesServerList', body=null]
     119.23s JNILog.cpp     33: [qtp766524074-51] Started TopicProvider for topic FavoritesServerList
     121.25s JNILog.cpp     33: [AsyncProviderExecutor_FavoritesServerList] Stopped TopicProvider for topic FavoritesServerList
     126.81s JNILog.cpp     33: [AsyncProviderExecutor_InternetServerList] Stopped TopicProvider for topic InternetServerList
     127.18s osman.cpp     347: USER STARTED WRITING
     133.06s osman.cpp     347: USER STARTED WRITING
     141.25s osman.cpp     351: USER STOPPED WRITING
     142.90s JNIMultiplay  255: Multiplayer::processState() attempting mod download SRL Seasson 1 GT3 Package.rfmod from 85.215.222.139 : 64297
     143.00s JNIMultiplay  262: Multiplayer::processState() mod download failed with error code : 9
     143.01s JNILog.cpp     33: [qtp766524074-52] Close UI WebSocket channel, session id 3, reason
     
  5. montor

    montor Registered

    Joined:
    Nov 20, 2021
    Messages:
    5
    Likes Received:
    2
    ok solved by myself.
    Thanks
     
  6. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    2,600
    Likes Received:
    1,643
    Posting your solution could help other users.
     
  7. montor

    montor Registered

    Joined:
    Nov 20, 2021
    Messages:
    5
    Likes Received:
    2
    As solution : Instead of delete the game folder and do a repair on Steam i have done a uninstall from Steam, manually deleted the game folder and then reinstalled the game.
    Note: in my case i have backuped my "UserData" folder inside the game and restored it(copy and paste) in order to keep my old config.
     
    nolive721 and lagg like this.
  8. nolive721

    nolive721 Registered

    Joined:
    Jan 2, 2016
    Messages:
    102
    Likes Received:
    62
    Will try this because i am having same issues
    Thanks for sharing
     
  9. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,251
    Likes Received:
    396
    Before you do that, could you check that you have a 'Package' folder in your main rfactor2 folder. If not make one.
    My girlfriend had that same problem. We tried everything, and found that folder was missing. We had no idea why it was missing, but worked after making it.
     

Share This Page