[SOLVED] Can’t launch RF2 in Oculus

Discussion in 'Technical & Support' started by Finn Dog, Sep 25, 2018.

  1. Finn Dog

    Finn Dog Registered

    Joined:
    Dec 23, 2012
    Messages:
    39
    Likes Received:
    0
    It’s been a while since I’ve launched RF2 but I thought I would try out some of the new content. Last time I played I had no problems what so ever using it in Oculus. I’ve tried launching it many different ways but with no success. Game will launch in monitor but not in the Oculus headset. The only thing I can think has changed is windows 10 updates.

    I no longer have RF2 in my Oculus library despite enabling third part apps, I’m sure it used to be there. When I launch it in Steam it’s not included in the VR games section but not sure if it should be there or not. When I launch it I get a message saying it will it will launch in my headset but all I see is a virtual Oculus sensor and nothing happens apart it launches on my monitor. I have ticked the box saying VR in video settings. Can anyone suggest anything else I can try?

    Thanks
     
  2. Louis

    Louis Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,133
    Likes Received:
    551
    Me neither
     
  3. Mark Fuller

    Mark Fuller Registered

    Joined:
    Dec 10, 2016
    Messages:
    177
    Likes Received:
    49
    Just checking the obvious - you have enabled it in rF2 video settings [default is disabled]?
     
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    5,109
    Likes Received:
    1,363
    @Mark Fuller I think "I have ticked the box saying VR in video settings" probably takes care of that one :D
     
  5. Mark Fuller

    Mark Fuller Registered

    Joined:
    Dec 10, 2016
    Messages:
    177
    Likes Received:
    49
    From what Finn Dog describes, that is what happens if HMD is disabled in the rF2 video settings. I use that setting for watching replays etc. When I want to use VR, I have to change to enable HMD [or HMD + Monitor]
     
  6. Finn Dog

    Finn Dog Registered

    Joined:
    Dec 23, 2012
    Messages:
    39
    Likes Received:
    0
    Hi Mark, thanks for trying to help but have that ticked
     
  7. Mark Fuller

    Mark Fuller Registered

    Joined:
    Dec 10, 2016
    Messages:
    177
    Likes Received:
    49
    What do you mean by 'ticked?
     
  8. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,612
    Likes Received:
    436
    Select HMD Only in VR :
    upload_2018-9-27_23-56-17.png
     
  9. Mark Fuller

    Mark Fuller Registered

    Joined:
    Dec 10, 2016
    Messages:
    177
    Likes Received:
    49
    @Finn Dog If your VR setting is the same as Mad-King above, then:
    1. Does the light inside the unit change from yellow to white when you start rF2?
    2. Try running Oculus set up again.
    3. There was a patch update a few months ago as a DLL licence expired. If you have not downloaded Oculus software in a while, I would suggest you uninstall the software, do a fresh download and start again.

    Hope you get it working soon
     
    MaD_King likes this.
  10. Finn Dog

    Finn Dog Registered

    Joined:
    Dec 23, 2012
    Messages:
    39
    Likes Received:
    0
    Sorry mark I meant selected. I have configured everything as Mad Kings image but no luck.

    I launch Oculus home, then launch steam and the steam VR.

    Some of my other games have the option to launch in VR but not on RFactor. I just click to launch and it warns me it will launch on my monitor and in my headset, it then launches on my monitor but not my headset and I just get the image below.

    Thanks for the help all 37C61958-AA05-4ED7-80E7-613E92CE2326.jpeg C5694C24-88FE-47A7-8502-36D1A35E990C.jpeg
     
  11. Mark Fuller

    Mark Fuller Registered

    Joined:
    Dec 10, 2016
    Messages:
    177
    Likes Received:
    49
    Ok, I launch rF2 from the exe and not Steam. Can I suggest that you try starting rF2 first and allowing rF2 to start SteamVR? I have had the error message when I have opened SteamVR first or it hasn't closed properly.
     
  12. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    5,109
    Likes Received:
    1,363
    @Finn Dog Your rF2 says [v1111] in your steam library. I think this means you have selected that version from the betas tab. I could be wrong but I think it may help to 'opt out' so you're on the latest version.
     
  13. Finn Dog

    Finn Dog Registered

    Joined:
    Dec 23, 2012
    Messages:
    39
    Likes Received:
    0
    Thanks, You may well be right on this but I think I changed it because it didn’t work previously, but will change it and try again.

    Sadly might not get chance until next weekend now as going away, thanks all.
     
  14. AlanBernardo

    AlanBernardo Registered

    Joined:
    Jan 10, 2012
    Messages:
    141
    Likes Received:
    0
    One thing to make sure of is that, in the game menu, you don't have force 32 bit ticked.
     
  15. Finn Dog

    Finn Dog Registered

    Joined:
    Dec 23, 2012
    Messages:
    39
    Likes Received:
    0
    I do have that ticked because it doesn’t launch else! Looks like I have additional issues, thanks for letting me know
     
  16. Finn Dog

    Finn Dog Registered

    Joined:
    Dec 23, 2012
    Messages:
    39
    Likes Received:
    0
    Anyone have an idea why I can’t luanch the 64bt version?

    Thanks
     
  17. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,076
    Likes Received:
    1,478
    VR won't run in 32-bit, if you're having issues running 64-bit then Verify RF2 and SteamVR files, maybe swap your Oculus USB ports around and even reinstall Oculus Drivers/Software.
     
  18. Finn Dog

    Finn Dog Registered

    Joined:
    Dec 23, 2012
    Messages:
    39
    Likes Received:
    0
    CBF0B6A5-659A-44FD-B850-BA661B9BA332.jpeg Right I have verified files in steam and it says nothing is missing. I have also moved my usb cables around and all are shown to be okay in Oculus. I’ve tried launching the game in 64 bit but nothing happens. So I tried launching the game from the file location and ran as an administrator but got the following error if anyone knows what it could be?

    Thanks
     
  19. Finn Dog

    Finn Dog Registered

    Joined:
    Dec 23, 2012
    Messages:
    39
    Likes Received:
    0
    Just to update and for anyone else with the same issue I have now got this working by finding and running the DX file inside the RFactor 2 folders

    Thanks
     

Share This Page