Can´t Start Rfactor in VR

Discussion in 'Technical & Support' started by Hugo Becerra, Jun 2, 2017.

  1. Hugo Becerra

    Hugo Becerra Registered

    Joined:
    Jan 27, 2017
    Messages:
    27
    Likes Received:
    1
    Neither in the Beta version or the last non-beta release.

    So in the following order this happens;

    I open Steam VR

    then I open Rfactor 2 and the launcher opens correctly (video settings are set for Oculus) {it still says DX9 though}

    If I put my Oculus I can see the Rf2 Launcher as well

    then I launch it and the Rfactor Logo comes up

    Stays like that and eventually just crashes...


    This is not happening if I don't use the Oculus but I want to use it

    Hope someone can help:)
     
  2. mike.m

    mike.m Registered

    Joined:
    Apr 28, 2017
    Messages:
    30
    Likes Received:
    14
    I don't think that's right, I don't see the launcher when I put my Rift on. Do you have some VR desktop running?

    Did you run the Steam VR room setup?
     
  3. Depco

    Depco Registered

    Joined:
    Jun 16, 2014
    Messages:
    822
    Likes Received:
    489
    First off did you enable VR in the DX11 version of the program? The non Beta (DX9) version of the client does not support VR.

    In the rF2 launcher, before you fire up Steam VR you need to setup the VR options. Open rF2 launcher and click on the gear icon. Then click on the Video settings. in the window that comes up you need to set your resolution and graphical options, and make sure you check the VR dropdown. There will be options for HMD only and HMD + mirror. Select the one of your choice and then close the window. Now you can click on single player or multiplayer and start the game. It should then open up in your HMD.
     
  4. Hugo Becerra

    Hugo Becerra Registered

    Joined:
    Jan 27, 2017
    Messages:
    27
    Likes Received:
    1
    Yes I do have the beta [V1108-dx11-open-beta] enabled, it actually downloaded around 1gb so pretty sure its enabled. The thing is that even when I do that and open the launcher and go to the gear icon and choose the video settings where I enabled VR on the bottom it still says directX 9.0c... It still not working with vr
     
  5. Tango

    Tango Registered

    Joined:
    Jun 1, 2017
    Messages:
    4
    Likes Received:
    4
    If I remember correctly, the beta download was around 2.5gb, might be best to steam verify your files to make sure it's installed correctly
     
  6. Old Hat

    Old Hat Registered

    Joined:
    Feb 22, 2011
    Messages:
    163
    Likes Received:
    8
    I have basically the same problem, other than I don't know if the launcher appears in the CV1 headset.

    In my case, VR did work the day before, but now after the logo appears on the monitor, the game appears to just crash. I've verified local files.

    Btw my vid settings also says DX9. I think it may have before though when it worked, not sure about that.
     
  7. Axly

    Axly Registered

    Joined:
    Jun 26, 2012
    Messages:
    158
    Likes Received:
    4
    It seems I have a similar issue.
    I start Steam, then SteamVR, rF2 and then single player. It then starts in the "desktop theatre" (which it hasn't before). The RF2-logo is shown and I end up back in the desktop.. It doesn't seem to matter whether I choose HMD only or HMD+mirror, same result.

    I tried restarting a few times, and it seemed to work immediately after restart, but then the same problem. This has worked just fine before, so it's a new thing since the update on the 1'st.
    I'm using HTC Vive b.t.w.

    hmm, and if I try to start it without starting SteamVR first, everything seems to work... but then of course, there's no Force Feedback.
     
    Last edited: Jun 5, 2017
  8. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,407
    Likes Received:
    1,703
    Right-click rfactor2 in steam -> Properties and Untick the 'Use Desktop Game Theatre...' box
     
    mike.m and Old Hat like this.
  9. Axly

    Axly Registered

    Joined:
    Jun 26, 2012
    Messages:
    158
    Likes Received:
    4
    It seems I found a workaround.
    If I first start the rf2-launcher from Steam, and then start SteamVR before going into the game itself, it seems to work fine.

    EDIT: or do that Marc ;)
    Thanks! (very odd, I haven't changed that..)
     
    MarcG likes this.
  10. Old Hat

    Old Hat Registered

    Joined:
    Feb 22, 2011
    Messages:
    163
    Likes Received:
    8
    Worked for me. Thanks MarcG!
     
    MarcG likes this.

Share This Page