Build 660 Released

Discussion in 'News & Notifications' started by 88mphTim, Apr 15, 2014.

Thread Status:
Not open for further replies.
  1. Prodigy

    Prodigy Registered

    Joined:
    Nov 2, 2012
    Messages:
    946
    Likes Received:
    59
    What would that mean, that those features won't be in the game at all? Or just not trying to spend time on it now?
     
  2. Gerald Jacobson

    Gerald Jacobson Registered

    Joined:
    Jan 26, 2013
    Messages:
    827
    Likes Received:
    11
    Hello,
    Could you give some details about "Added some replay control to the plugin interface." ?

    Thanks
     
  3. Foxiol

    Foxiol Registered

    Joined:
    Nov 23, 2011
    Messages:
    380
    Likes Received:
    8
    Made some tests with my bottlenecked PC (dual core at 3.0Ghz, 4 GB RAM -both so dated that hurts- and a GTX560Ti OC 1GB) and I can report a massive increase in performance at least on my system.

    For example for me Silverstone is the most demanding track for me since the day it was released, I couldn´t even play with reflections ON and mirrors because at the pit lane my frame rate went down like mad at unplayable rates (max I got were 50´s down to 20´s). Today after updating went directly to Silverstone and in the very first seconds I noticed how my frame rate at the pits were at freaking 58´s FPS!!! with reflections ON (but LOW) and mirrors ON too. Then the average in the race were at about 70´s FPS and then at the pit lane at 58´s 60´s FPS.

    This of course (don´t laugh because my CPU is old, from 2007) with one car...but hell for me (a "hot lapper") having more than 60FPS in a track that I really like is really good. I couldn´t play on it until today...


    Have to check at Monaco and others but I can tell that ISI is doing an amazing job when it comes to performance and polishing stuff...If I can run this game (also yes, at 1080p and almost everything at max) well now, maybe others with far better PC´s than me should run it without problems.

    Thank you ISI! :eek:
     
  4. Rik

    Rik Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,172
    Likes Received:
    9
    I have the same problem with auto update with the file msvcp100.dll. Right now I'm downloading the lite.

    Edit: installed the "lite" over the previous version and the pc crashed. I tried deleting everything, and do a fresh installation of the "lite". RF2 does not start anymore. I try to contentbuild.

    Edit2:
    also tested the contentbuild but it will not start. I tried to run the file "rf config" in the core folder, seem to miss the various translations that were present in 590.
    I deleted everything again and tried again with the 590. Now even the 590 does not work anymore and gives me this error:
    Error in build 590
    [​IMG]

    a screen of rfconfig with missing translations (build 660):

    [​IMG]

    : (
     
    Last edited by a moderator: Apr 16, 2014
  5. TIG_green

    TIG_green Registered

    Joined:
    Jul 21, 2012
    Messages:
    3,037
    Likes Received:
    42
    haven't test the new build yet but Silverstone was optimixed already in the last content updated. It haven't been the most demanding track for a long time anymore. At least with my system.
     
  6. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,826
    Likes Received:
    582
    Updated fine with auto-updater, after 2 hours of Karting on previous build we tested the 660 yesterday just after, and we notice changes in FFB feeling on Kart, a better feeling and a more progressive tire slides, not a huge change but, it's less hard to feel the lost of rear, better for us to place the karting on brakes and to master the power slides ;).
    There is nothing in the change log, is our feeling right?

    We tested the collisions and the graphical render is strange, but the result is better, the bumps are more natural and the close battle are more easy to control. Is there anything to activate on client side (like on the previous collision algorithm tentative), or all is activated by default on both server/client after update?
     
    Last edited by a moderator: Apr 16, 2014
  7. Foxiol

    Foxiol Registered

    Joined:
    Nov 23, 2011
    Messages:
    380
    Likes Received:
    8
    It was playable before but still without mirrors and reflections, now I can play with that ON and have more frame rates. That´s on my PC of course. I notice more the minor performance issues/or increases because of my massive bottleneck.
     
  8. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    825
    Build 660, player.plr.
    Texture Sharpening="5" // Sharpen textures using MIP LOD bias - 0=Off, 1=+2.0(very blurry), 2=+1.0(blurry), 3=-1.0(sharp), 4=-2.0(very sharp), 5=0.0(auto)

    "Old-fashioned Alt+M"
    Texture Sharpening="0" // Sharpen textures using MIP LOD bias - 0=Off, 1=+2.0(very blurry), 2=+1.0(blurry), 3=-1.0(sharp), 4=-2.0(very sharp), 5=0.0(auto)
     
  9. Racefreak1976

    Racefreak1976 Registered

    Joined:
    Apr 16, 2012
    Messages:
    1,086
    Likes Received:
    62
    Autoupdate worked flawlessly. No crashes here so far. Though I did not test for a long time. Have to go to work.
     
  10. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,062
    Likes Received:
    3,496
    I took it to mean they don't want to put up a list of features they're looking to implement in the future.
     
  11. YoLolo69

    YoLolo69 Registered

    Joined:
    May 28, 2012
    Messages:
    978
    Likes Received:
    6
    Thanks ISI for this new build! :)

    I'll test it tonight. In the meantime, how does the auto mode for Texture Sharpening (5=auto) react for people? Is it smart enough to give a better render than the usual ALT-M (0=Off) trick? I'm wondering what could be the algorithm behind an auto mode here?
     
  12. Mulero

    Mulero Registered

    Joined:
    Jan 16, 2012
    Messages:
    351
    Likes Received:
    153
    Sorry for the previous post. No improvement in performance with mirrors, but if there is an overall performance improvement.

    I made a little comparison with the build 590 and build 660.

    These are the results. Average FPS in a lap on SPA with EVE F2.

    Build 590 with mirrors -------- 57.125 FPS
    Build 590 whitout mirrors ---- 73.693 FPS

    Build 660 whit mirrors -------- 63.796 FPS
    Build 660 whitout mirrors ---- 80.739 FPS
     
  13. baked bean

    baked bean Registered

    Joined:
    Jan 17, 2012
    Messages:
    1,296
    Likes Received:
    47
    Thanks for the update ISI team. :)
     
  14. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,067
    Likes Received:
    363
    Now if only ISI could fix it so that when I bump an AI car, it is them that spins out and not me, thanks :D
     
  15. Spinelli

    Spinelli Banned

    Joined:
    Jan 28, 2012
    Messages:
    5,290
    Likes Received:
    30
    - 74 to 81 fps
    - 57 to 64 fps

    Those are nice improvements. I hope that carries over to any track/car combo, rather than being the result of a specific car or track being further optimized.
     
  16. GCCRacer

    GCCRacer Banned

    Joined:
    Dec 12, 2012
    Messages:
    1,318
    Likes Received:
    2
    Do you know if you lost performance between 494 and 590, like some did? I.e. is this a "recovery" ?
     
  17. GTrFreak

    GTrFreak Registered

    Joined:
    Dec 7, 2010
    Messages:
    376
    Likes Received:
    7
    Thanks ISI

    It's a shame I don't have the time to try this build at the moment. I'm just real curious to what improvements have been made to the multiplayer collisions. Anyone tried multiplayer yet?
     
  18. baked bean

    baked bean Registered

    Joined:
    Jan 17, 2012
    Messages:
    1,296
    Likes Received:
    47
    Has any one else still got the problem with the Civic changing shape on the boot and parts disappearing at certain distance's? is there a fix? kinda off putting.
     
  19. Mulero

    Mulero Registered

    Joined:
    Jan 16, 2012
    Messages:
    351
    Likes Received:
    153
    Not a recovery performance. From the Build 342 to Build 590 performance was the same, at least in my case. 1 or 2 FPS difference with the same configuration and the same conditions.
     
  20. mart280

    mart280 Registered

    Joined:
    Dec 3, 2013
    Messages:
    18
    Likes Received:
    0
    Thank you for fixing HDR on multiple graphic cards, HDR automation now works on my 3 ATI 5850's :D
     
Thread Status:
Not open for further replies.

Share This Page