[build 240] [server] drivers and AI not always showing, or still there after boot

Discussion in 'Technical Archives' started by Denstjiro, Aug 10, 2013.

  1. Denstjiro

    Denstjiro Registered

    Joined:
    Oct 6, 2010
    Messages:
    2,952
    Likes Received:
    13
    Could not find matching thread so here go's,

    During online sessions when AI get booted, they are removed, but sometimes their names are still visible.
    I booted ingame and some remained, then checked on the dedi. on dedi all was good. (leaving joining myself fixed it)

    Also with drivers, after a race where some dnf and leave their names remain (after restart-weekend)

    Even one of our drivers not being visible at all, but he was there. issue remained after he left/rejoined. (not in spec. mode, he raced with us)
    And it was not just me, couple of the peeps noticed this and saw different things then I did.

    We restart-weekend because 1st full session is to build rubber and this rubber stays when we move to the next quick-races. i'm pretty sure everything gets reset properly would we just let the server re-load but that's not our goal.

    After doing a few races it became really confusing, 13 drivers and no idea whom was there, whom was AI. maybe I was al alone lol. or maybe there where 30 invisible drivers....



    oh, sidenote: red text in the timing list and/or server details is hardly readable.


    Sayonara :)
     
  2. JGraf

    JGraf Registered

    Joined:
    Oct 5, 2010
    Messages:
    461
    Likes Received:
    13
    i seen your very same boot AI confusion while testing the chat command, /callvote kick <name>

    ---

    set this option in your player.PLR file, it will create a label/identifier for who is AI.

    [ Game Options ]
    Code:
    Monitor AI Postfix="[B] AI[/B]" // what is displayed after AI driver names in monitor (multiplayer only)
     
  3. Jorgen

    Jorgen Registered

    Joined:
    Oct 5, 2010
    Messages:
    558
    Likes Received:
    3
    Similar AI/boot issue, but not quite the same: I attempted to boot all AI drivers one by one as admin when in the game, and I ended up with one left which I couldn't boot. However, the dedicated server listed another name as the remaining AI driver.
     
  4. Denstjiro

    Denstjiro Registered

    Joined:
    Oct 6, 2010
    Messages:
    2,952
    Likes Received:
    13
    Thx JGaf I will try that out, will be helpful at least (although via dedi-window they also are identified as AI)
     
  5. Denstjiro

    Denstjiro Registered

    Joined:
    Oct 6, 2010
    Messages:
    2,952
    Likes Received:
    13
    I have another thingy, not worth creating a thread for:

    I don't see whispers. tested it with me mates, it don't work. I can whisper to them though.

    Also I've added the welcome-message-plugin to our server and at first I thought it was not working, didn't get anything. until members stated they did get it.
    Now I see I do also get it when I check the dedi-window, but in-game it does not show at all.

    Tried .plr and multiplayer.ini but I can't find anything related?


    Edit: Come to think of it, could this be related with the nick-change? I race under Denstjiro but am registered under my real name. will test it out.
     
  6. Denstjiro

    Denstjiro Registered

    Joined:
    Oct 6, 2010
    Messages:
    2,952
    Likes Received:
    13
    The AI tip made it even more confusing JGaf :)

    This is a shot from our 2nd race tonight.
    All human drivers, Grant & Dale crashed and left during the race and where marked AI (and Grant shows twice as well)

    E de Vries only raced in race one, he never re-joined. he still remained listed and now also marked as AI.

    Other drivers where seeing different things. we had 5 AI for the first 10 minutes. they got booted and after quali some could not see what was what because AI names still showed. but not for me.

    [​IMG]

    Going to blank out Monitor AI Postfix=" AI" as its just adding to the confusion.

    I hope this gets picked up by the cody people :)
     
  7. Gupster

    Gupster Registered

    Joined:
    May 19, 2013
    Messages:
    404
    Likes Received:
    25
    We did a fun race with 2 races set in the ini and the second race the drivers who quit the first race turned into AI. They did much better in the second race as AI finishing 1 and 2 with one of our members driving his tail off trying to catch them. Funny to witness but shouldn't have happened as they had left in the first race session.
     
  8. Denstjiro

    Denstjiro Registered

    Joined:
    Oct 6, 2010
    Messages:
    2,952
    Likes Received:
    13
    So its not just a graphical issue, stuff gets really stuck on the server then...
     
  9. Gupster

    Gupster Registered

    Joined:
    May 19, 2013
    Messages:
    404
    Likes Received:
    25
    IMHO Yes, something with the server and adding then removing AI isn't working properly. The 2 real drivers had left in race one but their AI drivers came onto the grid for the second race.
     
  10. DurgeDriven

    DurgeDriven Banned

    Joined:
    Mar 20, 2012
    Messages:
    6,320
    Likes Received:
    42
    Here is mine then.

    Set admin password for the room and tell them what it is.

    If anyone wants to leave a race session they become admin and boot themselves ( that way it requires no votes )

    Ai problem solved.

    Ah, yeah, I know what you are thinking.

    If anyone can get all drivers in a room to actually do it, they should go buy a lottery ticket.

    lopl
     
    Last edited by a moderator: Sep 5, 2013
  11. Denstjiro

    Denstjiro Registered

    Joined:
    Oct 6, 2010
    Messages:
    2,952
    Likes Received:
    13
    great solution DD.

    lopl
     
  12. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    124
    This isn't a "bug" it is due to the WIP rejoin code Build 218 and 240.

     
  13. Denstjiro

    Denstjiro Registered

    Joined:
    Oct 6, 2010
    Messages:
    2,952
    Likes Received:
    13
    Oh ok fair enough Tim, thx for the response.

    Difficult to keep up with everything :p
     

Share This Page