Build 118 rilasciata

Discussion in 'rFactor 2 General discussion (Discussioni)' started by Max Angelo, Oct 20, 2012.

  1. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Jeremy sta sistemando in questi minuti l'auto update (che per la prima volta funzionerà come da disegno, ovvero senza interventi manuali).
    In pratica sarà solo necessario essere loggati al launcher, andare nella tab Update e cliccare sull'icona Automatic Update.

    In torrent è disponibile la versione Full, e la versione completa scaricabile via HTML sarà pronta nel giro di due o tre giorni.

    Change Log


    UPDATE 8 (Build 118) Changelog (October 19, 2012):
    ======================================


    GRAPHICS:
    —————————
    Fixed a bug with inconsistent shadow detail between channels in multiview
    Added 3 levels of shadow filtering speed vs quality
    Enhanced autodetail framerate processing to better maintain minimum FPS
    Added auto detection of multiGPU setups to improve some processing and support more than 2 GPU
    Fixed a quadgrid culling bug
    Fixed bug with pendulum texture animations
    Bloom is now working properly with multiview
    Different texture detail levels between player and opponents now (almost) works
    FPS counter now shows yellow when frame rate is being regulated
    Attempt to fix 'left-behind-shadows' problem
    Separated auto detail processing from visible vehicles processing
    Limit auto-detail FPS option to the current refresh rate
    Selecting multiview now works; changed widescreen HUD to only stick if Apply button is pressed, just to be consistent with the rest of the settings on that page.
    Sync shadow groups between views in multiview
    Added code to visible vehicles calculation to maintain minimum framerate.
    Improved multiGPU awareness of HDR processing


    GAMEPLAY:
    —————————-
    Corrected code to always use track GDB SettingsFolder override
    Setting session starting times default to 9am
    Changed default steering help from low to off because it confused a lot of people
    Re-enabled transparent trainer and added some options for it.


    PHYSICS:
    —————————-
    Added code to allow RealRoad to be pre-conditioned in a number of ways
    Moved some real road computations into road shader
    Fixed typo that prevented the middle turbo dump sample from playing
    Improved turbo dump
    Added minor effect of turbo spool friction
    Fixed a small problem with auto reverse


    AI:
    —————————-
    Attempts to get the fuel-less AI to slowly pull off the road.


    UI / HUD:
    —————————-
    Fixed bug on skin spinner where sometimes the skin listed wouldn't match the skin displayed in showroom
    Fixed statbar car position map to correctly scale with screen/hud resolution.
    Now checking livery availability on vehicle change to make sure it's valid....clearing out the playerfile value if it is not found.
    Eliminated more conditions where the player vehicle gets incorrectly set to Pace car.
    More UI stuff for RealRoad loading/saving
    Minor fix to info display on Video Res page
    Scaled text on mouseless spinners to correct value based on screen res and res of options.
    Added ability to add boost gauges to cockpit and HUD.


    BUG FIXES:
    —————————-
    Fixed crash in multiplayer
    Fixed some memory/resource leaks
    Fixed crash when changing tire compounds in pitstop
    Small optimization with regards to buffering data between simulation & multimedia threads


    MULTIPLAYER:
    —————————-
    Added dedi server RealRoad options
    Fix occasional flash of opponent vehicles in wrong spot during heavy multiplayer races
    Fixed a glitch that caused it to confirm you closing the dedicated server when clicking the window manager close button at the final window


    CONTROLLER/FFB:
    ----------------------------
    Enabled and expanded Fanatec support. We can now set the steering wheel angle to match the vehicle, as long as the wheel isn't using a preset. Note that these wheels must be connected and turned on before rF2 is started in order for specific features to be supported.
    Removed double initialization of controllers. It's still a mystery why force feedback is occasionally lost, and the lack of error codes returned by drivers doesn't help much (this applies to all manufacturers ... please return error codes if the force feedback isn't working).
    "Reset FFB" control now also resets steering wheel range, which also gets changed occasionally for no apparent reason.
    Now automatically holding clutch and brakes on grid for people using a combined axis for throttle & brakes (this feature was already available for people using auto-shifting). This Feature activates *if* Auto Clutch is enabled as well as "Hold Clutch On Start" and "Hold Brake" in the controller.ini file.


    PLUGINS:
    ----------------------------
    Completed custom plugin control (this invalidates old Version05 plugins)
    A little bit more robustness with respect to saving and restoring custom plugin control mappings


    REPLAYS:
    ----------------------------
    Fixed issue where transparent trainer would flicker in replay; note that this changes the replay format


    MODDING / PUBLIC DEV
    ----------------------------
    Fixed bug with render target selection for all 3DS Max plugin versions
    Added a new default method for generating normal map tangent basis. original method (meshmender) is still available as an option.
    Added _v25 to the names of all plugin dlls
    First release of scene viewer, located in ModMgr directory
    Fixed some problem with component Install/Uninstall in mas2 packaging tool
    Updated modmaker doc to sync with latest tools
    Added CG visualizer to Ctrl-U dev tool
    Added support for RealRoad file reading in viewer


    Qui il link per il download
    http://isiforums.net/f/showthread.php/1396-Downloads

    Qui il link al thread internazionale per la discussione

    http://isiforums.net/f/showthread.php/8184-Build-118-Released

    Nota - non è escluso che il server dell'auto update possa crashare, ma un test sul sistema di auto update è gradito. :)
    Nei builds interni (con traffico molto limitato ovviamente) il sistema funzionava perfettamente, ma il server andrebbe testato anche con più traffico.
     
  2. Mauro

    Mauro Registered

    Joined:
    Oct 14, 2011
    Messages:
    1,959
    Likes Received:
    3,296
    sto aggiornando
     
  3. ~IsR~Barabba

    ~IsR~Barabba Registered

    Joined:
    Oct 6, 2010
    Messages:
    1,160
    Likes Received:
    40
    Installato dal Automatic Update tutto ok
    Pero Il server appena installato con La Full 118,quando l'ho chiuso,ha dato ancora il problema del runtime.


    Babs:)
     
  4. Mauro

    Mauro Registered

    Joined:
    Oct 14, 2011
    Messages:
    1,959
    Likes Received:
    3,296
    ho interrotto l'autoupdate (molto lento in questo momento) e sto facendo il manuale.
     
  5. Eternum

    Eternum Registered

    Joined:
    Jan 9, 2012
    Messages:
    125
    Likes Received:
    0
    Installato aggiornamento come le altre build, ma una volta avviato il Launcher non parte l'offline e nemmeno online!
     
  6. Antiogre

    Antiogre Registered

    Joined:
    Jul 24, 2012
    Messages:
    69
    Likes Received:
    0
    Il mio funziona alla perfezione
     
    Last edited by a moderator: Oct 20, 2012
  7. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Cioè le icone nel launcher sono grigie?

    Prova a riattivare, cmq è un problema abbastanza strano.
    Se riattivare non risolve, riposta. :)
     
  8. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Beh, il problema è stato segnalato ... probabilmente non viene considerato un fix urgente perchè relativo solo al comando di chiusura.
     
  9. Eternum

    Eternum Registered

    Joined:
    Jan 9, 2012
    Messages:
    125
    Likes Received:
    0
    Ho risolto!
    La 118 è incompatibile con il rF2PedalOverlay Plugin, tolte le dll è tornato a funzionare! ;)
     
  10. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Ah si, infatti! :)

    I vecchi plugin sono diventati incompatibili.
     
  11. Taranta

    Taranta Registered

    Joined:
    Oct 5, 2010
    Messages:
    92
    Likes Received:
    5
    Vedo le piste con solo l'asfalto e le colline ????????
     
  12. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Tutte le piste?

    Come hai aggiornato, con l'auto update o con torrent?
    E se con torrent, la Full o l'aggiornamento?

    A naso direi un problema causato da un aggiornamento non riuscito bene.
     
  13. Zizza

    Zizza Registered

    Joined:
    Jan 10, 2012
    Messages:
    431
    Likes Received:
    11
    in aggiornamento..... moooolto lento....
     
  14. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Dunque, pochi punti che ho piacere di mettere in rilievo:

    1) il bug dei CTD nella pit lane dovrebbe essere fixato, test di massa dovrebbero confermare il buon funzionamento del fix

    2) la nuova opzione, nello schermo del controller, del "FFB smoothing" equivale al torque filter nel controller.ini.
    Il valore di default con un player nuovo, su tutte le periferiche Logitech, è "9".
    Diminuite questo valore solo se il rumore non vi da fastidio!

    3) nella cartella ModDev c'è la prima versione del Viewer

    4) è possibile regolare ReadRoad attraverso dei "preset" di funzionamento e salvare la condizione corrente
    I file di salvataggio sono in UserData/player/settings/nome_della_pista in formato *.rrbin

    5) il bug del basso livello grafico riportato qui
    http://isiforums.net/f/showthread.php/8148-grafica-differente-tra-online-e-offline
    dovrebbe essere fixato. Anche in questo caso test di massa per confermare il buon funzionamento dewl fix saranno certamente utili

    6) la ghost car dovrebbe funzionare di nuovo

    7) il bottone "Reset FFb" adesso resetta anche la rotazione

    8) i plugin version05 sono ora incompatibili ... è probabile che la versione attuale sia quella "gold" e che quindi per un bel po' la compatibilità rimarrà assicurata
     
  15. GTClub_wajdi

    GTClub_wajdi Registered

    Joined:
    Feb 28, 2012
    Messages:
    3,145
    Likes Received:
    485
    Mmmmmm...c'è qualcosa che nn quadra!
    Ho provato nei circuiti di feels3(Putnam Park e Croft)sembra che la strada sia bagnata,anzi una parte bagnata ed una parte asciugata e le textures della strada sembrano sparite quasi tutte:(nn ho riscontrato questa problema a Med-ohio ne a Spa ma una cosa strana che ho notato che la strada(l'asfalto)sembra piu scuro ed liscio come se anche li le textuers sembrano sparite!!
     
  16. GTClub_wajdi

    GTClub_wajdi Registered

    Joined:
    Feb 28, 2012
    Messages:
    3,145
    Likes Received:
    485
    Aggiungo:che anche riflessi sulla strada sembrano strane(da bagnato)!
    Sorry doppio post!
     
  17. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Beh, se è un problema localizzato nelle piste di feels3 sembrerebbe causato da qualcosa sul suo modo di creare i riflessi.

    Cmq ora provo anch'io.

    Per quanto riguarda le textures nelle piste ISI nelle ultime settimane ho girato solo sulla pista che verrà rilasciata prossimamente perchè i test interni sono stati concentrati su quella pista e sulla vettura in lavorazione, e poco fa ho caricato Monaco 1966 ... francamente non noto differenze nelle textures rispetto alla build 107, cmq già che lancio rF2 proverà a vedere anche questa cosa. :)
     
  18. GTClub_wajdi

    GTClub_wajdi Registered

    Joined:
    Feb 28, 2012
    Messages:
    3,145
    Likes Received:
    485
  19. Zizza

    Zizza Registered

    Joined:
    Jan 10, 2012
    Messages:
    431
    Likes Received:
    11
    mi sà che ci sono dei problemi con il server... non mi va oltre all'29% (barra sopra) e 11% barra sotto... provo con il 4° riavvio...
     
  20. GTClub_wajdi

    GTClub_wajdi Registered

    Joined:
    Feb 28, 2012
    Messages:
    3,145
    Likes Received:
    485
    Si anche a me si bloccava a 17%!ti consiglio di farlo manualmente dove ci ho messo 10min per scaricare i 160MB:)
     

Share This Page