Bug PIT STOP con tempo infinito

Discussion in 'rFactor 2 Support (Supporto Tecnico)' started by brook, Apr 8, 2014.

  1. brook

    brook Registered

    Joined:
    Dec 7, 2011
    Messages:
    198
    Likes Received:
    3
    Nella prima versione di rfactor era presente il fatidico bug che bloccava la macchina ai box in caso di pit stop senza possibilità di ripartire, facendo comparire come tempo previsto un numero pari a -2.140493843 o giù di li, non ricordo di preciso il numero.
    Pensavo che con rf2 questo bug fosse stato risolto definitivamente, invece con mio enorme stupore nei giorni scorsi on-line sia in pratica, sia in una gara ufficiale ad un altro concorrente, è riapparso questo baco.
    Prima di postare la cosa nel forum internazionale con tanto di screenshot, volevo sapere se a qualcuno era già successo e se per caso la cosa era in fase di valutazione da parte di ISI.

    grazie.
     
  2. Black75

    Black75 Registered

    Joined:
    Jan 9, 2012
    Messages:
    138
    Likes Received:
    0
    chiedo scusa ma per caso su rF1 era stato in qualche modo risolto e/o arginato?
     
  3. MMartin

    MMartin Registered

    Joined:
    Oct 30, 2010
    Messages:
    515
    Likes Received:
    3
    a me non è mai successo .... per ora...sgrat!
     
  4. Black75

    Black75 Registered

    Joined:
    Jan 9, 2012
    Messages:
    138
    Likes Received:
    0
    no ma a me nemmeno in realtà, ma è capitato a 4 piloti diversi in 2 gare distinte del ns Champ.... ma fin'ora credevo fosse un discorso legato a chissà cosa della mod in particolare, invece qui capisco che potrebbe essere un qualcosa nel core di entrambi (a questo punto) i simulatori ISI... scatenato da cosa non so, magari da qualche particolare combinazione hardware o software o, perchè no?, di tutto messo assieme :D
     
  5. brook

    brook Registered

    Joined:
    Dec 7, 2011
    Messages:
    198
    Likes Received:
    3
    no in rf1 non credo qualcuno sia riuscito a correggere la cosa, il fatto grave che il bug è presente anche in rf2, nel campionato dove partecipo si è già verificato un paio di volte, anche se raramente comunque, per ora su 5 gare con una media di 18 piloti a gara è successo 2 volte.
     
  6. Black75

    Black75 Registered

    Joined:
    Jan 9, 2012
    Messages:
    138
    Likes Received:
    0
    a questo punto devo riconsiderare (parlandone con gli altri ns admin) anche il "modo" di affrontare l'evento quando succede, perchè purtroppo abbiamo fermato la gara in corso, sulla base della convinzione di aver toccato qualcosa di troppo nella fisica della mod (capienza serbatoio ad esempio) e che in qualche modo i responsabili del "bug" (che cmq colpisce a random) fossimo noi che avevamo dato in mano all'utenza uno strumento non perfettametne funzionante.
    Grazie mille ragazzi, questo scambio di info è stato molto molto utile!!!! ;)
     
  7. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Sinceramente non ero a conoscenza di questo bug su rF, né tanto meno su rF2.

    Non si può escludere che sia un bug "di core" (lol, non sono romano e i sentimentalismi non c'entrano :) ), ma potrebbe essere anche qualcosa relativo alla vettura.

    Per provare a capire, la prima domanda è: vi è accaduto con vetture ISI o solo con vetture addon?
     
  8. brook

    brook Registered

    Joined:
    Dec 7, 2011
    Messages:
    198
    Likes Received:
    3
    Max, escludo che sia un problema relativo al mod o alla vettura, e tenderei a credere che come dici tu sia un problema intrinseco di core builder di rfactor.
    Il problema si verifica con rf1 e rf2 quando in qualsiasi momento si rientra ai box (quindi , pratica, qualifiche o gara), ed è noto credo un po' a tutti quelli che organizzano campionati, certo non posso dire con assoluta certezza che si verifica anche con mod non modificate isi, ma di certo capita con svariate mod.

    p.s. la cosa si puo' verificare sia se si gioca on-line che in locale.
     
  9. Black75

    Black75 Registered

    Joined:
    Jan 9, 2012
    Messages:
    138
    Likes Received:
    0
    Aggiungo qualche info su cosa stiamo combinando in merito.

    Parametri dei Pits sotto osservazione (lol) della fisica (mod F1AL-2014) nel momento in cui si sono verificati gli eventi:

    NumPitstopsRange=(0, 0, 0)
    NumPitstopsSetting=0
    Pitstop1Range=(1.0, 1.0, 0)
    Pitstop1Setting=49
    Pitstop2Range=(1.0, 1.0, 0)
    Pitstop2Setting=49
    Pitstop3Range=(1.0, 1.0, 0)
    Pitstop3Setting=49

    Parametri della fisica modificati che testeremo pomeriggio/sera durante una simulazione breve di gara:

    NumPitstopsRange=(0,1,2)
    NumPitstopsSetting=0
    Pitstop1Range=(0,0,0)
    Pitstop1Setting=0
    Pitstop2Range=(0,0,0)
    Pitstop2Setting=0

    Commento:
    Non trovo abbia senso tenere i parametri così com'erano dal momento che il refuel non è abilitato, in più credo sia errato il concetto di non dichiarare un range di Pit Stop e poi parametrizzarne addirittura 3.
    I valori che ho modificato (ma appunto non ancora testato), sono frutto del ragionamento che mi porta a credere che (e magari qui mi sbaglio) un range vada comunque indicato (non tutto a zero), che il successivo codice inerente al numero dei Pit Stop debba essere coerente con tale parametro (quindi per 0, 1, 2 settare massimo n° 2 Pit Stops) e semmai mettere a zero i valori inerenti al numero Pits dichiarati.
    Se avete l'impressione di avere a che fare con un pazzo scatenato... probabilmente avete ragione! ;)

    p.s. cmq Grazie mitico MaxAngelo per essere intervenuto pure tu nella discussione.
     
  10. brook

    brook Registered

    Joined:
    Dec 7, 2011
    Messages:
    198
    Likes Received:
    3
    No non sei un pazzo scatenato e grazie molte per le info, qualche prova su quei parametri li ho fatti anch'io. Il problema grosso è che il bug viene fuori casualmente, non in modo deterministico,quindi non è facile fare questi test, l'unica è tenere certi valori per un intero campionato e vedere se nell'arco del campionato si verifica o meno il bug.
     
  11. Black75

    Black75 Registered

    Joined:
    Jan 9, 2012
    Messages:
    138
    Likes Received:
    0
    :)

    figurati, mi spiace solo appunto che non posso scrivere qualcosa tipo "risolto! erano quelle le stringhe malefiche!" :cool:
    A questo punto (a meno che qualcuno nel frattempo non abbia altre novità in merito) direi che è il caso di aspettare (nel nostro caso) almeno 3 GP (un arco temporale di almeno un mesetto) prima magari di confermare un "ok raga, sapete, dopo la modifica non è successo più nulla", anche perchè come casistica al momento è stata pesantuccia, perchè 2 ritiri in entrambi i primi 2 GP (e parliamo di 4 piloti diversi) non è poco, quindi se non dovesse accadere altro per 3 GP di fila.... chissà! :D
    Sempre, ripeto, almeno che qualcuno nel frattempo non arrivi ad una determinazione diversa ;)
     
  12. brook

    brook Registered

    Joined:
    Dec 7, 2011
    Messages:
    198
    Likes Received:
    3
    Mi sembra che per ora sia l'unico modo per testare la cosa, io purtroppo per ora sono fermo e non sto correndo in alcun champ, comunque magari tu tienici aggiornati dopo ogni gara, se con quei parametri la cosa scompare.
     
  13. Black75

    Black75 Registered

    Joined:
    Jan 9, 2012
    Messages:
    138
    Likes Received:
    0
    ok, restiamo così allora... ;)
     
  14. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    La percentuale (immagino attorno al 10%) è decisamente troppo alta, ma questo aggiunge stranezza alla cosa, nel senso che con questi numeri dovrei essere a conoscenza del bug, mentre invece non ne ho mai sentito parlare, né in rF né in rF2.
    Diciamo, in rF non ho mai fatto l'admin, ma in 9 anni ho corso in svariate leghe.

    Posso riportare una testimonianza cmq: pochi giorni fa durante un test interno è capitato una volta che i distacchi a fine gara avessero valori assurdi, simili a quelli che avete scritto sopra.

    In questo caso è stato un altro bug a creare confusione, mandando in crisi il timing del server (praticamente aveva vinto un tester che poi dopo aver tagliato il traguardo ha fatto un burn out ripassando la linea di arrivo e venendo squalificato).
    Il server non ha capito bene la faccenda e ha risposto appunto riportando nel monitor dei distacchi assurdi.

    Voglio dire, potrebbe essere che anche nel vostro caso il problema sia solo l'effetto di una confusione causata da un altro fattore.

    Posso copiare le linee scritte sopra (sono nel file hdv?) e riportarle a ISI, chiedendogli se c'è qualcosa di sbagliato.

    A te brook con che mod succede?
     
  15. brook

    brook Registered

    Joined:
    Dec 7, 2011
    Messages:
    198
    Likes Received:
    3

    A noi è successo per ora un paio di volte su una mod privata di derivazione FORMULA ISI per quanto riguarda la fisica, ma comunque è sempre una mod derivata quindi, tra l'altro è successo su due circuiti diversi e sempre in gara (a me personalmente non mi è mai successo in gara, ma durante una sessione di pratica sono tornato ai box per continuare con gomme nuove e sono rimasto li, tra l'altro avevo anche fatto degli screenshot che dovrebbero essere sempre li nella dir del gioco), quindi chi è andato hai box per il cambio gomme o per la rottura dell'ala è rimasto li bloccato nella piazzola.
     
  16. Black75

    Black75 Registered

    Joined:
    Jan 9, 2012
    Messages:
    138
    Likes Received:
    0
    il test di stasera è saltato e credo che ci fermeremo un attimo col champ... purtroppo è ricapitato ancora prima che cominciassimo la prova anche con i valori sopracitati :(
     
  17. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Ho fatto adesso una ricerca nel forum con parole chiave "pit stop timing bug".

    http://isiforums.net/f/search.php?searchid=1041728&pp=

    Sette pagine di threads (di rF e rF2) che non ho letto interamente, ponendo l'attenzione solo sui threads con titolo che sarebbe potuto essere in topic con il vostro problema.

    Non sono riuscito a trovare niente di interessante ... magari la mia ricerca non aveva le parole chiave giuste, ma a naso se il problema fosse comune e nelle proporzioni che descrivete, qualcosa sarebbe saltato fuori.

    Insomma, c'è qualcosa che mi sfugge.

    Ormai è Venerdì e oggi ISI è concentrata su altre cose, ma Lunedì chiederò nel forum interno se qualcuno ha idee su cosa possa scatenare questo comportamento anomalo.
     
  18. Black75

    Black75 Registered

    Joined:
    Jan 9, 2012
    Messages:
    138
    Likes Received:
    0
    grazie mille Max!!!! ;)
     
  19. Matti1291

    Matti1291 Registered

    Joined:
    Mar 3, 2013
    Messages:
    110
    Likes Received:
    2
    NumPitstopsRange=(1, 1, 1)
    NumPitstopsSetting=1
    Pitstop1Range=(0.0, 0.0, 0)
    Pitstop1Setting=0

    Settato così funziona sempre, nessun caso di pit-stop infinito. Abbiamo risolto questo problema circa un anno e mezzo fa (per cui posso dire con certezza che funziona)...
     
  20. brook

    brook Registered

    Joined:
    Dec 7, 2011
    Messages:
    198
    Likes Received:
    3
    Ottimo Guglielmo (sei tu vero??) intanto modifico il mod e spero funzioni anche in rf2!!
     

Share This Page